+ Post New Thread
Page 4 of 4 FirstFirst 1234
Results 46 to 57 of 57
Network and Classroom Management Thread, Solution to stop people disconnecting network cables (Testers wanted please) in Technical; Tested here. Windows 7 x64 and works well. Only problem I had for the start was I had Virtualbox and ...
  1. #46

    Join Date
    Jun 2010
    Location
    England
    Posts
    735
    Thank Post
    89
    Thanked 52 Times in 46 Posts
    Rep Power
    35
    Tested here. Windows 7 x64 and works well. Only problem I had for the start was I had Virtualbox and VMWare Virtual Network Adapters enabled. After disabling these in device manager all worked fine.
    Nice work

  2. Thanks to ihaveaproblem from:

    Steve21 (18th April 2011)

  3. #47

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    16,038
    Thank Post
    888
    Thanked 1,727 Times in 1,490 Posts
    Blog Entries
    12
    Rep Power
    453
    Quote Originally Posted by Steve21 View Post
    Ah.

    Would you mind trying this version when you got a few minutes: Attachment 9954

    Should force update GPO at unlock. Not sure how fast it'll update them though, (Would help if I had some GPOs here to test lol)

    It's set to do computer and user, shouldn't cause any issues, but we'll see

    Thanks again

    Steve
    Been working on other things today. Will give it a test tomorrow and will report back.

  4. Thanks to FN-GM from:

    Steve21 (18th April 2011)

  5. #48

    EduTech's Avatar
    Join Date
    Aug 2007
    Location
    Reading
    Posts
    5,068
    Thank Post
    160
    Thanked 925 Times in 727 Posts
    Blog Entries
    3
    Rep Power
    273
    Quote Originally Posted by Steve21 View Post
    Awesome thanks, Out of curiosity did you use the copy on front page, or one few posts up? For some reason it won't let me edit first post, so can't update it.

    Steve
    It might be worth linking to an external source for the code so that you can update it there oppose to having it attached to the posts. there is a time limit you have when editing posts, so after a few days you won't be able to edit the post/thread in which you created.

    James.

  6. Thanks to EduTech from:

    Steve21 (18th April 2011)

  7. #49

    Steve21's Avatar
    Join Date
    Feb 2011
    Location
    Swindon
    Posts
    2,697
    Thank Post
    335
    Thanked 515 Times in 483 Posts
    Rep Power
    179
    Quote Originally Posted by ihaveaproblem View Post
    Tested here. Windows 7 x64 and works well. Only problem I had for the start was I had Virtualbox and VMWare Virtual Network Adapters enabled. After disabling these in device manager all worked fine.
    Nice work
    Awesome thanks. Yeah Virtual adaptors (same as hamachi etc), count as always connected even if the wire isn't plugged in, as "in bad terminology" the switch is on your computer, thus never disconnected. And as such the API for checking if network available returns true :P But yeah, I'm hoping (aka. assuming :P) that majority of networks won't be using virtual adaptors on student machines. (Else might have to look into making it ignore virtual ones)

    Quote Originally Posted by FN-GM View Post
    Been working on other things today. Will give it a test tomorrow and will report back.
    Thanks!

    Quote Originally Posted by EduTech View Post
    It might be worth linking to an external source for the code so that you can update it there oppose to having it attached to the posts. there is a time limit you have when editing posts, so after a few days you won't be able to edit the post/thread in which you created.

    James.
    Yeah certainly will have to try to get original page editted to say such :P Never realised it locks after a certain time, was going to update it constantly. Silly me hey!

    Thanks all,
    Steve

  8. #50

    EduTech's Avatar
    Join Date
    Aug 2007
    Location
    Reading
    Posts
    5,068
    Thank Post
    160
    Thanked 925 Times in 727 Posts
    Blog Entries
    3
    Rep Power
    273
    Quote Originally Posted by Steve21 View Post
    Yeah certainly will have to try to get original page editted to say such :P Never realised it locks after a certain time, was going to update it constantly. Silly me hey!
    Have a chat with Shaun / ZeroHour I am sure he will be able to sort it out for you.

    James

  9. Thanks to EduTech from:

    Steve21 (20th April 2011)

  10. #51

    DaveP's Avatar
    Join Date
    Oct 2006
    Location
    Can't talk now: The mother-ship is calling!
    Posts
    8,968
    Thank Post
    352
    Thanked 1,295 Times in 886 Posts
    Blog Entries
    4
    Rep Power
    1130
    I tried it yesterday on a Windows7 desktop logged on as a local user. It worked a treat. [EduLockv4]

    Any idea of time-scales/when the completed version will be released?

  11. Thanks to DaveP from:

    Steve21 (20th April 2011)

  12. #52

    Steve21's Avatar
    Join Date
    Feb 2011
    Location
    Swindon
    Posts
    2,697
    Thank Post
    335
    Thanked 515 Times in 483 Posts
    Rep Power
    179
    Quote Originally Posted by DaveP View Post
    I tried it yesterday on a Windows7 desktop logged on as a local user. It worked a treat. [EduLockv4]

    Any idea of time-scales/when the completed version will be released?
    Honestly, depends on two things.

    1) One I wanted a way to be able to set options network wide (aka making a registry link to it, so you "could" change options with GPOs etc if needed)
    2) If people turn on auto-unlock, as mentioned above you can effectively let computer boot unconnected, then reconnect without GPOs applied, and they wanted a way for it to force update

    I need to sort out #1 for sure, and #2 depends on if people are going to use autounlock or not really :P

    But shouldn't be far into future, assuming I get some time after work to finish it At least if I sort #1, I can finish #2 later, when I got more time to test.

    And thanks all who've been testing it, nice to get peoples feedback over something I may miss stupidly etc

    I'll get cracking on it in the evenings and try to get a complete version sorted.


    * Edit - Don't suppose anyone tested to see if my "GPO" quick-fix in v4 worked? (should refresh GPOs on unlock)

    Steve

  13. #53

    Join Date
    Jul 2009
    Posts
    273
    Thank Post
    6
    Thanked 43 Times in 37 Posts
    Rep Power
    16
    stev21 , thanks this is awesome, works and cant wait to get my hands on it without the button that allows you to exit

  14. Thanks to andydis from:

    Steve21 (20th April 2011)

  15. #54

    Steve21's Avatar
    Join Date
    Feb 2011
    Location
    Swindon
    Posts
    2,697
    Thank Post
    335
    Thanked 515 Times in 483 Posts
    Rep Power
    179
    Quote Originally Posted by andydis View Post
    stev21 , thanks this is awesome, works and cant wait to get my hands on it without the button that allows you to exit
    Ha yes indeed. Only reason I added that, was when I was testing things, I kept finding I made a bug and locked myself out of computer. And couldn't kill program as I disabled everything including taskmanager etc in original copy :P Thus the "HELP" button :P

    Will be removed once I sort the two issues mentioned!

    Steve

  16. #55

    Steve21's Avatar
    Join Date
    Feb 2011
    Location
    Swindon
    Posts
    2,697
    Thank Post
    335
    Thanked 515 Times in 483 Posts
    Rep Power
    179
    (If any mods around to lock this thread would be appreciated)

    Please forward any new requests/bugs etc to:

    http://www.edugeek.net/forums/networ...tml#post665415

    Thanks Steve

  17. #56

    Join Date
    May 2011
    Location
    Wales
    Posts
    15
    Thank Post
    7
    Thanked 4 Times in 4 Posts
    Rep Power
    7
    Seems like a pretty nifty idea but the only issue i can see is:
    if the server goes down, will all of the computers running the software be completely useless (as opposed to being almost completely useless as the user cant save to their documents or access the internet ect.)
    i also saw a post where a bloke was having problems with students disconnecting network cables on startup which stopped user policies from running and thus giving them more freedom to play games and stuff, so even if this software locks the screen, wouldnt the computer still keep running underneath the locked screen, and theyd be able to log in without seeing the logon screen and reconnect it once the computer is fully started and logged in?

  18. #57

    Steve21's Avatar
    Join Date
    Feb 2011
    Location
    Swindon
    Posts
    2,697
    Thank Post
    335
    Thanked 515 Times in 483 Posts
    Rep Power
    179
    Quote Originally Posted by geraintpowell View Post
    Seems like a pretty nifty idea but the only issue i can see is:
    if the server goes down, will all of the computers running the software be completely useless (as opposed to being almost completely useless as the user cant save to their documents or access the internet ect.)
    i also saw a post where a bloke was having problems with students disconnecting network cables on startup which stopped user policies from running and thus giving them more freedom to play games and stuff, so even if this software locks the screen, wouldnt the computer still keep running underneath the locked screen, and theyd be able to log in without seeing the logon screen and reconnect it once the computer is fully started and logged in?
    Please forward any new requests/bugs etc to:

    http://www.edugeek.net/forums/edulock/

    Thanks Steve


    (ps. answered you in new thread)
    Last edited by plexer; 6th May 2011 at 03:40 PM.

SHARE:
+ Post New Thread
Page 4 of 4 FirstFirst 1234

Similar Threads

  1. how to stop students pulling out network cables before policy loads
    By ict_support in forum Network and Classroom Management
    Replies: 10
    Last Post: 22nd April 2010, 04:31 PM
  2. Beta Testers Wanted
    By russdev in forum General Chat
    Replies: 12
    Last Post: 7th May 2008, 08:10 PM
  3. Beta Testers Wanted
    By ICTNUT in forum Group Project
    Replies: 6
    Last Post: 18th February 2007, 09:16 PM
  4. BETA Testers Wanted
    By russdev in forum General EduGeek News/Announcements
    Replies: 2
    Last Post: 7th April 2006, 09:46 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •