+ Post New Thread
Results 1 to 12 of 12
Network and Classroom Management Thread, iTALC 1.0.10 in Technical; There's finally a new release of iTALC classroom management and monitoring software out! I tried in vain last week to ...
  1. #1
    tutech's Avatar
    Join Date
    Aug 2010
    Location
    Boca Raton, FL
    Posts
    59
    Thank Post
    9
    Thanked 7 Times in 5 Posts
    Rep Power
    10

    iTALC 1.0.10

    There's finally a new release of iTALC classroom management and monitoring software out!

    I tried in vain last week to set this up in my computer lab. Every time that I install the master application on my teacher's computer it freezes up the mouse. When I hit Ctrl+Alt+Del to get to task manager, it is active then... but when I start task manager and get back to regular explorer, its frozen once again. Same deal with the clients that I tested as well. I love the program and the fact that it's free, but this is obviously a deal-breaker for me. I'm running XP Pro SP3 on all machines with all the latest windows updates, and USB keyboards and USB optical mice. All client machines are Dell Optiplex 740s and the master is an HP Compaq dc7800p. All machines are on the same subnet, members of the same Windows domain, all connected to the same Dell 100Mbit managed switch.

    Has anyone else encountered this with the 1.0.10 version and if so, have you been able to find a work-around for it?

    In the mean time, I am putting 1.0.9 back on until this is resolved.

  2. #2

    DaveP's Avatar
    Join Date
    Oct 2006
    Location
    Can't talk now: The mother-ship is calling!
    Posts
    8,791
    Thank Post
    351
    Thanked 1,274 Times in 870 Posts
    Blog Entries
    4
    Rep Power
    1126
    I found the same. See this post:

    Link: Italc 1.0.9

    The same thread has suggestions as to possible iTalc alternatives.

  3. #3

    Join Date
    Aug 2010
    Posts
    1
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Ditto

    Quote Originally Posted by tutech View Post
    There's finally a new release of iTALC classroom management and monitoring software out!

    I tried in vain last week to set this up in my computer lab. Every time that I install the master application on my teacher's computer it freezes up the mouse. When I hit Ctrl+Alt+Del to get to task manager, it is active then... but when I start task manager and get back to regular explorer, its frozen once again. Same deal with the clients that I tested as well. I love the program and the fact that it's free, but this is obviously a deal-breaker for me. I'm running XP Pro SP3 on all machines with all the latest windows updates, and USB keyboards and USB optical mice. All client machines are Dell Optiplex 740s and the master is an HP Compaq dc7800p. All machines are on the same subnet, members of the same Windows domain, all connected to the same Dell 100Mbit managed switch.

    Has anyone else encountered this with the 1.0.10 version and if so, have you been able to find a work-around for it?

    In the mean time, I am putting 1.0.9 back on until this is resolved.
    Same her dude

  4. #4

    Join Date
    Dec 2009
    Posts
    605
    Thank Post
    8
    Thanked 36 Times in 34 Posts
    Rep Power
    17
    are you sure you have the latest 1.0.10 ? i had this problem before with the original 1.0.10 he released
    Now it works fine .

    Having a problem with Multiple userlogon though , If i try and logon all the machines using italc the service crashes on all the machines and so does my italc client

  5. #5
    tutech's Avatar
    Join Date
    Aug 2010
    Location
    Boca Raton, FL
    Posts
    59
    Thank Post
    9
    Thanked 7 Times in 5 Posts
    Rep Power
    10
    I just looked and I see the last time the compiled version of 1.0.10 was updated on the sourceforge website was 7/28/10, and I did test out that version and it did what I described in my original post.

  6. #6

    Join Date
    Dec 2009
    Posts
    605
    Thank Post
    8
    Thanked 36 Times in 34 Posts
    Rep Power
    17
    Quote Originally Posted by tutech View Post
    I just looked and I see the last time the compiled version of 1.0.10 was updated on the sourceforge website was 7/28/10, and I did test out that version and it did what I described in my original post.
    i originally had the problem of my mouse freezing when i installed the OLD version of 1.0.10 , when setting up the Keys . Only when i got to the KEY stage. This problem was on my PC's in my old Job , so i assumed it could be a update installed on the Machine ?

    I have never had the teachers Software Crash , Only when trying to use the Multiple Logon Feature as Described above it gives me hassle !

  7. #7

    Join Date
    Aug 2010
    Location
    Stafforshire
    Posts
    6
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Don't you find that if you try and view more than 7 desktops the network dies?

    I have 20 systems plus the trainers = 21 I tested this on 10 systems and when I got to 7 desktop views it killed the network...

  8. #8
    tutech's Avatar
    Join Date
    Aug 2010
    Location
    Boca Raton, FL
    Posts
    59
    Thank Post
    9
    Thanked 7 Times in 5 Posts
    Rep Power
    10
    Quote Originally Posted by UKAndy View Post
    Don't you find that if you try and view more than 7 desktops the network dies?

    I have 20 systems plus the trainers = 21 I tested this on 10 systems and when I got to 7 desktop views it killed the network...
    I'm successfully using 1.0.9 on my one teacher computer and the 30 student computers in my computer lab without any network issues.

  9. #9

    Join Date
    Aug 2010
    Location
    Stafforshire
    Posts
    6
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Yes I successfully installed the app on 10 systems as a trial and all went well untill I began to view the students desktops, when I got to 6/7 the students noticed a bad lag with their systems and the mouse was slow responding, closed a few monitoring desktops down to 4 and the lag reduced.

  10. #10

    Join Date
    Oct 2005
    Location
    Bangkok
    Posts
    235
    Thank Post
    15
    Thanked 32 Times in 23 Posts
    Rep Power
    23
    if your running the master controller on a windows xp or vista machine then you should download and run this patch
    www.LvlLord.de - Tipps, Tricks & Utilities - Tools
    This enables desktop machines to handle more than 10 connections at once

  11. #11

    Join Date
    Aug 2010
    Location
    Stafforshire
    Posts
    6
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Hi Jose Sorry not got back to you sooner, I've been on holiday and was then tasked with other things.

    I reviewed you answer and have just gone to download the patch you gave ref to which has issues.

    http://picasaweb.google.com/lh/photo...eat=directlink

    I was wondering if you could advise on a solution.
    Last edited by UKAndy; 8th September 2010 at 06:12 AM.

  12. #12
    truslack's Avatar
    Join Date
    Jan 2009
    Posts
    75
    Thank Post
    11
    Thanked 9 Times in 9 Posts
    Rep Power
    13
    Italc 1.0.11 is now out - I think this bug is fixed.

SHARE:
+ Post New Thread

Similar Threads

  1. Italc
    By krisd32 in forum Network and Classroom Management
    Replies: 53
    Last Post: 31st May 2014, 05:18 AM
  2. ITALC problems
    By silver in forum Network and Classroom Management
    Replies: 37
    Last Post: 26th July 2011, 11:58 PM
  3. Italc 1.0.9
    By KoolTech in forum Network and Classroom Management
    Replies: 6
    Last Post: 17th August 2010, 04:56 PM
  4. iTalc
    By mikeglover in forum Windows
    Replies: 7
    Last Post: 6th November 2009, 09:03 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •