+ Post New Thread
Results 1 to 5 of 5
Network and Classroom Management Thread, RM Service Host Issue in Technical; Good afternoon, having got the rest of the system up this morning, we can't access the RMMC. Looking at Services, ...
  1. #1

    Join Date
    Sep 2012
    Posts
    144
    Thank Post
    17
    Thanked 22 Times in 19 Posts
    Rep Power
    8

    RM Service Host Issue

    Good afternoon,

    having got the rest of the system up this morning, we can't access the RMMC. Looking at Services, the RM Service Host hasn't started properly (even after restarts and looking at Tec1751186. Despite waiting to hear back from both the LEA service desk and RM (neither are being particularly fast) I was wondering if any of you wonderful people had come across this before, and if you did, how you got the system working again?

    I am getting the following message when attempting to start the process manually "Windows could not start the RM Service Host service on Local Computer. Error 1053: The service did not respond to the start or control request in a timely fashion."

    Any help would be greatly appreciated!

  2. #2

    Join Date
    Apr 2008
    Location
    Keighley, West Yorks
    Posts
    339
    Thank Post
    52
    Thanked 51 Times in 45 Posts
    Rep Power
    22
    Have a look on your FRDC at c:\Program Files\RM\Connect\CommsRM.Networks.Comms.ServiceHos t.Viewer.exe - that might give you an idea whether a sub-service is failing, and if so give you an idea what to look at?

    Peter

  3. #3

    Join Date
    Sep 2012
    Posts
    144
    Thank Post
    17
    Thanked 22 Times in 19 Posts
    Rep Power
    8
    Had a look at that soon after I had posted - program is visible under the processes in task manager on the forest root, but doesn't actually open, even with DNS stopped...

  4. #4

    Join Date
    Feb 2014
    Location
    South East London
    Posts
    39
    Thank Post
    8
    Thanked 5 Times in 5 Posts
    Rep Power
    2
    Restart the RM Connection Pool first, then the RM Dal Config Service.
    We've had quite a few issues with the Service Host, and this provides an almost immediate fix in most cases.

    The RMDCS restarts service host as part of it's restart anyway.

    Hope this helps.


    iForgot

  5. #5

    Join Date
    Sep 2012
    Posts
    144
    Thank Post
    17
    Thanked 22 Times in 19 Posts
    Rep Power
    8
    Tracked it down, the reason it wasn't working was RMConnect Postgres service was failing to start with the issue of bogus data in lock file postmaster.pid. renamed the file, restarted the service and it all worked again.

    Cheers for your help iForgot!

SHARE:
+ Post New Thread

Similar Threads

  1. CC4 Stuck installing update - "Stopping RM Service Host Service"
    By themanfromict in forum Network and Classroom Management
    Replies: 3
    Last Post: 22nd August 2014, 11:20 AM
  2. Scripts to restart RM Service host (CC4)
    By d-taylor in forum Scripts
    Replies: 8
    Last Post: 20th February 2013, 12:10 PM
  3. RM CC4 Rebuild Issues
    By Zaphod in forum Network and Classroom Management
    Replies: 2
    Last Post: 14th May 2010, 02:07 PM
  4. RM Connector (Install issues)
    By gpjt in forum Network and Classroom Management
    Replies: 4
    Last Post: 24th December 2009, 11:57 AM
  5. RM Service Release 5
    By CheeseDog in forum General Chat
    Replies: 2
    Last Post: 21st March 2006, 10:57 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •