+ Post New Thread
Results 1 to 3 of 3
Network and Classroom Management Thread, LDAP authentication to MRBS on linux in Technical; hi I am trying to authenticate mrbs with ldap on my machine having ubuntu-12.04. I have installed mrbs it's working ...
  1. #1

    Join Date
    Dec 2012
    Posts
    1
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    LDAP authentication to MRBS on linux

    hi
    I am trying to authenticate mrbs with ldap on my machine having ubuntu-12.04. I have installed mrbs it's working fine. Now I need to authenticate it with ldap. So I set-up ldap server on my machine.I added entries in config.inc.php from the documentation and previous post on ldap and mrbs. But which value should be given to $ldap_dn_search_attrib? As I'm working on linux machine i cannot give sAMAccountName so what value is to be given?
    $ldap_dn_search_attrib = "sAMAccountName"; #this is for Microsoft AD directories
    Here is my config.inc.php for ldap authentication

    $auth["session"] = "php";
    $auth["type"] = "ldap";
    $auth["realm"] = "mrbs";
    $ldap_host = "127.0.1.1";
    $ldap_port = 389;
    $ldap_v3 = true;
    $ldap_tls = false;
    $ldap_user_attrib = "uid";
    $ldap_dn_search_attrib = "sAMAccountName";
    $ldap_base_dn = "ou=2000,ou=students,ou=comp,dc=***,dc=org,dc=in";
    $ldap_dn_search_dn = "cn=admin,dc=***,dc=org,dc=in";
    $ldap_dn_search_password = "****";

    So please tell what modification are to be done in order to make it work. Also how to check the error when I try to login through ldap? I get the page Unknown user every time when I try to login with ldap. So I'm not able to get where exactly is the error?

  2. #2

    PICNIC's Avatar
    Join Date
    Oct 2010
    Location
    Zooniverse
    Posts
    292
    Thank Post
    186
    Thanked 84 Times in 45 Posts
    Rep Power
    109
    I can't answer your question, but cmorrison or John Berenek will be able to on the MRBS lists.

    mrbs-general@lists.sourceforge.net

    Jon

  3. #3


    Join Date
    Jan 2006
    Posts
    8,202
    Thank Post
    442
    Thanked 1,032 Times in 812 Posts
    Rep Power
    339
    $ldap_host = "127.0.1.1";
    the ldap host should be that of you domain controller, not the mrbs server.

    my working config:

    Code:
     $auth["type"] = "ldap";
    //# 'auth_ldap' configuration settings
     //# Where is the LDAP server
     $ldap_host = "192.168.0.5";
     //# If you have a non-standard LDAP port, you can define it here
    
     $ldap_port = 389;
     //# If you want to use LDAP v3, change the following to true
     $ldap_v3 = true;
     //# If you want to use TLS, change following to true
     $ldap_tls = false;
     //# LDAP base distinguish name
     //# See AUTHENTICATION for details of how check against multiple base dn's
     $ldap_base_dn = "ou=staff,dc=example,dc=college,dc=internal";
     $ldap_user_attrib = "uid";
     // If you need to search the directory to find the user's DN to bind
     // with, set the following to the attribute that holds the user's
     // "username". In Microsoft AD directories this is "sAMAccountName"
     $ldap_dn_search_attrib = "sAMAccountName";
    
     $ldap_dn_search_dn = "cn=LDAP,cn=Users,dc=example,dc=college,dc=internal";
     $ldap_dn_search_password = "xxxx";

SHARE:
+ Post New Thread

Similar Threads

  1. Replies: 2
    Last Post: 8th March 2012, 05:26 AM
  2. Replies: 6
    Last Post: 8th September 2010, 09:27 PM
  3. Replies: 0
    Last Post: 29th March 2010, 09:23 AM
  4. Replies: 1
    Last Post: 2nd March 2010, 10:23 AM
  5. Replies: 1
    Last Post: 6th October 2005, 01:49 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •