+ Post New Thread
Results 1 to 4 of 4
Netbooks, PDA and Phones Thread, Stop Automatic Connection to Open WiFi in Technical; My phone keeps picking up a BTOpenzone network when I'm in school, and I don't want it to. Anyone know ...
  1. #1
    enjay's Avatar
    Join Date
    Apr 2007
    Location
    Reading, Berkshire, UK
    Posts
    4,452
    Thank Post
    278
    Thanked 196 Times in 167 Posts
    Rep Power
    75

    Stop Automatic Connection to Open WiFi

    My phone keeps picking up a BTOpenzone network when I'm in school, and I don't want it to. Anyone know how to stop it automatically connecting to what it thinks are open networks?

    To save the questions, the reason I don't want to use the BTOpenzone are: 1) it doesn't take me to the logon page to enter BTOpenzone details, which means that I then can't use the Internet until I turn WiFi off, forcing the phone to use 3G instead, and then have to remember to turn WiFi back on again when I'm at home and 2) the signal strength is so weak that I get better service on 3G anyway.

    I've noticed this problem on other WiFi hotspots where you need to agree to terms of use (e.g. on the buses here), so I think it might be a bug in my phone/Android version/not using stock browser. Not a major problem, though.

    FWIW, the phone is an HTC Sensation running Android 2.3.4, stock browser plus Dolphin Browser HD (set as default).

  2. #2

    Join Date
    Apr 2007
    Location
    Birmingham
    Posts
    139
    Thank Post
    6
    Thanked 45 Times in 39 Posts
    Rep Power
    22
    Any chance you are on Vodafone? Seems that their app automatically connects to BTOpenzone:

    Vodafone app > More > settings > Untick Enable BT Openzone.

    Otherwise, less of a fix, but have you tried https://play.google.com/store/apps/d...ab.Llama&hl=en.

    It use it on my S2 to, amongst other things, automatically switch off wifi at work and switch it back on again when i get home. It uses cell towers to determine your location so isn't that much of a battery drain.

    Doesn't help with the random hotspots, but could save having to remember to switch wifi on again.

  3. 3 Thanks to andy_b:

    aerospacemango (29th March 2012), enjay (29th March 2012), Jackd (29th March 2012)

  4. #3
    enjay's Avatar
    Join Date
    Apr 2007
    Location
    Reading, Berkshire, UK
    Posts
    4,452
    Thank Post
    278
    Thanked 196 Times in 167 Posts
    Rep Power
    75
    Quote Originally Posted by andy_b View Post
    Any chance you are on Vodafone? Seems that their app automatically connects to BTOpenzone:

    Vodafone app > More > settings > Untick Enable BT Openzone.
    Yes I am on Vodafone. I don't have that option in my MyVodafone app though.

    Quote Originally Posted by andy_b View Post
    Otherwise, less of a fix, but have you tried https://play.google.com/store/apps/d...ab.Llama&hl=en.

    It use it on my S2 to, amongst other things, automatically switch off wifi at work and switch it back on again when i get home. It uses cell towers to determine your location so isn't that much of a battery drain.
    Thanks. I use Juice Defender to do something similar, although that still tries to find WiFi periodically. I'll give Llama a try (it would be useful for Mrs Enjay too, as she turns her phone to silent in work and then forgets to turn it back again at home).

  5. #4

    aerospacemango's Avatar
    Join Date
    Apr 2010
    Location
    Northants
    Posts
    1,994
    Thank Post
    283
    Thanked 248 Times in 199 Posts
    Blog Entries
    2
    Rep Power
    294
    Quote Originally Posted by andy_b View Post
    Any chance you are on Vodafone? Seems that their app automatically connects to BTOpenzone:

    Vodafone app > More > settings > Untick Enable BT Openzone.

    Otherwise, less of a fix, but have you tried https://play.google.com/store/apps/d...ab.Llama&hl=en.

    It use it on my S2 to, amongst other things, automatically switch off wifi at work and switch it back on again when i get home. It uses cell towers to determine your location so isn't that much of a battery drain.

    Doesn't help with the random hotspots, but could save having to remember to switch wifi on again.
    Good call on Llama... Just installed so will give it a whirl....

    Fed up with my Galaxy connecting to BTFon when I walk in the door, as opposed to my home hub!

SHARE:
+ Post New Thread

Similar Threads

  1. Stop WIFI connecting to BT Open networks!
    By TechSupp in forum Windows 7
    Replies: 2
    Last Post: 2nd November 2011, 09:48 AM
  2. Replies: 1
    Last Post: 27th June 2011, 12:48 PM
  3. Laptop wont connect to wifi network
    By cjw1903 in forum Network and Classroom Management
    Replies: 11
    Last Post: 6th November 2009, 02:47 PM
  4. stopping unwanted connections to router
    By IA76 in forum Wireless Networks
    Replies: 1
    Last Post: 11th July 2008, 07:21 AM
  5. Replies: 1
    Last Post: 23rd January 2008, 09:47 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •