+ Post New Thread
Results 1 to 14 of 14
MIS Systems Thread, Active Users in Technical; hello all, does anyone know why the my solus update is seeing active users? i have rebooted / unshared S: ...
  1. #1
    mm3
    mm3 is offline

    Join Date
    Dec 2011
    Posts
    40
    Thank Post
    19
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Active Users

    hello all,

    does anyone know why the my solus update is seeing active users?

    i have rebooted / unshared S: / detached then reattached but it still see around 10 active users!

    Thanks

  2. #2

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    15,945
    Thank Post
    886
    Thanked 1,696 Times in 1,474 Posts
    Blog Entries
    12
    Rep Power
    447
    Do you have any third party apps that use some aspects of sims?

  3. Thanks to FN-GM from:

    mm3 (15th August 2012)

  4. #3
    mm3
    mm3 is offline

    Join Date
    Dec 2011
    Posts
    40
    Thank Post
    19
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Nope i have even tried building up a new server and same on a new SQL

  5. #4

    matt40k's Avatar
    Join Date
    Jun 2008
    Location
    Ipswich
    Posts
    4,407
    Thank Post
    368
    Thanked 639 Times in 521 Posts
    Rep Power
    158
    Bit dramatic deattaching the database, if it isn't a 3rd party app, then it's most like a machine that's been left switched on and logged into SIMS somewhere - basically the homepage will "ping" the database every few seconds for updates - this basically keeps an open connection with the database - SIMS is also pretty smart when it comes to drop outs too, so it could even auto-reconnect. If you've got SQL management studio installed, run sp_who2, it'll list all the connections to the SQL server, all the SIMS users will be prefix'd with the database name, normally sims_, it should also give you the blasted computer name too, why Capita couldn't have include it in SOLUS is beyond me - still SOLUS3 is the way forward.

  6. Thanks to matt40k from:

    mm3 (15th August 2012)

  7. #5
    mm3
    mm3 is offline

    Join Date
    Dec 2011
    Posts
    40
    Thank Post
    19
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    by using sp_who2 sql shows no connected users but solus claims a list of users still connected even if the servers nic is disabled!

    gotta love sims

  8. #6

    matt40k's Avatar
    Join Date
    Jun 2008
    Location
    Ipswich
    Posts
    4,407
    Thank Post
    368
    Thanked 639 Times in 521 Posts
    Rep Power
    158
    Can you still do the upgrade? If not, try with the /FORCEUPGRADE switch

    /FORCEUPGRADE - Used in conjunction with /SAUSER and /SAPASSWORD
    It will force off all users still logged in to the database before upgrading

  9. Thanks to matt40k from:

    mm3 (15th August 2012)

  10. #7
    mm3
    mm3 is offline

    Join Date
    Dec 2011
    Posts
    40
    Thank Post
    19
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Quote Originally Posted by matt40k View Post
    Can you still do the upgrade? If not, try with the /FORCEUPGRADE switch

    /FORCEUPGRADE - Used in conjunction with /SAUSER and /SAPASSWORD
    It will force off all users still logged in to the database before upgrading
    ahh never knew of this thanks

    i shall try this now!

  11. #8
    mm3
    mm3 is offline

    Join Date
    Dec 2011
    Posts
    40
    Thank Post
    19
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Still no luck "Sims Database upgrade tool" just keeps not responding then it restores the DB

  12. #9

    matt40k's Avatar
    Join Date
    Jun 2008
    Location
    Ipswich
    Posts
    4,407
    Thank Post
    368
    Thanked 639 Times in 521 Posts
    Rep Power
    158
    Often doesn't look like it's responding, does it actually roll back by its self? What does the dbupgrade log file say (it's in My Documents > My SIMS Documents)

  13. Thanks to matt40k from:

    mm3 (15th August 2012)

  14. #10
    mm3
    mm3 is offline

    Join Date
    Dec 2011
    Posts
    40
    Thank Post
    19
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Quote Originally Posted by matt40k View Post
    Often doesn't look like it's responding, does it actually roll back by its self? What does the dbupgrade log file say (it's in My Documents > My SIMS Documents)
    Hello,

    i just looked into the logs

    i will assume this is the issue

    he database restore failed because the following error occurred :

    Warning: Unable to create a login ([15401] Windows NT user or group 'SERVER\pxadmin' not found. Check the name again.)
    Warning: Unable to create a user ([15401] Windows NT user or group 'SERVER\pxadmin' not found. Check the name again.)
    Warning: Unable to assign a default database ([15151] Cannot alter the login 'SERVER\pxadmin', because it does not exist or you do not have permission.)
    ------- Info 14/08/2012 23:07 SERVER\Administrator ============================dbUpgrade Version 2.28.8.0============================
    ------- Info 14/08/2012 23:10 SERVER\Administrator ============================dbUpgrade Version 2.28.8.0============================
    ------- Info 14/08/2012 23:10 sa Login for: sa
    ------- Info 14/08/2012 23:10 sa Requested multiple upgrade file: S:\SIMS\Setups\6b4bbc47-c84a-4ad1-82c4-505fcc92c125\3.61.806 to 3.61.822 Upgrade.zip
    ------- Info 14/08/2012 23:10 sa Requested multiple upgrade file: S:\SIMS\Setups\6b4bbc47-c84a-4ad1-82c4-505fcc92c125\3.61.822 to 3.61.827 Upgrade.zip
    ------- Info 14/08/2012 23:10 sa Running dbUpgrade Version: 2.28.8.0
    ------- Info 14/08/2012 23:10 sa : SERVER
    ------- Info 14/08/2012 23:10 sa Database: SIMS
    ------- Info 14/08/2012 23:10 sa Attempting to Create Schedule User
    ------- Info 14/08/2012 23:10 sa Backup Started...
    ------- Info 14/08/2012 23:10 sa Creating backup:
    ------- Info 14/08/2012 23:11 SERVER\Administrator ============================dbUpgrade Version 2.28.8.0============================
    ------- Info 14/08/2012 23:12 sa Created backup: D:\Program Files\Microsoft SQL \MSSQL10_50.MSSQL\MSSQL\Backup\SIMS_cp361_mnw_2012 0814_231100.bak
    ------- Info 14/08/2012 23:12 sa Backup Completed
    ------- Info 14/08/2012 23:12 sa Database Login Revoked
    ------- Info 14/08/2012 23:12 sa Executing SQL Batch 3.61.806 to 3.61.822 Upgrade.zip
    ------- Info 14/08/2012 23:12 sa Error on: 3.61.806 to 3.61.822 Upgrade.zip, Detail: Arithmetic overflow error converting float to data type numeric.
    The statement has been terminated.
    ------- Info 14/08/2012 23:12 sa Upgrade Failed: Exception of type 'DBUpgrade.DatabaseUpgradeException' was thrown.
    ------- Info 14/08/2012 23:12 sa Attempting to restore...
    ------- Info 14/08/2012 23:13 sa Error during restore: Warning: Unable to create a login ([15401] Windows NT user or group 'SERVER\pxadmin' not found. Check the name again.)
    Warning: Unable to create a user ([15401] Windows NT user or group 'SERVER\pxadmin' not found. Check the name again.)
    Warning: Unable to assign a default database ([15151] Cannot alter the login 'SERVER\pxadmin', because it does not exist or you do not have permission.)
    ------- Info 14/08/2012 23:13 sa Error: A problem occured while trying to run the database upgrade script '3.61.806 to 3.61.822 Upgrade.zip: Your database could not be restored correctly and must be restored from an earlier backup.

    The error reported was
    Arithmetic overflow error converting float to data type numeric.
    The statement has been terminated.
    'SERVER\pxadmin' as far as im aware is from an old software we no longer use called partner exchange?

  15. #11

    matt40k's Avatar
    Join Date
    Jun 2008
    Location
    Ipswich
    Posts
    4,407
    Thank Post
    368
    Thanked 639 Times in 521 Posts
    Rep Power
    158
    Is this Summer release 4? I did see something similar that is resolved in release 4. But I would guess this is one for Capita. PX makes me twitch.

  16. #12
    meastaugh1's Avatar
    Join Date
    Jul 2006
    Location
    London/Hertfordshire
    Posts
    890
    Thank Post
    69
    Thanked 85 Times in 70 Posts
    Rep Power
    32
    Quote Originally Posted by mm3 View Post
    'SERVER\pxadmin' as far as im aware is from an old software we no longer use called partner exchange?
    Did you get a solution to this?

    I get a similar message whenever I try to attach our SIMS database, or dbupgrade tries to automatically restore the database after a failed upgrade. My message refers to an old local account on a previous SIMS db server, that was used for the Discover Group Transfer when Discover was first released. I can't find the user in the SIMS or Master db users/logins.

  17. #13

    matt40k's Avatar
    Join Date
    Jun 2008
    Location
    Ipswich
    Posts
    4,407
    Thank Post
    368
    Thanked 639 Times in 521 Posts
    Rep Power
    158
    Quote Originally Posted by meastaugh1 View Post
    Did you get a solution to this?

    I get a similar message whenever I try to attach our SIMS database, or dbupgrade tries to automatically restore the database after a failed upgrade. My message refers to an old local account on a previous SIMS db server, that was used for the Discover Group Transfer when Discover was first released. I can't find the user in the SIMS or Master db users/logins.
    That sounds slightly different. If you go into SIMS .net, then focus > system > manage users - are they listed.

  18. Thanks to matt40k from:

    meastaugh1 (21st August 2012)

  19. #14
    meastaugh1's Avatar
    Join Date
    Jul 2006
    Location
    London/Hertfordshire
    Posts
    890
    Thank Post
    69
    Thanked 85 Times in 70 Posts
    Rep Power
    32
    Quote Originally Posted by matt40k View Post
    That sounds slightly different. If you go into SIMS .net, then focus > system > manage users - are they listed.
    Thank you. I had previously run a quick search in the username field; when no results were returned I assumed that the user hadn't been created in SIMS, and just been assigned permission directly in SQL.
    Have now searched in the forename field, found user and marked inactive. Database now attaching without the warnings.

SHARE:
+ Post New Thread

Similar Threads

  1. Active User Manager will not create bulk home folders
    By brickwall53 in forum Windows Server 2008 R2
    Replies: 2
    Last Post: 21st February 2012, 03:58 PM
  2. Active User Manager
    By laserblazer in forum Windows Server 2000/2003
    Replies: 2
    Last Post: 21st February 2012, 03:49 PM
  3. Replies: 0
    Last Post: 21st February 2012, 03:41 PM
  4. Active Directory-Script for Creating Bulk Users
    By calapso in forum How do you do....it?
    Replies: 8
    Last Post: 14th January 2009, 06:32 PM
  5. Replies: 3
    Last Post: 16th November 2006, 09:55 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •