+ Post New Thread
Results 1 to 8 of 8
MIS Systems Thread, Gulp... in Technical; Just updated our serco cmis to 11.3 with census fix... first time i've done one solo. seems to have gone ...
  1. #1

    Oaktech's Avatar
    Join Date
    Jul 2011
    Location
    Bournemouth
    Posts
    2,806
    Thank Post
    774
    Thanked 547 Times in 427 Posts
    Rep Power
    260

    Gulp...

    Just updated our serco cmis to 11.3 with census fix... first time i've done one solo. seems to have gone OK, but only time (and the return of the schools data manager tomorrow morning) will tell...

    Gulp.

  2. #2

    sonofsanta's Avatar
    Join Date
    Dec 2009
    Location
    Lincolnshire, UK
    Posts
    4,954
    Thank Post
    862
    Thanked 1,444 Times in 991 Posts
    Blog Entries
    47
    Rep Power
    617
    As scary a prospect as it always is - and it does still scare me, with so much riding on it - most upgrades are actually fairly straightforward if you follow the checklist. You have enough backups to easily revert, and for the most part it's a) waiting for the database backup b) double clicking setup.exe c) waiting for the database validation. It's mostly just boring. I still hate doing ePortal though as that always finds a way to break that takes me at least an hour to put right.

    Best advice for Serco upgrades is wait as long as you possibly can. About a third to a half of the time there's a fix comes out after the update, although this time sadly the patch came too late for me this month and I had to go through the faff of it all twice

    Didn't the census need to be in by last Friday though?

  3. #3

    Oaktech's Avatar
    Join Date
    Jul 2011
    Location
    Bournemouth
    Posts
    2,806
    Thank Post
    774
    Thanked 547 Times in 427 Posts
    Rep Power
    260
    According to our data manager the census needs to be in on thursday (which, just to be helpful is also h&s audit day, so yay, happy happy joy working environment that day)

    we usually give it a calendar month, but this one can't wait, due to said census. Also, this particular upgrade did not include an eportal upgrade, but did include an ews export upgrade which no-one has ever seen before... i applied it between facility and doc store and so far no-one has jumped up and down about it not working, so fingers crossed all is well.

    Owen

  4. #4

    sonofsanta's Avatar
    Join Date
    Dec 2009
    Location
    Lincolnshire, UK
    Posts
    4,954
    Thank Post
    862
    Thanked 1,444 Times in 991 Posts
    Blog Entries
    47
    Rep Power
    617
    Quote Originally Posted by Oaktech View Post
    According to our data manager the census needs to be in on thursday (which, just to be helpful is also h&s audit day, so yay, happy happy joy working environment that day)

    we usually give it a calendar month, but this one can't wait, due to said census. Also, this particular upgrade did not include an eportal upgrade, but did include an ews export upgrade which no-one has ever seen before... i applied it between facility and doc store and so far no-one has jumped up and down about it not working, so fingers crossed all is well.

    Owen
    I hate to panic you, but... When I queried the date (so I knew the latest time to do the update) we were told by our LEA that the census was always the third Thursday in January, which was the 19th. Unless your authority runs differently, of course.

    11.3 build 30 had no ePortal update, but 11.3 itself did. The ExpEMS has been in since at least 9.2 nearly 2 years ago, which was the first one I did, but the SMS thing is new as of 11.2 back in September. I don't think installing extra things hurts - it's just adding a few extra files in to the folder, that'll just sit there if no-one uses that functionality.

    You ever looked at the date modified field in the install folder after an upgrade? It'll make you laugh when you see how old some of the core DLLs are.

  5. #5
    SkywOrca's Avatar
    Join Date
    Sep 2008
    Posts
    88
    Thank Post
    1
    Thanked 18 Times in 17 Posts
    Rep Power
    48
    We've just upgraded 350+ schools to the second 11.3 release last week (hopefully!), and have had very few reports of issues. We do write our own guidance notes, however, and the only occasions where schools have had problems have been where the notes weren't followed fully. Specifically this time around the system does not automatically validate the structure if you've already run the first 11.3 release. Our notes include a step to manually run the validation if the automatic step doesn't happen, and this has caught some schools out by causing some reports and filters to crash the system. I can't comment on the Serco upgrade guidance notes, but I do recommend that you bear this in mind for future upgrades.

    We've also had one report of a failed ePortal installation, which I believe was down to multiple installations on the same server - a "relatively" painless full uninstall and reinstall usually corrects this. You have to remember to run the uninstallers in the right order if you try this procedure however, there is an "uninstall.exe" file inside your ePortal folder, and an "Unwise.exe" file in the parent folder, you should run the inner "Uninstall.exe" first, followed by the "Unwise.exe", this should remove all the parts of your ePortal installation and allow you to perform a clean reinstall. If you have an installation in another location you should be OK to just delete these folders after you've run the uninstallers. The installation should then allow you to create one new completely clean installation. Obviously, you should take a backup copy of your configuration xml files, but DO NOT copy these files back over the top of the newly installed files. You should instead open the conf files and re-apply any configuration changes you've made on an individual conf setting basis.

    Upgrades can sometimes be messy affairs, but Facility is usually recoverable by just uninstalling and reinstalling, and you only need to do this once on the server. Indeed, for Admin the easiest reinstall solution is to just rename the Admin folder to Adminold and just rerun the installation, no need to run any uninstallation. This means you can still copy across any sundry other files (like ctf files, census summaries etc.) that might have been added by the office staff to the Admin folder.

  6. Thanks to SkywOrca from:

    michael2k6 (24th January 2012)

  7. #6
    SkywOrca's Avatar
    Join Date
    Sep 2008
    Posts
    88
    Thank Post
    1
    Thanked 18 Times in 17 Posts
    Rep Power
    48
    Quote Originally Posted by sonofsanta View Post
    You ever looked at the date modified field in the install folder after an upgrade? It'll make you laugh when you see how old some of the core DLLs are.
    In fairness to Serco, most of the really old dlls are common interface dlls that they don't need to update since they just "work". Don't fix it if it ain't broke!

    All the Serco written files are updated with each release, but I'd imagine that for a sizeable number of them this is purely to update the version numbers!

  8. Thanks to SkywOrca from:

    michael2k6 (24th January 2012)

  9. #7

    Oaktech's Avatar
    Join Date
    Jul 2011
    Location
    Bournemouth
    Posts
    2,806
    Thank Post
    774
    Thanked 547 Times in 427 Posts
    Rep Power
    260
    Quote Originally Posted by sonofsanta View Post
    I hate to panic you, but... When I queried the date (so I knew the latest time to do the update) we were told by our LEA that the census was always the third Thursday in January, which was the 19th. Unless your authority runs differently, of course.

    11.3 build 30 had no ePortal update, but 11.3 itself did. The ExpEMS has been in since at least 9.2 nearly 2 years ago, which was the first one I did, but the SMS thing is new as of 11.2 back in September. I don't think installing extra things hurts - it's just adding a few extra files in to the folder, that'll just sit there if no-one uses that functionality.

    You ever looked at the date modified field in the install folder after an upgrade? It'll make you laugh when you see how old some of the core DLLs are.
    I'm not paniced about that, it's not my head on the block if it's late! We have a systems data manager for that! We told them we usually waited to see if serco patched the update, Systems data told me that wasn't going to happen this time due to census, they told me when they wanted it installed, and i installed it.

    My old NM did the 11.3 upgrade and i've just done the 11.3 build 30. I'm intrigued by the expems thing, as i'm sure i've never seen it done before!

    I'm sure it would be less scary if i actually understood the software, but i don't use it, i just get the phone call when it breaks!

  10. #8

    Join Date
    Jun 2007
    Location
    Wakefield, West Yorkshire
    Posts
    625
    Thank Post
    96
    Thanked 130 Times in 101 Posts
    Rep Power
    67
    The ExpEMS module is a return which is required by some LA's, but not many, and I can't quire remember which off the top of my head - it won't do any harm having it installed, as said, it will just sit and not be used if it's not needed.

    Mic

  11. Thanks to michael2k6 from:

    john (24th January 2012)

SHARE:
+ Post New Thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •