+ Post New Thread
Results 1 to 6 of 6
MIS Systems Thread, [kind of SOLVED] Macro Errors - IndRepBaseTemplate.dot in Technical; Hi all, had this problem for a while now and it's really starting to wind me up. I use macros ...
  1. #1

    LosOjos's Avatar
    Join Date
    Dec 2009
    Location
    West Midlands
    Posts
    5,447
    Thank Post
    1,438
    Thanked 1,168 Times in 797 Posts
    Rep Power
    707

    [kind of SOLVED] Macro Errors - IndRepBaseTemplate.dot

    Hi all,

    had this problem for a while now and it's really starting to wind me up.

    I use macros in my Individual Report templates to help with formatting issues. This works beautifully when running reports from SIMS, however when you try to export them, you get random errors about base functionality missing a reference (for instance, I get an error saying a reference to a function is missing on the Left$() function). The actual reference that is missing is to IndRepBaseTemplate.dot

    In the past, this has been easily fixed by opening up the original individual report template. However, trying it out today (I believe it's the first time I've used it since the 7.140 update) this doesn't fix the issue.

    Has anybody else had this problem and do you know how to fix it? If I copy IndRepBaseTemplate.dot to the folder containing my XML's, it does solve the problem but also massively slows the script down as Word saves the template every time and requires Word to have focus. I'm really hoping there's a way of programatically removing the reference!


    EDIT: Sometimes just putting your frustration in to words helps! Removing references programatically worked, anybody else who's having this problem can find a solution here: http://support.microsoft.com/kb/308340
    Last edited by LosOjos; 25th November 2011 at 12:03 PM.

  2. #2

    LosOjos's Avatar
    Join Date
    Dec 2009
    Location
    West Midlands
    Posts
    5,447
    Thank Post
    1,438
    Thanked 1,168 Times in 797 Posts
    Rep Power
    707
    Well, now that method has randomly stopped working. I hate individual reports.

  3. #3

    vikpaw's Avatar
    Join Date
    Sep 2006
    Location
    Saudi Arabia
    Posts
    5,848
    Thank Post
    671
    Thanked 1,383 Times in 1,145 Posts
    Rep Power
    350
    Quote Originally Posted by LosOjos View Post
    Well, now that method has randomly stopped working. I hate individual reports.
    Sucks

  4. #4

    LosOjos's Avatar
    Join Date
    Dec 2009
    Location
    West Midlands
    Posts
    5,447
    Thank Post
    1,438
    Thanked 1,168 Times in 797 Posts
    Rep Power
    707
    Quote Originally Posted by vikpaw View Post
    Sucks
    Indeed. I understand the need for IndRepBaseTemplate (it contains the macros required for adding tags when editing templates), but surely there's a better way? Couldn't the reference be removed automatically by SIMs when you close the document? It's only needed for editing templates, not viewing them!

    Hell, I'd prefer to have a plain old Word Add-In that sits there all the time than this!

  5. #5

    vikpaw's Avatar
    Join Date
    Sep 2006
    Location
    Saudi Arabia
    Posts
    5,848
    Thank Post
    671
    Thanked 1,383 Times in 1,145 Posts
    Rep Power
    350
    I love the way the excel template, has a macro to call a text document (csv or whatever) that is opened then modified.. It's great. Bill Gates would turn in his grave

  6. #6

    LosOjos's Avatar
    Join Date
    Dec 2009
    Location
    West Midlands
    Posts
    5,447
    Thank Post
    1,438
    Thanked 1,168 Times in 797 Posts
    Rep Power
    707
    Quote Originally Posted by vikpaw View Post
    I love the way the excel template, has a macro to call a text document (csv or whatever) that is opened then modified.. It's great.
    These things are so frustrating!

    On the plus side, I have had a reply from Capita regarding my attendance filter problem. No solution yet, but it's progress!

    Quote Originally Posted by vikpaw View Post
    Bill Gates would turn in his grave
    Which is made all the creepier by the fact he's not dead!

SHARE:
+ Post New Thread

Similar Threads

  1. Kind of delegating control problem
    By Jamie_a in forum Windows
    Replies: 11
    Last Post: 24th July 2008, 05:08 PM
  2. Replies: 5
    Last Post: 11th July 2008, 02:43 PM
  3. No internet connectivity kind of
    By mudcow007 in forum Windows
    Replies: 4
    Last Post: 29th May 2007, 01:17 PM
  4. what kind of microsoft software licencing do you use
    By in forum How do you do....it?
    Replies: 6
    Last Post: 10th March 2007, 02:53 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •