+ Post New Thread
Results 1 to 7 of 7
MIS Systems Thread, Serco Facility / ePortal in Technical; So we're getting users saying that eportal is crashing. To be litteral for a moment, it clearly isn't, but it ...
  1. #1

    Join Date
    Jul 2006
    Location
    London
    Posts
    1,254
    Thank Post
    111
    Thanked 242 Times in 193 Posts
    Blog Entries
    1
    Rep Power
    74

    Serco Facility / ePortal

    So we're getting users saying that eportal is crashing. To be litteral for a moment, it clearly isn't, but it is next to impossible to get end users to differentiate between 'no error message, but your work vanishes', 'an in web app error, and your work is lost' 'internet explorer crashing and your work is lost' and 'website internal error and your work is lost'. Anyhow ePortal/Tomcat are clearly still running well from the perspective of most of my users.

    In general it seems their browser isn't crashing, so the next thing is to look at the connectivity logs on the server... Any way of turning on detailed logging in tomcat to see what might be going on?

    Cheers
    P.
    Last edited by psydii; 23rd November 2011 at 10:44 AM. Reason: typo

  2. #2

    Oaktech's Avatar
    Join Date
    Jul 2011
    Location
    Bournemouth
    Posts
    2,776
    Thank Post
    764
    Thanked 541 Times in 424 Posts
    Rep Power
    259
    we have this, it seems to go in spates, we will have people unable to take registers in the morning, we'll restart the apropriate services on the server and it will be stable for days, and then it'll become un relaible for a few days and we'll have to restart services every morning for the duration, and then it'll be fine for months. we've raised it with serco and they have essentially just told us to live with it!

  3. #3

    Join Date
    Nov 2009
    Location
    Rotherham
    Posts
    80
    Thank Post
    34
    Thanked 9 Times in 8 Posts
    Rep Power
    11
    I have setup a schedule task that resets the data Facility server service and the Facility Eportal every morning, can't find a true solution.. but this works.

  4. #4

    Join Date
    Jul 2006
    Location
    London
    Posts
    1,254
    Thank Post
    111
    Thanked 242 Times in 193 Posts
    Blog Entries
    1
    Rep Power
    74
    Hmm. We restart ePortal every night, since it only pulls information like on/off roll or addresses on startup. Which is a bit rubbish really.

    There is a Serco Document that recommends this as best practice. I think it is the Troubleshooting guide, which is only available on request/merit.

  5. #5

    john's Avatar
    Join Date
    Sep 2005
    Location
    London
    Posts
    10,513
    Thank Post
    1,493
    Thanked 1,050 Times in 919 Posts
    Rep Power
    302
    It has always been recommended for a long time to have a daily stop / start of the services behind ePortal and its still advisable as it gives it a nice clean slate for the day, however with newer releases things have improved and got better with time so its less required but still very much recommended

  6. #6

    Join Date
    Feb 2006
    Location
    Newport
    Posts
    80
    Thank Post
    23
    Thanked 3 Times in 3 Posts
    Rep Power
    19
    We had his happen for a long time until we upgraded our server from 4GB to 8GB RAM. The problem was worst when teachers were entering assessment data (reports to parents).

    I read somewhere that the version of Tomcat used has a memory leak. As others have posted the workaround is to schedule a restart of the ePortal services in the middle of the night.

  7. #7

    Join Date
    May 2008
    Location
    Kent
    Posts
    521
    Thank Post
    26
    Thanked 72 Times in 63 Posts
    Rep Power
    28
    As John says a scheduled stop and start of the services in the early hours has always been recommended.

SHARE:
+ Post New Thread

Similar Threads

  1. [ACS] Serco Facility & ePortal and Virtualisation in 2011
    By psydii in forum MIS Systems
    Replies: 8
    Last Post: 6th May 2011, 07:48 AM
  2. Quick ePortal question - Serco Facility
    By cheredenine in forum MIS Systems
    Replies: 0
    Last Post: 14th July 2008, 03:20 PM
  3. Facility ePortal data loss
    By DaveP in forum MIS Systems
    Replies: 2
    Last Post: 3rd May 2007, 04:23 PM
  4. Facility Eportal
    By _Bat_ in forum MIS Systems
    Replies: 12
    Last Post: 20th March 2007, 03:51 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •