+ Post New Thread
Page 3 of 4 FirstFirst 1234 LastLast
Results 31 to 45 of 47
MIS Systems Thread, Exams Organiser - "Automation Error" in Technical; Ding Ding Ding... that time of the year again! - - - Updated - - - Originally Posted by PhilNeal ...
  1. #31
    Sam_Brown's Avatar
    Join Date
    Sep 2009
    Location
    Northampton
    Posts
    574
    Thank Post
    97
    Thanked 40 Times in 38 Posts
    Rep Power
    18
    Ding Ding Ding... that time of the year again!

    - - - Updated - - -

    Quote Originally Posted by PhilNeal View Post
    I've asked someone to try to replicate this.
    How did that go?

  2. #32

    Join Date
    Sep 2006
    Location
    London
    Posts
    1,332
    Thank Post
    36
    Thanked 353 Times in 238 Posts
    Rep Power
    79
    It happens when someone is still logged into Exams. If I recall SOLUS3 fixes it.

  3. #33

    matt40k's Avatar
    Join Date
    Jun 2008
    Location
    Ipswich
    Posts
    4,433
    Thank Post
    368
    Thanked 646 Times in 528 Posts
    Rep Power
    159
    Nope, happens with SOLUS3 when someone is logged in.

    So SOLUS3 does an update, files are locked because the application is still open, so files get replace upon reboot, old version gets registered, then DLL vs reg'd COM version is different upon reboot. So you may find it works, then you reboot and it stops working.

  4. #34
    CAM
    CAM is offline

    CAM's Avatar
    Join Date
    Mar 2008
    Location
    Burgh Heath, Surrey
    Posts
    4,192
    Thank Post
    841
    Thanked 374 Times in 290 Posts
    Blog Entries
    60
    Rep Power
    284
    Quote Originally Posted by PhilNeal View Post
    It happens when someone is still logged into Exams. If I recall SOLUS3 fixes it.
    So is this only for the person suffering the error still being logged in to Exams whilst upgrading or is it if one person is logged into exams by leaving it on overnight and the upgrade kicks in, everyone gets hit? I've had automation error before even though I switch the machine off every night when SOLUS2 upgrades go live.

  5. #35
    zag
    zag is offline
    zag's Avatar
    Join Date
    Mar 2007
    Posts
    3,832
    Thank Post
    918
    Thanked 423 Times in 356 Posts
    Blog Entries
    12
    Rep Power
    88
    Quote Originally Posted by PhilNeal View Post
    It happens when someone is still logged into Exams. If I recall SOLUS3 fixes it.
    Nope Solus 3 does not fix it.

  6. #36

    matt40k's Avatar
    Join Date
    Jun 2008
    Location
    Ipswich
    Posts
    4,433
    Thank Post
    368
    Thanked 646 Times in 528 Posts
    Rep Power
    159
    SOLUS2 I thought was permissions - I remember seeing some regkey users need read\write permission to.

  7. #37

    Join Date
    Mar 2011
    Location
    East Sussex
    Posts
    88
    Thank Post
    51
    Thanked 14 Times in 9 Posts
    Rep Power
    10
    Had this issue yesterday after update, ran simsapplicationsetup.exe from the setup dir and it fixed it.

  8. #38

    Join Date
    Sep 2006
    Location
    London
    Posts
    1,332
    Thank Post
    36
    Thanked 353 Times in 238 Posts
    Rep Power
    79
    I've double checked with the team.

    The current solution with SOLUS3 is to re-apply the update to the machine once the user is out of exams as this should fix the issue. You can’t easily do that in SOLUS2.
    Ideally we would look to improve SOLUS3 to handle this further but a solution hasn’t been looked at for this yet.

  9. #39

    Join Date
    Jun 2011
    Location
    Hampshire
    Posts
    64
    Thank Post
    2
    Thanked 7 Times in 7 Posts
    Rep Power
    8
    I have the error since the upgrade was applied on Thursday. I had shut down Sims - and definitely didn't have exams open - in fact strangely the exams officers do NOT have the problem this time. And we are using Solus 3 too.

  10. #40
    zag
    zag is offline
    zag's Avatar
    Join Date
    Mar 2007
    Posts
    3,832
    Thank Post
    918
    Thanked 423 Times in 356 Posts
    Blog Entries
    12
    Rep Power
    88
    I just did ours and it seems to have worked this time.

    I did make sure our exams lady was out of Sims this time though.

  11. #41

    Join Date
    Jul 2012
    Location
    Spalding
    Posts
    7
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    We have always had 'automation error' after every single SIMS upgrade.
    I always get everyone out of SIMS, switch the database to SINGLE user so no one can try gaining access then apply the SIMS update, but still get the error.
    Only solution is to reinstall SIMS on the workstations using Exams.
    I contacted Capita and they say it doesnt happen to all schools and are unable to replicate the issue so only solution is to re-install.

  12. #42
    MrMat's Avatar
    Join Date
    Jul 2013
    Location
    Solihull
    Posts
    171
    Thank Post
    18
    Thanked 38 Times in 28 Posts
    Rep Power
    28
    Quote Originally Posted by ITGURU View Post
    We have always had 'automation error' after every single SIMS upgrade.
    I always get everyone out of SIMS, switch the database to SINGLE user so no one can try gaining access then apply the SIMS update, but still get the error.
    Only solution is to reinstall SIMS on the workstations using Exams.
    I contacted Capita and they say it doesnt happen to all schools and are unable to replicate the issue so only solution is to re-install.
    Yup we have the same issue but only with a few users at a couple of schools.

    A quick reinstall of SIMS using SIMSApplicationSetup.exe does the trick.

    I may be stating the obvious here but did you guys know you can run SIMSApplicationSetup and install using UNC path? i.e. just run the exe and when prompted, change the SIMS Local Destination Folder to "\\computer123\c$\Program Files\SIMS\SIMS .net". Saves you getting up, going to the machine, getting user to log off etc

  13. #43
    zag
    zag is offline
    zag's Avatar
    Join Date
    Mar 2007
    Posts
    3,832
    Thank Post
    918
    Thanked 423 Times in 356 Posts
    Blog Entries
    12
    Rep Power
    88
    @PhilNeal Is there any chance this can be fixed permanently? This bug is now 3 years old

    We've just got the same error again after the latest solus 3 Sims update.

    1.png

    Case Log 1408-3228913 if you need to educate support on how to fix it. They just told me to Run Sims as an administrator but thats not really a solution.

    Currently only a manual re-install will fix it.
    Last edited by zag; 5th September 2014 at 12:00 PM.

  14. #44

    Join Date
    Jul 2012
    Location
    Spalding
    Posts
    7
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Capita told me that there was no permanent fix as doesnt happen to all schools and unable to replicate the error.
    Such a poor excuse! Who wrote the software?! lol

    Quote Originally Posted by zag View Post
    @PhilNeal Is there any chance this can be fixed permanently? This bug is now 3 years old

    We've just got the same error again after the latest solus 3 Sims update.

    1.png

    Case Log 1408-3228913 if you need to educate support on how to fix it. They just told me to Run Sims as an administrator but thats not really a solution.

    Currently only a manual re-install will fix it.

  15. #45

    Join Date
    Sep 2006
    Location
    London
    Posts
    1,332
    Thank Post
    36
    Thanked 353 Times in 238 Posts
    Rep Power
    79
    @ITGURU/@Zag The ONLY way we have been able to replicate this error is when Exams is open when the upgrade is being applied. Re-applying the upgrade does solve this.
    SOLUS 3.8 expected November 2014 will be able to force closure of Exams and avoid the problem.

SHARE:
+ Post New Thread
Page 3 of 4 FirstFirst 1234 LastLast

Similar Threads

  1. Exams Organiser errors after every upgrade
    By Gatt in forum MIS Systems
    Replies: 30
    Last Post: 16th August 2013, 02:10 PM
  2. [SIMS] Exams Organiser - unlocking a result set
    By ctaylor in forum MIS Systems
    Replies: 2
    Last Post: 4th February 2011, 10:26 AM
  3. Replies: 2
    Last Post: 7th May 2010, 12:03 PM
  4. Replies: 3
    Last Post: 1st May 2008, 01:09 PM
  5. Replies: 2
    Last Post: 18th December 2007, 09:25 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •