+ Post New Thread
Results 1 to 10 of 10
MIS Systems Thread, connect.ini changes to a redirect somehow in Technical; Hi there I have a problem and have looked at a few threads but cannot tsee my problem listed. On ...
  1. #1

    Join Date
    Jun 2011
    Location
    UK
    Posts
    7
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    connect.ini changes to a redirect somehow

    Hi there
    I have a problem and have looked at a few threads but cannot tsee my problem listed. On our SQL 2008 server on which we have sims .net installed, I point the connect.ini to the database.
    This facilitates a number of automatic processes which run. They won't run if it redirects to a mapped drive.

    Some unknown process changes the connect.ini to include a redirect to a connect.ini on a mapped drive. Does anyone have any idea what the cause may be?

  2. #2

    vikpaw's Avatar
    Join Date
    Sep 2006
    Location
    Saudi Arabia
    Posts
    5,788
    Thank Post
    716
    Thanked 1,441 Times in 1,194 Posts
    Rep Power
    360
    Usually a connect.ini is held on the server in the SIMS share (often S: drive for normal users.)

    If you have the SIMS client installed on the server too, it will have a local connect.ini with a redirect pointing to the mapped drive (S: for instance). Then by going there and reading the S:\sims\connect.ini it will point to itself and do what it needs.

    Normal practise is for all clients to have a local connect.ini with a redirect to the mapped drive, so that any changes are made centrally.

    If you delete the local copy on next run, it should look for one and ask you to point to it. If you point to the mapped drive it will make a redirect. If you create a local one it will be a custom one.

    Don't know if that helps. Perhaps you are loooking at the local server copy not the shared one...? Is it affecting things? You could change / delete the local one, stored in "C:\program files\sims .net\ ..." or whereever it is. Just don't delete the one in the mapped drive area else all users pointing to it will fail.
    Last edited by vikpaw; 8th June 2011 at 01:41 PM. Reason: grammar/spelling check

  3. #3

    Join Date
    Jun 2011
    Location
    UK
    Posts
    7
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Thanks for your quick response Vikpaw. That is interesting what you say about the deletion and where you choose for the connect.ini location.
    I realise i did not state it in my original post, the connect.ini I have still exists, its just it inserts a redirect line into it.

    why would it do that if there was already a valid connect.ini?
    You are right - it resides in c:\program files\sims\sims .net - as we have the client installed on the server.
    I wonder is there a way to preserve it? I have tried setting it to read only but it still changes.

  4. #4

    Jawloms's Avatar
    Join Date
    Aug 2007
    Posts
    834
    Thank Post
    177
    Thanked 105 Times in 73 Posts
    Rep Power
    185
    I had similar issues with something like this once. I just made the connect.ini read only and the problem went away.

  5. #5

    Join Date
    Jun 2011
    Location
    UK
    Posts
    7
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Thanks Jawloms
    we have tried and the change still happens - I had thought about setting up a task to replace the connect.ini but I would rather get to the cause if I could.

  6. #6

    vikpaw's Avatar
    Join Date
    Sep 2006
    Location
    Saudi Arabia
    Posts
    5,788
    Thank Post
    716
    Thanked 1,441 Times in 1,194 Posts
    Rep Power
    360
    Odd that it overwrites the 'read only' file.

    Do you have any third party or automated systems? I'm presuming yes. Many of these rely on the connect.ini perhaps one of them updates it. I know a lot of systems don't like a mapped drive in there.

    We recently changed ours to redirect to a mapped drive whereas before it was redirecting to the share name and when i moved servers this was a pain.

    I have had a couple of users recently who despite having the S drive mapped, and accessible, cannot load sims as it complains about inability to access S:\connect.ini i think this is to do with the privileges of the user / account that made the mapping. There is a thread on that related to win7 installs somewhere.

    But anyway, i digress.

    An odd thing that may be relevant is once i had a situation where the connect.ini was requested, and seemed to work, but then after log off and another using going in it would ask for it again, so it was giving permission to access sims and reading the location but not actually saving the connect.ini due to permissions.

    What if you delete the local connect.ini and don't run sims. Whatever is injecting that line, will either fail, or create a new file with only redirect settings...? Perhaps the permissions / owner on that new file will tell you the culprit. More so if the systems have a service account.

    Just to confirm, you manually create the local connect.ini in this format right?...

    Code:
    [SIMSConnection]
    ServerName=servername\SIMS2008
    DatabaseName=sims
    Last edited by vikpaw; 8th June 2011 at 01:42 PM.

  7. #7

    vikpaw's Avatar
    Join Date
    Sep 2006
    Location
    Saudi Arabia
    Posts
    5,788
    Thank Post
    716
    Thanked 1,441 Times in 1,194 Posts
    Rep Power
    360
    I just had a thought.
    If you do script a replace of the connect.ini you might find another task running that was installed by a third party to inject this line of redirect in because it fixed some bugs with their software!
    Can you show us what the final borked connect.ini looks like. I presume running sims still works, it just isn't possible for the automation processes to use it...?

  8. #8

    Join Date
    Jun 2011
    Location
    UK
    Posts
    7
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Thanks Vikpaw
    the problem is that the redirect line appears and this stops my automated tasks.
    I have not a copy but it is usually like this:-
    [SIMSConnection]
    Redirect=S:\Sims
    ServerName=servername\SIMS2008
    DatabaseName=sims

    as regards the read only getting overwritten, it has to be some sort of system or local admin which has the rights to do that, but it seems to happen

  9. #9

    Join Date
    Apr 2010
    Location
    Cheshire
    Posts
    17
    Thank Post
    1
    Thanked 2 Times in 2 Posts
    Rep Power
    10
    If you chose to switch on the Redirect Service when SIMS was migrated to SQL 2008 it may be that causing the problem. To resolve this I would suggest stopping the SIMS2005 Instance and see if that helps.

  10. #10

    vikpaw's Avatar
    Join Date
    Sep 2006
    Location
    Saudi Arabia
    Posts
    5,788
    Thank Post
    716
    Thanked 1,441 Times in 1,194 Posts
    Rep Power
    360
    @janit might have it. if not, can you try the other things i suggested to try and track down who creates or overwrites the file based on permissions / modifications.

SHARE:
+ Post New Thread

Similar Threads

  1. [SIMS] SIMS error when using a Redirect Connect.ini
    By Rawns in forum MIS Systems
    Replies: 3
    Last Post: 31st January 2012, 08:22 PM
  2. [SIMS] SIMS.net and multiple connect.ini files
    By NortyUK in forum MIS Systems
    Replies: 23
    Last Post: 9th September 2011, 12:05 PM
  3. Replies: 6
    Last Post: 4th January 2011, 09:55 PM
  4. Replies: 1
    Last Post: 17th April 2008, 04:44 PM
  5. SIMS Connect.ini default location
    By PHolland in forum MIS Systems
    Replies: 8
    Last Post: 16th May 2007, 04:31 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •