+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 20
MIS Systems Thread, Migrated sims server but workstations can't connect in Technical; Hi I have moved our sims setup to a nice new server. I was given a nice little set of ...
  1. #1
    philjones2000's Avatar
    Join Date
    Mar 2006
    Location
    Pool, Cornwall
    Posts
    137
    Thank Post
    52
    Thanked 8 Times in 4 Posts
    Rep Power
    21

    Migrated sims server but workstations can't connect

    Hi

    I have moved our sims setup to a nice new server. I was given a nice little set of instructions from our support team and everything seemed to go well.

    Sims.net now runs fine from the server but on all the client workstations I get:

    SQL server does not exist or access denied : System.Data.SqlClient.SqlException

    Fault code: 4636-9321-1000


    After login.

    I've made sure the new S: drive points to the new server and that the new connect.ini is correct. I can ping the new server from the workstations. I've tried reinstalling sims on one and that didn't work. The mssql service is running on the server.

    The only fly in the ointment I can think of is that the server already had a sql database on it and I had to manually install the new sims database as a named instance- but this did go fine and like I say, the sims.net on the server is fine.

    Help!

    Phil

  2. #2

    Join Date
    Apr 2007
    Location
    NW1
    Posts
    38
    Thank Post
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0

    Re: Migrated sims server but workstations can't connect

    are you using the same IP as the original server? It might be worth checking HOSTS files etc or any DNS entry to ensure that the workstations are looking at the right destination. Was your ping test with server name or with ip? Ensure that server name resolves to correct IP.

  3. #3
    philjones2000's Avatar
    Join Date
    Mar 2006
    Location
    Pool, Cornwall
    Posts
    137
    Thank Post
    52
    Thanked 8 Times in 4 Posts
    Rep Power
    21

    Re: Migrated sims server but workstations can't connect

    Pinged with server name- resolves fine to the correct ip.

    Have also tried everything mentioned on the capita support document KB24764.

    It does seem like a connection problem but I'll be damned if I can see what it is. (firewall is disabled).

  4. #4

    Join Date
    Apr 2007
    Location
    NW1
    Posts
    38
    Thank Post
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0

    Re: Migrated sims server but workstations can't connect

    try switching off any firewall on the server as the named instance will probably listen on a different port.

    edit: just seen your other message. Hmm it might be worth seeing what port its running on anyways so it will be easier to investigate. You can check the service logs. For info see that KB.

  5. #5
    philjones2000's Avatar
    Join Date
    Mar 2006
    Location
    Pool, Cornwall
    Posts
    137
    Thank Post
    52
    Thanked 8 Times in 4 Posts
    Rep Power
    21

    Re: Migrated sims server but workstations can't connect

    It's listenening on port 1280

  6. #6

    Join Date
    Apr 2007
    Location
    NW1
    Posts
    38
    Thank Post
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0

    Re: Migrated sims server but workstations can't connect

    Although i'm fairly sure it won't work, can you just test changing the workstations local connect ini to:

    [SIMSConnection]
    ServerName=0.0.0.0\SIMS
    DatabaseName=SIMS

    Replace the 0's with the real server IP. Also can you double check that the connect ini in the servers sims.net client dir uses re-direct to s:\sims?

  7. #7

    Join Date
    Apr 2007
    Location
    NW1
    Posts
    38
    Thank Post
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0

    Re: Migrated sims server but workstations can't connect

    another thing to try is to load up MS excel and try and connect to the SIMS instance. This way we can see if its a sims problem or SQL. If you've not done this before then open excel and:

    data || Import External Data || Import Data.

    Click on New source. MS Sql server. Enter server name as SIMS1\SIMS or whatever the sims server and instance is. Use your sa user and pass for the login. It will then connect and try and browse the db's listed in that instance so select SIMS from there. If it lists all the tables then you probably dont have an SQL connection issue, more a problem with how the SIMS.net client wants to connect to it.

  8. #8
    BKGarry's Avatar
    Join Date
    Mar 2006
    Location
    Kent
    Posts
    930
    Thank Post
    94
    Thanked 120 Times in 97 Posts
    Rep Power
    47

    Re: Migrated sims server but workstations can't connect

    It could be the connect.ini in the S:\ drive, but also try the SIMS.ini located in c:\windows or c:\winnt

    we had these problems when we changed our server's name when we made it the new SIMS server,

  9. #9
    philjones2000's Avatar
    Join Date
    Mar 2006
    Location
    Pool, Cornwall
    Posts
    137
    Thank Post
    52
    Thanked 8 Times in 4 Posts
    Rep Power
    21

    Re: Migrated sims server but workstations can't connect

    Thanks everyone for the help.

    I can only think there was some sort of conflict between the sql databases on the server as I uninstalled them (unimportant ones any way just booking software for the school field) and reinstalled sims as the only sql database.

    Now works fine.

    Thanks

    Phil

  10. #10
    Mcshammer_dj's Avatar
    Join Date
    Feb 2007
    Location
    Portsmouth
    Posts
    944
    Thank Post
    35
    Thanked 165 Times in 133 Posts
    Rep Power
    94

    Re: Migrated sims server but workstations can't connect

    Did you have backup exec 11d on the server using SQL 2005? I have seen this cause a problem

  11. #11
    philjones2000's Avatar
    Join Date
    Mar 2006
    Location
    Pool, Cornwall
    Posts
    137
    Thank Post
    52
    Thanked 8 Times in 4 Posts
    Rep Power
    21

    Re: Migrated sims server but workstations can't connect

    No but I did have a booking software program (booking pro) that used a sql 2005 db.....

    Maybe something to this...

  12. #12
    zag
    zag is offline
    zag's Avatar
    Join Date
    Mar 2007
    Posts
    3,829
    Thank Post
    918
    Thanked 422 Times in 355 Posts
    Blog Entries
    12
    Rep Power
    88

    Re: Migrated sims server but workstations can't connect

    Yes it needs to be the only sql server on the machine, I had this problem also. Backupexec uses a sql server.

  13. #13

    Join Date
    May 2007
    Location
    North Yorkshire
    Posts
    11
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Re: Migrated sims server but workstations can't connect

    Phil,

    I want to do the same and move my SIMS to a new server. Is it possible for you to send me the info you mentioned on doing this. Greatly apprieciated if you could.

    Many thanks.

    Jason.

  14. #14
    philjones2000's Avatar
    Join Date
    Mar 2006
    Location
    Pool, Cornwall
    Posts
    137
    Thank Post
    52
    Thanked 8 Times in 4 Posts
    Rep Power
    21

    Re: Migrated sims server but workstations can't connect

    My sims support people sent me a booklet with the details- it was swgfl specific though I guess most of its the same- I can scan it and let you have a copy if you want it still tho?

  15. #15

    bossman's Avatar
    Join Date
    Nov 2005
    Location
    England
    Posts
    3,942
    Thank Post
    1,199
    Thanked 1,069 Times in 760 Posts
    Rep Power
    330

    Re: Migrated sims server but workstations can't connect

    Our Sims.ini has just this:

    [SIMSConnection]
    Redirect=S:\Sims

    Don't know if this will help just thought it might.

SHARE:
+ Post New Thread
Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 6
    Last Post: 11th July 2007, 03:32 PM
  2. SIMS Connect.ini default location
    By PHolland in forum MIS Systems
    Replies: 8
    Last Post: 16th May 2007, 04:31 PM
  3. Minium Specs for server and Workstations
    By Ste_Harve in forum Hardware
    Replies: 16
    Last Post: 19th January 2007, 10:12 AM
  4. ASP connect to SIMS database
    By ryan_powell in forum MIS Systems
    Replies: 1
    Last Post: 26th October 2006, 06:31 PM
  5. Workstations unable to connect to domain
    By richard in forum Wireless Networks
    Replies: 8
    Last Post: 8th September 2006, 08:54 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •