+ Post New Thread
Results 1 to 13 of 13
MIS Systems Thread, CMIS ePortal Single Sign-on in Technical; I am trying to setup LDAP Single Sign-on for ePortal. I have got the connection to Active Directory no problem ...
  1. #1

    Join Date
    Mar 2007
    Location
    Bradford
    Posts
    107
    Thank Post
    7
    Thanked 14 Times in 14 Posts
    Rep Power
    18

    CMIS ePortal Single Sign-on

    I am trying to setup LDAP Single Sign-on for ePortal. I have got the connection to Active Directory no problem and can see all the staff ePortal logins and the staff network User Accounts in the Single Sign On Logins table.

    When I select an ePortal username and try to link it to their AD login I get an error back:

    "Failed to implement changes. Error: LDAP user creation error: 16: No Such attribute"

    Anyone got any ideas?

    Mark Berry,
    Challenge College

  2. #2

    Join Date
    Jan 2007
    Location
    Birmingham
    Posts
    807
    Thank Post
    29
    Thanked 36 Times in 24 Posts
    Rep Power
    26

    Re: CMIS ePortal Single Sign-on

    Didnt realise there was an option for that... Where is it?
    How'd you even start to go with that.

  3. #3

    Join Date
    Jun 2005
    Location
    London, UK
    Posts
    115
    Thank Post
    0
    Thanked 3 Times in 3 Posts
    Rep Power
    21

    Re: CMIS ePortal Single Sign-on

    Same problem here. It *may* have been fixed in the latest build but I haven't tested it yet.

    (Incidentally, the Serco representative in the room with me is not aware of an issue.)

  4. #4

    Join Date
    Mar 2007
    Location
    Bradford
    Posts
    107
    Thank Post
    7
    Thanked 14 Times in 14 Posts
    Rep Power
    18

    Re: CMIS ePortal Single Sign-on

    If he is still there with you, can you tell him there is also an issue with the number of Active Directory user accounts it can handle. Pointing it at the OU which contains all user accounts (as we want all staff and students to access it) it falls over stating too many objects.

  5. #5

    Join Date
    Mar 2007
    Location
    Bradford
    Posts
    107
    Thank Post
    7
    Thanked 14 Times in 14 Posts
    Rep Power
    18

    Re: CMIS ePortal Single Sign-on

    Quote Originally Posted by Lee_K_81
    Didnt realise there was an option for that... Where is it?
    How'd you even start to go with that.
    It's within Facility Controller on the server. Last tab on "Server Settings" to setup connection.

    Then you need to look in "Login name table -> Single Sign ons" for setting up the user accounts.

  6. #6

    Join Date
    Jan 2007
    Location
    Birmingham
    Posts
    807
    Thank Post
    29
    Thanked 36 Times in 24 Posts
    Rep Power
    26

    Re: CMIS ePortal Single Sign-on

    ah, thanks for that. Might have a go at that over the summer.

  7. #7
    budgester's Avatar
    Join Date
    Jan 2006
    Location
    Enfield, Middlesex
    Posts
    486
    Thank Post
    4
    Thanked 37 Times in 30 Posts
    Rep Power
    24

    Re: CMIS ePortal Single Sign-on

    I can confirm, trying to connect to a RM CC3 active directory.

    "Failed to implement changes. Error: LDAP user creation error: 16: No Such attribute"

    I initially tried configuring with student and teacher accounts, and got the error about to many accounts (over 1000), but this error goes away when I only try staff (less than 200 accounts).

    Regards

    Martin

  8. #8
    tosca925's Avatar
    Join Date
    Aug 2005
    Location
    Midlands
    Posts
    1,547
    Thank Post
    4
    Thanked 4 Times in 4 Posts
    Rep Power
    22

    Re: CMIS ePortal Single Sign-on

    It's within Facility Controller on the server. Last tab on "Server Settings" to setup connection.

    Then you need to look in "Login name table -> Single Sign ons" for setting up the user accounts
    I cant find this on our server, is it a paid for add on?

  9. #9

    Join Date
    Jan 2007
    Location
    Birmingham
    Posts
    807
    Thank Post
    29
    Thanked 36 Times in 24 Posts
    Rep Power
    26

    Re: CMIS ePortal Single Sign-on

    Quote Originally Posted by tosca925
    It's within Facility Controller on the server. Last tab on "Server Settings" to setup connection.

    Then you need to look in "Login name table -> Single Sign ons" for setting up the user accounts
    I cant find this on our server, is it a paid for add on?
    Where in midlands are you tosca925? we're a brummy school and it's on ours.

  10. #10
    tosca925's Avatar
    Join Date
    Aug 2005
    Location
    Midlands
    Posts
    1,547
    Thank Post
    4
    Thanked 4 Times in 4 Posts
    Rep Power
    22

    Re: CMIS ePortal Single Sign-on

    I launched the Admin.exe today and can't findit anywhere?

    Am i missing something?

  11. #11
    budgester's Avatar
    Join Date
    Jan 2006
    Location
    Enfield, Middlesex
    Posts
    486
    Thank Post
    4
    Thanked 37 Times in 30 Posts
    Rep Power
    24

    Re: CMIS ePortal Single Sign-on

    It's on the ePortal Data Controller

  12. #12

    Join Date
    Jan 2007
    Location
    Birmingham
    Posts
    807
    Thank Post
    29
    Thanked 36 Times in 24 Posts
    Rep Power
    26

    Re: CMIS ePortal Single Sign-on

    Quote Originally Posted by tosca925
    I launched the Admin.exe today and can't findit anywhere?

    Am i missing something?
    On your server where CMIS is installed, you should have the "facility data controller" open that.

  13. #13
    tosca925's Avatar
    Join Date
    Aug 2005
    Location
    Midlands
    Posts
    1,547
    Thank Post
    4
    Thanked 4 Times in 4 Posts
    Rep Power
    22

    Re: CMIS ePortal Single Sign-on

    Will check tomorrow.



SHARE:
+ Post New Thread

Similar Threads

  1. Moodle Single Sign On with CMS
    By monkeyx in forum Virtual Learning Platforms
    Replies: 0
    Last Post: 26th November 2007, 09:39 AM
  2. CMIS / EPortal Advice
    By stitch in forum MIS Systems
    Replies: 18
    Last Post: 9th October 2007, 10:27 PM
  3. ePortal / Facility / CMIS
    By daveyboy in forum MIS Systems
    Replies: 2
    Last Post: 9th October 2007, 08:13 PM
  4. ePortal and CC3 Single Sign On
    By budgester in forum MIS Systems
    Replies: 3
    Last Post: 21st June 2007, 11:26 AM
  5. Hel with CMIs/ePortal upgrade please.
    By tosca925 in forum Educational Software
    Replies: 5
    Last Post: 11th January 2006, 10:08 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •