+ Post New Thread
Results 1 to 9 of 9
MIS Systems Thread, SIMS Server query in Technical; Just want to check that my opinion on something is right. Our current server spec for SIMS is a Xeon ...
  1. #1
    Cache's Avatar
    Join Date
    Apr 2008
    Location
    Cumbria
    Posts
    1,223
    Thank Post
    454
    Thanked 177 Times in 174 Posts
    Blog Entries
    3
    Rep Power
    65

    SIMS Server query

    Just want to check that my opinion on something is right.

    Our current server spec for SIMS is a Xeon E5420 with 8GB RAM running Server and SQL 2008 x64.

    While idling at this current point in time (so no users except me), the Processor usage is 1%/2% and RAM usage is approx 6GB.

    SQL Database Size is 1.2GB, log file 4MB.

    The reason I'm asking is that when running an export using groupcall we currently have one report which is failing, while the report is running processor usage ranges between 10% and 35% and memory usage remains about 6.5GB.

    Would this suggest that the report is taxing the server in anyway or not? IMHO it's not, but just checking (only because of something fairly recently I'm starting to doubt myself)

    Thanks.
    Last edited by Cache; 20th January 2011 at 09:17 PM.

  2. #2

    vikpaw's Avatar
    Join Date
    Sep 2006
    Location
    Saudi Arabia
    Posts
    6,008
    Thank Post
    680
    Thanked 1,397 Times in 1,157 Posts
    Rep Power
    353
    Doesn't sound taxing. But perhaps when you run it in a live environment with other users, the usage may ramp up a bit. Does it still fail with no-one else on the system?

  3. Thanks to vikpaw from:

    Cache (21st January 2011)

  4. #3

    matt40k's Avatar
    Join Date
    Jun 2008
    Location
    Ipswich
    Posts
    4,429
    Thank Post
    368
    Thanked 643 Times in 525 Posts
    Rep Power
    159
    Does it give any errors? It could just be the report needs reimporting.

  5. Thanks to matt40k from:

    Cache (21st January 2011)

  6. #4

    glennda's Avatar
    Join Date
    Jun 2009
    Location
    Sussex
    Posts
    7,817
    Thank Post
    272
    Thanked 1,138 Times in 1,034 Posts
    Rep Power
    350
    Is this the latest version of groupcall exporter? With the older version i had real problems with it running reports and using all the ram that it could and then crashing (was pulling students photos in groups).

    also do you use the attendance graphs on the homepage for staff? and also when they display student information? as these are really badly written and as they auto refresh they tend to cause high load on the server and mean other things tend to crash while its happening.

  7. Thanks to glennda from:

    Cache (21st January 2011)

  8. #5
    Cache's Avatar
    Join Date
    Apr 2008
    Location
    Cumbria
    Posts
    1,223
    Thank Post
    454
    Thanked 177 Times in 174 Posts
    Blog Entries
    3
    Rep Power
    65
    The report was still failing even with me just logged onto the server (not even into SIMS) and after I'd disabled BackupExec and Sophos services to check they wern't causing problems.

    35 staff have just logged into SIMS now to do registers and what not, RAM usage still about 6.5GB, processor usage hasn't gone above 30% while I've been monitoring it, tends to hover about 10%.

    Groupcall said we are running the latest version of the exporter (was working fine before it updated and stopped immediately after the update now that I've looked through the log files)

    I'll fire the call back to groupcall and they can do more investigating then.

    Thanks
    Last edited by Cache; 21st January 2011 at 09:26 AM.

  9. #6
    Cache's Avatar
    Join Date
    Apr 2008
    Location
    Cumbria
    Posts
    1,223
    Thank Post
    454
    Thanked 177 Times in 174 Posts
    Blog Entries
    3
    Rep Power
    65
    It does have various SQL Strings and SIMS rept.def files all associated with it, although atm I've sent the call back across to Groupcall so a little reluctant to mess. Might move everything across to my test system and see if it works on there.

  10. #7
    Cache's Avatar
    Join Date
    Apr 2008
    Location
    Cumbria
    Posts
    1,223
    Thank Post
    454
    Thanked 177 Times in 174 Posts
    Blog Entries
    3
    Rep Power
    65
    As a quick update, last night I copied the database and DMS to my test virtual machine which I admit won't be upto any usable spec other then my individual testing, but the groupcall export failed with the exact same error which suggests to me that it is either something in our data or something wrong with the groupcall report (or am I jumping to far ahead?)

  11. #8

    vikpaw's Avatar
    Join Date
    Sep 2006
    Location
    Saudi Arabia
    Posts
    6,008
    Thank Post
    680
    Thanked 1,397 Times in 1,157 Posts
    Rep Power
    353
    No that's reasonable. It's most likely to do with their update, so let them deal with it for now.
    Sometimes for slow reports there is a patch from Capita (re-indexing) that can sometimes help, but i'd reckon if all other reports are okay, and this happened recently post upgrade then it's their issue.

    Is it a mission critical report? Can you replicate the report yourself in SIMS, make your own similar one and see if that works any better..?

  12. Thanks to vikpaw from:

    Cache (23rd January 2011)

  13. #9
    Cache's Avatar
    Join Date
    Apr 2008
    Location
    Cumbria
    Posts
    1,223
    Thank Post
    454
    Thanked 177 Times in 174 Posts
    Blog Entries
    3
    Rep Power
    65
    From what I understand, it's one that is supposed to pull the Linked Documents of a certain type out of SIMS and upload them for Parental Reporting so don't know of anyway of replicating the report (as I don't really understand how it's doing it).

    I'll maybe try Capita for the re-indexing patch Monday anyway so that I've ruled everything out my end. (although since they are stored in the DMS can't really see that making much difference either :/)

    Thanks
    Last edited by Cache; 23rd January 2011 at 02:35 PM.

SHARE:
+ Post New Thread

Similar Threads

  1. [SIMS] Query, SIMS and access to DB
    By dwhyte85 in forum MIS Systems
    Replies: 35
    Last Post: 5th October 2010, 03:25 PM
  2. SQL server hardware query
    By Hecate in forum Hardware
    Replies: 1
    Last Post: 15th March 2010, 11:13 AM
  3. setting up sims for fronter, and got a query
    By Simon_Gibbs in forum Virtual Learning Platforms
    Replies: 3
    Last Post: 19th May 2009, 03:10 PM
  4. Run LDAP query intranet server
    By ryan_powell in forum Web Development
    Replies: 4
    Last Post: 18th February 2008, 02:23 PM
  5. Exchange Server 2003 licensing query
    By tarquel in forum Windows
    Replies: 5
    Last Post: 4th July 2005, 01:56 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •