+ Post New Thread
Results 1 to 7 of 7
MIS Systems Thread, Incorrect Connect.ini file : SIMS.Processes.Exception when opening Exams Org [Solved] in Technical; Since upgrading our 2 SIMS terminal servers to Windows Server 2008 R2 staff with normal user accounts are unable to ...
  1. #1

    Join Date
    Apr 2007
    Location
    Croydon
    Posts
    504
    Thank Post
    18
    Thanked 31 Times in 30 Posts
    Rep Power
    22

    Incorrect Connect.ini file : SIMS.Processes.Exception when opening Exams Org [Solved]

    Since upgrading our 2 SIMS terminal servers to Windows Server 2008 R2 staff with normal user accounts are unable to run any of the "older modules" such as Exams Org on either of the servers. They get the error:

    Fault Code: 4257-7697-3000
    Incorrect Connect.ini file : SIMS.Processes.Exception


    They can load and use SIMS perfectly fine so I am cofused about what exactly is incorrect with connect.ini and when I log onto the server as an administrator everything works as expected - so some sort of permission issue, but what?!?!

    The connect.ini in the C:\Programs Files (x86)\SIMS\SIMS.net dir is set to redirect to the root of our mapped drive where the connect.ini exists with all the correct settings. Staff have been given modify rights on the whole C:\Programs Files (x86)\SIMS\SIMS.net folder and connect.ini on the mapped drive - still it doesn't work.

    Capita's suggestion was to uninstall SIMS and .NET Framework from the server and re-install which I have done and it's made no difference - oddly enough the SIMS Infrastrucure application did not appear in the "unistall a program" list.

    Any suggestions on how to get this working.

  2. #2

    Join Date
    Apr 2007
    Location
    Croydon
    Posts
    504
    Thank Post
    18
    Thanked 31 Times in 30 Posts
    Rep Power
    22
    Fixed! Turns out SIMS was looking for a copy of connect.ini in \\server\sims\WINDOWS, once i'd copied the connect.ini there it was happy. Then I discovered that it wasn't able to find the ExamsW.exe executable because it was looking in C:\Program Files\SIMS\SIMS.net but by default you are prompted to install SIMS in C:\Programs Files (x86)\SIMS\SIMS.net.

    Re-installed to C:\Program Files\SIMS\SIMS.net and it's happy again!

  3. Thanks to adamf from:

    OverWorked (23rd April 2014)

  4. #3

    vikpaw's Avatar
    Join Date
    Sep 2006
    Location
    Saudi Arabia
    Posts
    5,956
    Thank Post
    775
    Thanked 1,487 Times in 1,234 Posts
    Rep Power
    367
    not sure about the error, but in terms of permissions, do they also have control of the folders in the mapped drive (often S)?. the older modules have folders there and need write permissions, e.g exams, nova, options etc.

  5. #4

    vikpaw's Avatar
    Join Date
    Sep 2006
    Location
    Saudi Arabia
    Posts
    5,956
    Thank Post
    775
    Thanked 1,487 Times in 1,234 Posts
    Rep Power
    367
    Quote Originally Posted by adamf View Post
    Fixed! Turns out SIMS was looking for a copy of connect.ini in \\server\sims\WINDOWS, once i'd copied the connect.ini there it was happy. Then I discovered that it wasn't able to find the ExamsW.exe executable because it was looking in C:\Program Files\SIMS\SIMS.net but by default you are prompted to install SIMS in C:\Programs Files (x86)\SIMS\SIMS.net.

    Re-installed to C:\Program Files\SIMS\SIMS.net and it's happy again!
    ODD, at least you're sorted.

  6. #5

    bossman's Avatar
    Join Date
    Nov 2005
    Location
    England
    Posts
    4,035
    Thank Post
    1,262
    Thanked 1,107 Times in 785 Posts
    Rep Power
    338
    @adamf:

    Could I make a suggestion and place a copy of the connect.ini file in the root of the C:\Windows dir and see if this helps.

    Let me know how you get on.

    You have just beat me to it hehe!! well done!

  7. #6

    Join Date
    Apr 2007
    Location
    Croydon
    Posts
    504
    Thank Post
    18
    Thanked 31 Times in 30 Posts
    Rep Power
    22
    @bossman:

    It works if you put it in the C:\Windows also! Good shout!

  8. Thanks to adamf from:

    bossman (4th January 2011)

  9. #7

    bossman's Avatar
    Join Date
    Nov 2005
    Location
    England
    Posts
    4,035
    Thank Post
    1,262
    Thanked 1,107 Times in 785 Posts
    Rep Power
    338
    Quote Originally Posted by adamf View Post
    @bossman:

    It works if you put it in the C:\Windows also! Good shout!
    Little bit slow tonight you will have to forgive me as it has been a long holiday hehe!! (back to work tomorrow though)



SHARE:
+ Post New Thread

Similar Threads

  1. [SIMS] SIMS error when using a Redirect Connect.ini
    By Rawns in forum MIS Systems
    Replies: 3
    Last Post: 31st January 2012, 09:22 PM
  2. [SIMS] SIMS.net and multiple connect.ini files
    By NortyUK in forum MIS Systems
    Replies: 23
    Last Post: 9th September 2011, 01:05 PM
  3. Replies: 4
    Last Post: 13th July 2010, 02:27 PM
  4. Replies: 1
    Last Post: 17th April 2008, 05:44 PM
  5. SIMS Connect.ini default location
    By PHolland in forum MIS Systems
    Replies: 8
    Last Post: 16th May 2007, 05:31 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •