+ Post New Thread
Results 1 to 14 of 14
MIS Systems Thread, Urgent Help needed !! Can't logon to sims.net in Technical; Hi guys, We have been experiencing sims running very slow and was advised to run the indexing patch....Ran the patch ...
  1. #1

    Join Date
    Jun 2008
    Location
    Norwich
    Posts
    29
    Thank Post
    1
    Thanked 1 Time in 1 Post
    Rep Power
    0

    Urgent Help needed !! Can't logon to sims.net

    Hi guys,

    We have been experiencing sims running very slow and was advised to run the indexing patch....Ran the patch which never finished and received an error ( I don't know what the error was as I was never there to see it)

    Anyway we can no-longer login to sims with an error stating :-

    "unable to set application role"

    Any Ideas ???

    Thanks in advance

  2. #2


    Join Date
    Feb 2007
    Location
    Northamptonshire
    Posts
    4,689
    Thank Post
    352
    Thanked 794 Times in 714 Posts
    Rep Power
    346
    Can you restore a back up from before the patch and confirm all is OK?

  3. #3

    Join Date
    Jun 2008
    Location
    Norwich
    Posts
    29
    Thank Post
    1
    Thanked 1 Time in 1 Post
    Rep Power
    0
    I've never had to do a restore - just to check, can I simply copy the restored DB (to another location) then attach the db's?

  4. #4

    Join Date
    Jun 2008
    Location
    Norwich
    Posts
    29
    Thank Post
    1
    Thanked 1 Time in 1 Post
    Rep Power
    0
    OK....completed restore and everything ok

  5. #5
    rh91uk's Avatar
    Join Date
    Sep 2008
    Location
    UK
    Posts
    876
    Thank Post
    137
    Thanked 132 Times in 114 Posts
    Rep Power
    35
    I;d be interested to know why the patch knocked it out ... once you've contacted your LA support team could you let us know? What was the patch #?

  6. #6

    Join Date
    Jun 2008
    Location
    Norwich
    Posts
    29
    Thank Post
    1
    Thanked 1 Time in 1 Post
    Rep Power
    0
    It was the indexing patch - It was knocked out because users still had active connections in SQL (we use xenapp so although they may not connected, their session is still active within SQL) I still have one connection active who I can't seem to kick out ?

    Ran :-

    SELECT db_name(dbid) as DatabaseName, count(dbid) as NoOfConnections,
    loginame as LoginName
    FROM sys.sysprocesses
    WHERE dbid > 0
    GROUP BY dbid, loginame

    Shows active connections, I still have one on the sims DB ??

  7. #7
    rh91uk's Avatar
    Join Date
    Sep 2008
    Location
    UK
    Posts
    876
    Thank Post
    137
    Thanked 132 Times in 114 Posts
    Rep Power
    35
    Have you tried restarting the SQL service? Usually does the trick for us (but oh so dirty!)

  8. #8

    matt40k's Avatar
    Join Date
    Jun 2008
    Location
    Ipswich
    Posts
    4,392
    Thank Post
    368
    Thanked 637 Times in 519 Posts
    Rep Power
    158
    sp_who2 would be a quicker way to do it.

    Also dbattach with /restoreui at the end of the command would allow you to restore the backup it took prior to the patch. (should end \dbattach.exe" /restoreui)

    Guess I know what I'll be doing in the morning

  9. #9

    Join Date
    Jun 2008
    Location
    Norwich
    Posts
    29
    Thank Post
    1
    Thanked 1 Time in 1 Post
    Rep Power
    0
    PMSL....What you doing on here ;-D

    You have some emails in your inbox at work lol

    OK - so is that using dbattach

  10. #10

    matt40k's Avatar
    Join Date
    Jun 2008
    Location
    Ipswich
    Posts
    4,392
    Thank Post
    368
    Thanked 637 Times in 519 Posts
    Rep Power
    158
    I get around

    I know, problem with leaving at 4pm.

    sp_who2 in management studio.

  11. #11

    Join Date
    Jun 2008
    Location
    Norwich
    Posts
    29
    Thank Post
    1
    Thanked 1 Time in 1 Post
    Rep Power
    0
    No the restore ??

  12. #12

    Join Date
    Jun 2008
    Location
    Norwich
    Posts
    29
    Thank Post
    1
    Thanked 1 Time in 1 Post
    Rep Power
    0
    What time you back in - in the morning?

  13. #13

    matt40k's Avatar
    Join Date
    Jun 2008
    Location
    Ipswich
    Posts
    4,392
    Thank Post
    368
    Thanked 637 Times in 519 Posts
    Rep Power
    158
    Ah yes, dbattach /restoreui - restore those pesky .bak. Had a quick look at the reindex patch (6635) - it reindexes then runs a dbcc (checks the database) - hopefully it hasn't found anything!! But that would be why it didn't complete - cause it didn't complete it was left in single user mode, or more likely, it couldn't go into single user mode because "someone" was logged in. If it's the latter, dbattach must lock it in some "special" way.

    In at 8am.

  14. #14

    matt40k's Avatar
    Join Date
    Jun 2008
    Location
    Ipswich
    Posts
    4,392
    Thank Post
    368
    Thanked 637 Times in 519 Posts
    Rep Power
    158
    Before I forget... again.

    SIMS sets the database to single user mode, then to multi user mode (I think), then applies the patch. It appears the citrix users aren't being logged off, just disconnected, which leaves a open SIMS connection, because of the homepage widgets, every few secs they reconnect to SIMS database, it appears, they have grabbed the one and only open connection. Quick fix would be to logon to SQL Management Studio and set it back to multi user, cause dbattach\patch hasn't got a connection to set it back.

    Next question is, if it was applied as SA, would it be fine?

    Anyway, SMIS made a tool to lock out all the SIMS user logins (I'm not sure it works with trusted logins) which should solve the problem.

SHARE:
+ Post New Thread

Similar Threads

  1. Replies: 5
    Last Post: 1st July 2014, 08:34 AM
  2. Urgent Help Needed! (School Website)
    By pritchardavid in forum Windows Server 2008
    Replies: 14
    Last Post: 1st October 2010, 11:47 PM
  3. EXTREMELY URGENT HELP NEEDED!
    By pritchardavid in forum Windows Server 2008 R2
    Replies: 15
    Last Post: 18th May 2010, 11:04 AM
  4. Urgent Help needed!
    By The_GuRu in forum Network and Classroom Management
    Replies: 27
    Last Post: 20th February 2008, 09:20 AM
  5. Replies: 11
    Last Post: 6th September 2007, 07:10 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •