+ Post New Thread
Results 1 to 15 of 15
MIS Systems Thread, SIMS FMS permissions problems in Technical; We are running a RM CC3 network and I have followed all of the RM instructions to create a FMS ...
  1. #1
    MicrodigitUK's Avatar
    Join Date
    May 2007
    Location
    Wiltshire
    Posts
    332
    Thank Post
    37
    Thanked 54 Times in 50 Posts
    Rep Power
    24

    SIMS FMS permissions problems

    We are running a RM CC3 network and I have followed all of the RM instructions to create a FMS package

    For permissions “Management information users” have full write access to “C:\Program Files\SIMS\FMSSQL” and the users in question are members of the security group.

    But still I am getting an error when trying to create a new JV the following error message appears.

    ptJVHeader:Field"Voucher_id"not found.

    On the capita support .net the solution is the usual “Please ensure FMS users have local administrator access rights on the workstation FMS is being used”

    I really don’t want to take Capita’s advice and unlock the users to have full admin on the workstation!

    Dose anyone have any other specific locations that permissions need changing to make this work.

  2. #2

    Edu-IT's Avatar
    Join Date
    Nov 2007
    Posts
    7,121
    Thank Post
    403
    Thanked 619 Times in 566 Posts
    Rep Power
    180
    RM provide a script which does all the permissions for SIMS. Have you set this to run for each user?

  3. #3
    MicrodigitUK's Avatar
    Join Date
    May 2007
    Location
    Wiltshire
    Posts
    332
    Thank Post
    37
    Thanked 54 Times in 50 Posts
    Rep Power
    24
    Thanks I might have missed that one.

    I’ve had a look round RM support but can’t find it. Could you joust point me to the correct place?

  4. #4
    danrhodes's Avatar
    Join Date
    Sep 2008
    Location
    Wath Upon Dearne
    Posts
    1,513
    Thank Post
    157
    Thanked 181 Times in 150 Posts
    Rep Power
    67
    Could you not just use Simsperm.exe?

    We use the following in a cmd file.

    S:
    cd sims\setups
    simsperm DOMAIN\STAFFGROUP

  5. #5

    Edu-IT's Avatar
    Join Date
    Nov 2007
    Posts
    7,121
    Thank Post
    403
    Thanked 619 Times in 566 Posts
    Rep Power
    180
    DWN1567504 on RM Support Knowledgebase.
    It's the Set Environment.

  6. #6

    matt40k's Avatar
    Join Date
    Jun 2008
    Location
    Ipswich
    Posts
    4,387
    Thank Post
    368
    Thanked 637 Times in 519 Posts
    Rep Power
    158
    Logon as administrator, run FMS, run a report (can't remember which one), basically so you end up with c:\PDOXUSRS.NET, give the user full control of it.

  7. 2 Thanks to matt40k:

    MicrodigitUK (12th March 2010), speckytecky (26th March 2010)

  8. #7

    bossman's Avatar
    Join Date
    Nov 2005
    Location
    England
    Posts
    3,905
    Thank Post
    1,186
    Thanked 1,057 Times in 749 Posts
    Rep Power
    328
    @MicrodigitUK:

    How many users do you have using the FMS if I may ask?

  9. #8
    MicrodigitUK's Avatar
    Join Date
    May 2007
    Location
    Wiltshire
    Posts
    332
    Thank Post
    37
    Thanked 54 Times in 50 Posts
    Rep Power
    24
    Quote Originally Posted by bossman View Post
    @MicrodigitUK:

    How many users do you have using the FMS if I may ask?
    five

  10. #9
    MicrodigitUK's Avatar
    Join Date
    May 2007
    Location
    Wiltshire
    Posts
    332
    Thank Post
    37
    Thanked 54 Times in 50 Posts
    Rep Power
    24
    Quote Originally Posted by matt40k View Post
    Logon as administrator, run FMS, run a report (can't remember which one), basically so you end up with c:\PDOXUSRS.NET, give the user full control of it.
    This indeed was the solution. To add to that I did the following:

    1. Log on as an "administrator" open FMS and log in with a valid user

    2. Click on "Focas" in the top right.
    Then click "General Ledger"
    Click "Manual Journal Processing"

    3. In netx window click "+" to "Add a new record.
    Select "Cash Book"
    Click next

    4. On the next window.
    Enter "TEST" as the Narrative
    Click next

    5. On the next window.
    Click the magnefiing glass and select a bank account.
    Enter "TEST" as the reference
    Click next

    6. Click finish on the nett window

    (Note: This generats a file called C:\PDOXUSRS.NET)

    7. Close the "Manual Jornal Proccessing window" by clicking "X"

    8. Carry out step 1 again folowd by step 9.

    9. Select "TEST" and click "-" to deleat the current record and click "yes" when prompted

    10. Close FMS and brouse to C:

    11. Give the file "C:\PDOXUSRS.NET" the permissions "Everyone" full controle.

  11. Thanks to MicrodigitUK from:

    speckytecky (26th March 2010)

  12. #10
    DMcCoy's Avatar
    Join Date
    Oct 2005
    Location
    Isle of Wight
    Posts
    3,434
    Thank Post
    10
    Thanked 489 Times in 429 Posts
    Rep Power
    111
    You can of course just change the settings with the Borland admin utility. Have to find it in program files and run as administrator on vista/7 as it won't save the settings when just run from control panel.

    I just create a special folder, set the permissions and point it at that.

    Even tells you how in the 6.91 release documents for example http://www.capitasolus.co.uk/Release...S/fms691ra.pdf

  13. Thanks to DMcCoy from:

    speckytecky (26th March 2010)

  14. #11
    speckytecky's Avatar
    Join Date
    May 2006
    Location
    UK
    Posts
    2,497
    Thank Post
    3,372
    Thanked 256 Times in 209 Posts
    Blog Entries
    3
    Rep Power
    109

    Thanks!

    You guys are just the business This morning I came in to find my Sims server had failed on backup with corrupt / inaccessible data on pdoxusrs.net

    Google search zip of use!

    Edugeek search and up came this thread. TVM

  15. #12

    dhicks's Avatar
    Join Date
    Aug 2005
    Location
    Knightsbridge
    Posts
    5,622
    Thank Post
    1,240
    Thanked 777 Times in 674 Posts
    Rep Power
    235
    Quote Originally Posted by MicrodigitUK View Post
    Give the file "C:\PDOXUSRS.NET" the permissions "Everyone" full controle.
    I took the SubInAcl command from the simsperm.bat file to give permissions to C:\PDOXUSRS.NET to just the appropriate user (or, in our case, a security group named "KS-SEC-ADMIN" in our domain named "CAMELOT"):

    SubInAcl /FILE "C:\PDOXUSRS.NET" /GRANT=CAMELOT\KS-SEC-ADMIN=F

  16. #13

    matt40k's Avatar
    Join Date
    Jun 2008
    Location
    Ipswich
    Posts
    4,387
    Thank Post
    368
    Thanked 637 Times in 519 Posts
    Rep Power
    158
    Umm... ok, hello yr old topic.

    For Win7\Vista you need to move the file into a subfolder, I recommend moving pdoxusr.dat into c:\sims. So to install FMS it's:
    · Run S:\Setups\SIMSInfrastructureSetup.EXE
    o Select FMS Workstation components > then Install
    · Open BDE Administrator from Control Panel
    o Select Configuration tab
    o Expand Configuration > Drivers > Native
    o Select PARADOX
    o Change the NET DIR to C:\SIMS
    o Click Object > Apply
    o Click OK to confirm saving changes.
    o And OK to confirm message.
    o Close BDE Administrator
    · Run S:\Setups\FMS\FMSApplicationSetup.exe
    o Destination Folder: C:\Program Files\SIMS\FMSSQL
    · Copy S:\sims\fmsconnect.ini to C:\Program Files\SIMS\FMSSQL
    · Give the user or user group (e.g. Authenticated Users) full control of the following files and folders:
    o C:\Windows\SIMS.ini
    o C:\SIMS\
    o C:\Program Files\SIMS\

  17. #14

    Join Date
    Sep 2011
    Posts
    162
    Thank Post
    5
    Thanked 1 Time in 1 Post
    Rep Power
    0
    Similar fix here, I fixed various errors in FMS for a user by copying my PDOX... file into their computer, opening it with notepad and changing only my username which was in that file to their one. Worked immediately.

  18. #15

    matt40k's Avatar
    Join Date
    Jun 2008
    Location
    Ipswich
    Posts
    4,387
    Thank Post
    368
    Thanked 637 Times in 519 Posts
    Rep Power
    158
    No, please don't do that. All you need to do is give users access to it. FMSINST will place pdoxusr.dat in the ProgramData folder for Win7, so it works out-of-the-box.

SHARE:
+ Post New Thread

Similar Threads

  1. SIMS FMS Error
    By ben_snclc in forum MIS Systems
    Replies: 16
    Last Post: 11th December 2009, 01:32 PM
  2. Reporting in SIMS FMS
    By cjohnsonuk in forum MIS Systems
    Replies: 1
    Last Post: 21st April 2009, 02:49 PM
  3. Sims FMS problems
    By dave20046 in forum Windows
    Replies: 15
    Last Post: 25th February 2009, 11:13 AM
  4. SIMS FMS Printer problems
    By GILLSMITH23 in forum MIS Systems
    Replies: 3
    Last Post: 5th December 2008, 03:46 PM
  5. Replies: 3
    Last Post: 9th September 2006, 08:13 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •