+ Post New Thread
Page 2 of 3 FirstFirst 123 LastLast
Results 16 to 30 of 40
MIS Systems Thread, SIMS and CC3 needs change in Technical; I've not come across this before. If you install the VB6 redistributable beforehand, does the Infrastrucutre installer still attempt to ...
  1. #16
    meastaugh1's Avatar
    Join Date
    Jul 2006
    Location
    London/Hertfordshire
    Posts
    893
    Thank Post
    70
    Thanked 85 Times in 70 Posts
    Rep Power
    33
    I've not come across this before. If you install the VB6 redistributable beforehand, does the Infrastrucutre installer still attempt to install it and consequently prompt for a reboot?

  2. #17
    morganw's Avatar
    Join Date
    Apr 2009
    Location
    Cambridge
    Posts
    818
    Thank Post
    46
    Thanked 132 Times in 126 Posts
    Rep Power
    40
    Yes, the infrastructure installer will always run it even if it's just been run and it's been installed / rebooted. I also get errors when logging in on a non-admin account afterwards (just for that first logon) giving a Windows Update error for two vb6 runtime components.

  3. #18

    matt40k's Avatar
    Join Date
    Jun 2008
    Location
    Ipswich
    Posts
    4,523
    Thank Post
    375
    Thanked 677 Times in 551 Posts
    Rep Power
    166
    What version is your SIMSInfrastructureSetup.EXE and your simsinst.exe?

  4. #19
    morganw's Avatar
    Join Date
    Apr 2009
    Location
    Cambridge
    Posts
    818
    Thank Post
    46
    Thanked 132 Times in 126 Posts
    Rep Power
    40
    The latest ones from the Autumn 2009 update I presume, i'm calling them directly from the MIS server so they are definitely current.

  5. #20

    matt40k's Avatar
    Join Date
    Jun 2008
    Location
    Ipswich
    Posts
    4,523
    Thank Post
    375
    Thanked 677 Times in 551 Posts
    Rep Power
    166
    SIMSINST doesn't get updated (yet) via SOLUS, so it's prob out of date. SIMSINF will also be out of date, unless you've downloaded the latest CCS inf packages via SOLUS (Autumn Update).

  6. #21

    Edu-IT's Avatar
    Join Date
    Nov 2007
    Posts
    7,459
    Thank Post
    408
    Thanked 672 Times in 614 Posts
    Rep Power
    192
    I didn't have this problem using the supplied SIMS packages from RM...?

  7. #22
    morganw's Avatar
    Join Date
    Apr 2009
    Location
    Cambridge
    Posts
    818
    Thank Post
    46
    Thanked 132 Times in 126 Posts
    Rep Power
    40
    Where can I get the updated files from?
    Our local support team operate their own scripting system on top of the solus update system, but I think it only uses the solus updates and adds some scheduling.

    With regard to the CC3 packages how do you get them to install in order? The first time I tried most of them failed because of dependencies, and the CC3 installer doesn't automatically re-order or retry. So I would have to allocate one package at a time in the correct order? Or am I meant to use the early / late install groups with them?

  8. #23
    superfletch's Avatar
    Join Date
    Nov 2007
    Location
    South
    Posts
    445
    Thank Post
    153
    Thanked 77 Times in 61 Posts
    Rep Power
    32
    Hi Morgan,

    I'm only quoting several of your threads cause I know you and cause you're asking the interesting questions here:

    Quote Originally Posted by morganw View Post
    You actually don't need to provide to the S: drive for SIMS to run, but the 'normal' practice is to access your connect.ini file through that mapping
    Some, but not all others will need access as S: also holds the default paths for accessing CTFs, Census / Workforce Census Returns, Exams Basedata and FSM files.

    Quote Originally Posted by morganw View Post
    Will check this out our local SIMS support team have never mentioned this, thanks.
    That's wierd, we all did the CC3 and CC4 courses and made it clear to the instructor that SIMS was the MIS for all our schools and one of our biggest support commitments. I'm sure we asked the trainer if there were packages or even blueprints for the SIMS updates and we were told "no".

    Quote Originally Posted by morganw View Post
    Anyone found a way of stopping the Visual Basic Redist installer from asking for a reboot?
    It's set to install quietly but it doesnt.
    This is poor/inconsistent code from MS.

    Could you call it from a batch file as a shutdown script?

    That way someone will restart the PC for you even if it is stuck.

    Alternatively use something like AutoIt to call it then wait til the promt box appears and at that point tell it to reboot.

    Not sure that the syntax I've put here would be right - I'd have to check the help file.

    ***AutoIt***

    RunWait("\\servername\sharename\VB6.0-KB290887-X86.exe /q")

    IF ProcessExists("name_of_installers_exit_GUI.exe") then
    Shutdown(5)
    Else
    Processwait("name_of_installers_exit_GUI.exe")
    Shutdown(5)

    ***/AutoIt***


    Quote Originally Posted by Edu-IT View Post
    I didn't have this problem using the supplied SIMS packages from RM...?
    Where do you go on RM.com to get them?

    Quote Originally Posted by meastaugh1 View Post
    I've not come across this before. If you install the VB6 redistributable beforehand, does the Infrastrucutre installer still attempt to install it and consequently prompt for a reboot?
    REPLY

    Quote Originally Posted by morganw View Post
    Yes, the infrastructure installer will always run it even if it's just been run and it's been installed / rebooted. I also get errors when logging in on a non-admin account afterwards (just for that first logon) giving a Windows Update error for two vb6 runtime components.
    Surprised at that, fairly poor coding from Capita. Kind of makes the running it silently and independent of the rest of the infrastructure question obsolete. All they need to do is check for the existence of a couple of Reg Keys before calling it/not calling it.

    Makes me sad. :-(

    Quote Originally Posted by matt40k View Post
    Is this part of the SIMS Infrastructure?
    Yeah.
    Last edited by superfletch; 27th January 2010 at 09:00 AM. Reason: Add stuff

  9. Thanks to superfletch from:

    morganw (27th January 2010)

  10. #24
    meastaugh1's Avatar
    Join Date
    Jul 2006
    Location
    London/Hertfordshire
    Posts
    893
    Thank Post
    70
    Thanked 85 Times in 70 Posts
    Rep Power
    33
    Quote Originally Posted by superfletch View Post
    Where do you go on RM.com to get them?
    Np, if you have access to RM's support site, the link is: http://www.rm.com/Support/GeneralDownload.asp?cref=DWN1567504

  11. Thanks to meastaugh1 from:

    superfletch (27th January 2010)

  12. #25
    superfletch's Avatar
    Join Date
    Nov 2007
    Location
    South
    Posts
    445
    Thank Post
    153
    Thanked 77 Times in 61 Posts
    Rep Power
    32
    Quote Originally Posted by meastaugh1 View Post
    Np, if you have access to RM's support site, the link is: http://www.rm.com/Support/GeneralDownload.asp?cref=DWN1567504

    Nice one - thanks,

    I guess the packages won't force a restart cause they are already rolled up into MSI's.

    I'm off to see if the RM site includes packages for the infrastructure.

  13. #26

    matt40k's Avatar
    Join Date
    Jun 2008
    Location
    Ipswich
    Posts
    4,523
    Thank Post
    375
    Thanked 677 Times in 551 Posts
    Rep Power
    166
    There is one for SIMSINF - latest v.5.590.5.0 (SIMS INF that is)

  14. #27
    meastaugh1's Avatar
    Join Date
    Jul 2006
    Location
    London/Hertfordshire
    Posts
    893
    Thank Post
    70
    Thanked 85 Times in 70 Posts
    Rep Power
    33
    Quote Originally Posted by superfletch View Post
    I guess the packages won't force a restart cause they are already rolled up into MSI's.
    They are not MSIs, they are just package INIs which supply the silent parameters to Capita's legacy installers; not a great deal to it really.

  15. #28
    morganw's Avatar
    Join Date
    Apr 2009
    Location
    Cambridge
    Posts
    818
    Thank Post
    46
    Thanked 132 Times in 126 Posts
    Rep Power
    40
    I've tried the RM packages, and making my own. Still get the same issues either way.
    I'll have a look at AutoIT.

    What about setting up the infrastructure without using the SIMS infrastructure installer?
    .Net framework 3.5 and VB6 runtime sp6 may be manageable but what about a scripted install for the borland database engine and all of the other bits?

  16. #29
    morganw's Avatar
    Join Date
    Apr 2009
    Location
    Cambridge
    Posts
    818
    Thank Post
    46
    Thanked 132 Times in 126 Posts
    Rep Power
    40
    Quote Originally Posted by superfletch View Post
    Alternatively use something like AutoIt to call it then wait til the promt box appears and at that point tell it to reboot.
    The problem is if the vb6 runtime is part of a sequence of installers you don't actually want it to restart as you'll miss the rest of the infrastructure / installers.

    I'll look at trying something like pskill on a timer to deal with the reboot prompt.

  17. #30
    gybe78's Avatar
    Join Date
    May 2008
    Location
    Aylesbury
    Posts
    143
    Thank Post
    25
    Thanked 30 Times in 20 Posts
    Rep Power
    19
    morganw

    I have the exact same issue as you on CC3 using the latest RM packages and it drives me nuts! I've exhausted all ideas so would be very interested to know if/when you stumble across a solution.

    Thanks



SHARE:
+ Post New Thread
Page 2 of 3 FirstFirst 123 LastLast

Similar Threads

  1. If your board Vote for my SIMS Change Requests
    By Stuart_C in forum MIS Systems
    Replies: 1
    Last Post: 15th September 2009, 11:42 AM
  2. SIMS edit pupils' details crashing SIMS.net
    By CadlaM in forum MIS Systems
    Replies: 12
    Last Post: 13th January 2009, 03:20 PM
  3. SIMS change requests - Vote please!
    By park_bench in forum MIS Systems
    Replies: 4
    Last Post: 30th October 2008, 12:58 PM
  4. Change resolution an all CC3 stations?
    By reggiep in forum Network and Classroom Management
    Replies: 8
    Last Post: 14th July 2008, 12:36 PM
  5. CC3 Learning Resources on non-CC3 PC?
    By docboggle in forum Network and Classroom Management
    Replies: 4
    Last Post: 7th July 2008, 12:16 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •