+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 20
MIS Systems Thread, FMS in Technical; I have been having a problem with FMS for quite some time now and I was hoping that the new ...
  1. #1
    edie209's Avatar
    Join Date
    Mar 2006
    Location
    Kernow
    Posts
    671
    Thank Post
    41
    Thanked 17 Times in 16 Posts
    Rep Power
    22

    FMS

    I have been having a problem with FMS for quite some time now and I was hoping that the new update would end this error but it hasn't, It seems to happen when we have two users on FMS and surley it should cope with that?

    Here is a scrren shot of the error just incase someone has seen it and know a fix, (our local sims support have been looking into this for a couple of months now and still have not come back with any real solution




    [img][img=http://img2.freeimagehosting.net/uploads/th.b201267b73.jpg][/img]

  2. #2

    plexer's Avatar
    Join Date
    Dec 2005
    Location
    Norfolk
    Posts
    13,616
    Thank Post
    648
    Thanked 1,618 Times in 1,448 Posts
    Rep Power
    421

    Re: FMS

    Is it happening on a particualr machine or machines or from anywhere.

    I presume the database server is running and is generally conatactable from where you have the problem?

    Any client firewalls running that may be blocking connections?

    Ben

  3. #3
    edie209's Avatar
    Join Date
    Mar 2006
    Location
    Kernow
    Posts
    671
    Thank Post
    41
    Thanked 17 Times in 16 Posts
    Rep Power
    22

    Re: FMS

    We only use FMS on 3 machine in the admin offices, the database is running and the XP firewall has been opened and still we get the error

  4. #4

    plexer's Avatar
    Join Date
    Dec 2005
    Location
    Norfolk
    Posts
    13,616
    Thank Post
    648
    Thanked 1,618 Times in 1,448 Posts
    Rep Power
    421

    Re: FMS

    Have you tried turning the firewall off completely?

    OBDC setup correctly?

    You can ping etc.. the host that you are trying to connect to?

    Ben

  5. #5


    Join Date
    Dec 2005
    Location
    In the server room, with the lead pipe.
    Posts
    4,638
    Thank Post
    275
    Thanked 778 Times in 605 Posts
    Rep Power
    223

    Re: FMS

    Is the FMS database server (SQLAnywhere) installed on the main SIMS server or one of the XP workstations?

  6. #6
    edie209's Avatar
    Join Date
    Mar 2006
    Location
    Kernow
    Posts
    671
    Thank Post
    41
    Thanked 17 Times in 16 Posts
    Rep Power
    22

    Re: FMS

    @pete yes the SQLAnywhere database is on the main sims server

    @plexer I have turned the firewall off completly and still get the problem as to ODBC how can I check the setup?

  7. #7
    wesleyw's Avatar
    Join Date
    Dec 2005
    Location
    Kingswinford
    Posts
    2,207
    Thank Post
    225
    Thanked 50 Times in 44 Posts
    Blog Entries
    1
    Rep Power
    30

    Re: FMS

    Have you got an installation of FMS on the Server?


    Wes

  8. #8
    edie209's Avatar
    Join Date
    Mar 2006
    Location
    Kernow
    Posts
    671
    Thank Post
    41
    Thanked 17 Times in 16 Posts
    Rep Power
    22

    Re: FMS

    Yes the installation of FMS is on the Sims server

  9. #9
    wesleyw's Avatar
    Join Date
    Dec 2005
    Location
    Kingswinford
    Posts
    2,207
    Thank Post
    225
    Thanked 50 Times in 44 Posts
    Blog Entries
    1
    Rep Power
    30

    Re: FMS

    When running FMS on the server do you get the same error?

    Wes

  10. #10
    edie209's Avatar
    Join Date
    Mar 2006
    Location
    Kernow
    Posts
    671
    Thank Post
    41
    Thanked 17 Times in 16 Posts
    Rep Power
    22

    Re: FMS

    I have not tried running it directly on the server I will try that tomorrow as I will have to get one of the admin girls to do what they do thats when the problem seems to happen

  11. #11

    Ric_'s Avatar
    Join Date
    Jun 2005
    Location
    London
    Posts
    7,596
    Thank Post
    109
    Thanked 764 Times in 595 Posts
    Rep Power
    181

    Re: FMS

    Check that the SQLAnywhere location is that as seen on the server, not the client and that the user has sufficient priviledges to the IDAPI and .OCX files on c:\ of the client.

    FMS does some wiered stuff and will go off hunting for the server if the path is wrong - this is why it will work sometimes and not others.

  12. #12
    edie209's Avatar
    Join Date
    Mar 2006
    Location
    Kernow
    Posts
    671
    Thank Post
    41
    Thanked 17 Times in 16 Posts
    Rep Power
    22

    Re: FMS

    Thanks Ric I will try in the morning

  13. #13


    Join Date
    Dec 2005
    Location
    In the server room, with the lead pipe.
    Posts
    4,638
    Thank Post
    275
    Thanked 778 Times in 605 Posts
    Rep Power
    223

    Re: FMS

    Work through KB7885 on Capita Supportnet, reproduced below (the error is slightly different). I had this handy because we got caught out by the "2 network cards" bit recently after replacing dumb switches with managed ones. If you don't have a login, apply here:

    http://support.capitaes.co.uk/newlogin/register.asp
    Code:
    General SQL error
    Sybase ODBC Driver Unable to connect to Database Server: unable to start Database engine
    Alias: dbInitialConnection
    
    Occurs after running the FMS Module shortcut.
    Advice 	
    Fix 1
    
    Check the database server is running on the server as follows:
    
    1. At Start | Run type DBSVMN50
    
    2. If the service is not running, click the Start button to start service.
    
    3. If the service is running, check which protocols are being used by following the next fix:
    
    Fix 2
    
    On the Server:
    
    1. Stop the Database Server using Start | Run | DBSVMN50 and click Stop.
    
    2. At Start | Run type: DBSRV50 -n SIMS_Server
    
    This will try and broadcast on all protocols: make a note of which protocols are used.
    
    On the Workstation:
    
    1. At Start | Run type DBCLIENT -n SIMS_Server
    
    2. This will try all protocols and will display which are used
    
    3. Check if the protocol used by the client is also being used by the server, e.g TCPIP.
    
    Note: the server normally uses NamedPipes as a protocol to connect to itself.
    
    The protocol should be specified in the Database Server as follows:
    
    1. At Start | Run type: DBSVMN50 and open the SQL Anywhere Service Manager.
    
    2. Click Edit and then edit the parameter line. So, for example if protocols used are Named Pipes and TCP/IP it should read as follows:
    
    -n SIMS_Server -c 8192 -tl 1500 -x NamedPipes,TCPIP
    
    Note: The Service will need to be restarted for this to take effect.
    
    The protocol should be specified on the Client machine as follows:
    
    1. At Start | Run type: odbcad32
    
    2. Select the System DSN tab
    
    3. Select SIMS32
    
    4. Click the Configure button
    
    5. Click the Options button
    
    6. The parameter line for TCP/IP should read as follows:
    
    c:\sqlany50\win32\dbclient.exe -ta 600 -x TCPIP
    
    Fix 3
    
    Try pinging the IP address of the server from the workstation AND the IP address of the workstation from the server as follows:
    
    1. Start | Run | CMD  
    
    2. Type PING [IP address of server/workstation] 
    
    eg. Ping 192.168.2.1
    
    If two way connection is not possible this may be a problem with addressing on the network. 
    
    Fix 4
    
    This error can also occur if the workstation or server are using 2 IP addresses, or are on a subnet. If this is the case, unplug, or disable one of the cards to confirm that this resolves the problem.
    
    To resolve the above issue, and other possible network issues, it is also possible to specify explicitly the hostname of the FMS Server the client is trying to connect to and for the FMS Server to only accept requests.
    
    To try this:
    
    1. Stop the Database Server using Start | Run type: DBSVMN50 and click Stop.
    
    2. On the Database Server at Start | Run type:
    
    dbsrv50 -n SIMS_server -x tcpip{Broadcast=FALSE}
    
    3. At the workstation at Start | Run type:
    
    dbclient -n SIMS_server -x TCPIP{host=10.128.2.226} (e.g ipaddress of Database Server)
    
    4. If both of these respond positively (server starts and dbclient can see server):
    
    5: At Start | Run type: DBSVMN50 and open the SQL Anywhere Service Manager.
    
    6: Click Edit and then Edit the parameter line. So, for example:
    
    -n SIMS_Server -c 8192 -tl 1500 -x NamedPipes,TCPIP{Broadcast=FALSE}
    
    Note: The Service will need to be restarted for this to take effect.
    
    The protocol should be specified on the Client machine as follows:
    
    1. At Start | Run type: odbcad32
    
    2. Select the System DSN tab
    
    3. Select SIMS32
    
    4. Click the Configure button
    
    5. Click the Options button
    
    6. The parameter line, for example should read as follows:
    
    c:\sqlany50\win32\dbclient.exe -ta 600 -x TCPIP{host=10.128.2.226}

  14. #14
    edie209's Avatar
    Join Date
    Mar 2006
    Location
    Kernow
    Posts
    671
    Thank Post
    41
    Thanked 17 Times in 16 Posts
    Rep Power
    22

    Re: FMS

    Thats really helpful pete all three of my PCs have two IPs (this is the way they were set up before I got here) so maybe there is some mileage in this fix.

    I signed up to the Capita Supportnet site just before I came home from work tonight.

    I will try these and post the results thanks

  15. #15

    Join Date
    Sep 2006
    Location
    London
    Posts
    1,326
    Thank Post
    36
    Thanked 353 Times in 238 Posts
    Rep Power
    79

    Re: FMS

    I think that for multi-user FMS needs to be on the workstations.

SHARE:
+ Post New Thread
Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •