+ Post New Thread
Page 1 of 3 123 LastLast
Results 1 to 15 of 42
MIS Systems Thread, New SIMS install not letting users log on in Technical; Hi all. Everything seems to be going awry at the moment and the jobs keep piling up! New SIMS server ...
  1. #1
    Number6's Avatar
    Join Date
    Feb 2009
    Location
    Worcester, UK
    Posts
    457
    Thank Post
    2
    Thanked 9 Times in 8 Posts
    Rep Power
    12

    New SIMS install not letting users log on

    Hi all.

    Everything seems to be going awry at the moment and the jobs keep piling up!

    New SIMS server - brand new hardware, Server 2008. We're migrating our existing SIMS setup to the new server.

    Our DB manager installed SIMS onto the server and migrated the database. SQL was installed from the Capita disk. We had the devils own job getting it to work but eventually we did after a day and a half of solid work and hair pulling!

    We've set up two workstations to access the new server. The problem is this:

    No one can login. We get as far as the username and password entry screen but every attempted login is rejected with a "user unable to login, reason 0 (zero)". This happens for any user including sysman.

    If we work directly on the server then any user can login as a user and SIMS works flawlessly, so it doesn't appear to be a server or DB issue.

    We have raised a support issue with capita which is still open. We've tried their first recommeded set of fixes to no avail. Capita are now head scratching.

    The workstations have had all traces of previous SIMS installs removed, firstly via add/remove progs and then a manual deletion of any remaining folders. This is followed by a registry clean, a reboot and a further registry clean before reinstalling. So we're fairly sure there are no remnants of connect files or any rogue registry entries. We've tried all this twice now. All appropriate network drives and connect files point to the right place.

    Does anyone have any ideas we can try? I really need to get this fixed today as I'm on holiday for two weeks after today.

    Thanks all.

  2. #2

    matt40k's Avatar
    Join Date
    Jun 2008
    Location
    Ipswich
    Posts
    4,135
    Thank Post
    352
    Thanked 577 Times in 474 Posts
    Rep Power
    142
    Few thoughs:

    Check sims.ini, make sure setups is point to the new servers setups
    Make sure the user has access rights to the s drive (sims share)
    Make sure the firewall is opened up. (MSSQL,HTTP:8080(DMS),File sharing)
    If you installed MSSQL 2005 standard\enterprise, enable TCP\IP
    Checking the connect.ini (c:\program files\sims\sims .net\connect.ini)

  3. #3
    Number6's Avatar
    Join Date
    Feb 2009
    Location
    Worcester, UK
    Posts
    457
    Thank Post
    2
    Thanked 9 Times in 8 Posts
    Rep Power
    12
    Hi Matt

    Sims.ini has all the correct settings as far as I can see.

    Permissions should be fine because the workstations in question ran sims happily before, and if I change the network drive back to the old sims server the WS can access it just fine.

    SQL was installed from the Capita disc as part of the SIMS setup, we didn't use any other instance of SQL.

    My only other thought is that SQL permissions may be wrong but how do we check or change this on the Capita install?

  4. #4
    Ian_ICTDS's Avatar
    Join Date
    Jun 2009
    Location
    Warwickshire
    Posts
    70
    Thank Post
    11
    Thanked 15 Times in 12 Posts
    Rep Power
    12
    Hi 6

    Detaching and re-attaching the database using DBAttach usually re-creates the SQL users if something has gone wrong with the migration. Might be worth giving that a go.

    Ian.

    EDIT: Just noticed you said everything's fine on the server so DBAttach probably won't make a difference. Sorry. Might be still worth having a go though.

  5. #5
    Number6's Avatar
    Join Date
    Feb 2009
    Location
    Worcester, UK
    Posts
    457
    Thank Post
    2
    Thanked 9 Times in 8 Posts
    Rep Power
    12
    Hi Ian

    We did that yesterday to no avail.

    I don't anyway think it's a sims user problem per se, users can log into sims if they're working directly at the server, just not from a workstation.

  6. #6
    Ian_ICTDS's Avatar
    Join Date
    Jun 2009
    Location
    Warwickshire
    Posts
    70
    Thank Post
    11
    Thanked 15 Times in 12 Posts
    Rep Power
    12
    Hmmmmm. I often find problems like this are down to the Connect.ini files on the workstations.

    Do the clients PCs local connect.ini files (C:\Program Files\SIMS\SIMS .net) point directly to the server eg:

    [SIMSConnection]
    ServerName=SIMSSERVER\SIMS2005
    DatabaseName=sims
    DatabaseMode=OnLine
    CommandTimeout=1000000

    Or do you have a redirect:

    [SIMSConnection]
    Redirect=S:\sims

    If you have a redirect, changing the path to a UNC path can sometimes help. Also worth checking that the connect.ini that the redirect is pointing to has the correct details.

    If you donít have a redirect and have the server details written in then check if they are correct. It should be in the format above.

    Good luck.

    Ian.

  7. #7

    Join Date
    Nov 2008
    Location
    Birmingham
    Posts
    127
    Thank Post
    27
    Thanked 15 Times in 14 Posts
    Rep Power
    13
    ohh i might now why it aint working, before i left my work i shifted sims on to our new 64 bit server 2008 server. (almost went on a murderous rampage by the way) What i found was one or two people could log on so try every one with admin rights.

    What happened is when you dettach and reattach a database sometimes, a user password is reset to the default one you get when you first register a user. You know the kind, goes like THDIBWIW3J or something like it.

    If you can get in you'll find most peoples passwords have being reset. sorry Im not more helpful.

  8. #8
    Number6's Avatar
    Join Date
    Feb 2009
    Location
    Worcester, UK
    Posts
    457
    Thank Post
    2
    Thanked 9 Times in 8 Posts
    Rep Power
    12
    Quote Originally Posted by Wils86 View Post
    ohh i might now why it aint working, before i left my work i shifted sims on to our new 64 bit server 2008 server. (almost went on a murderous rampage by the way) What i found was one or two people could log on so try every one with admin rights.

    What happened is when you dettach and reattach a database sometimes, a user password is reset to the default one you get when you first register a user. You know the kind, goes like THDIBWIW3J or something like it.

    If you can get in you'll find most peoples passwords have being reset. sorry Im not more helpful.
    We're aware of this and tried all the new and old passwords.

    Same result - can't login, reason 0

  9. #9
    Number6's Avatar
    Join Date
    Feb 2009
    Location
    Worcester, UK
    Posts
    457
    Thank Post
    2
    Thanked 9 Times in 8 Posts
    Rep Power
    12
    Quote Originally Posted by Ian_ICTDS View Post
    Hmmmmm. I often find problems like this are down to the Connect.ini files on the workstations.

    Do the clients PCs local connect.ini files (C:\Program Files\SIMS\SIMS .net) point directly to the server eg:

    [SIMSConnection]
    ServerName=SIMSSERVER\SIMS2005
    DatabaseName=sims
    DatabaseMode=OnLine
    CommandTimeout=1000000

    Or do you have a redirect:

    [SIMSConnection]
    Redirect=S:\sims

    If you have a redirect, changing the path to a UNC path can sometimes help. Also worth checking that the connect.ini that the redirect is pointing to has the correct details.

    If you donít have a redirect and have the server details written in then check if they are correct. It should be in the format above.

    Good luck.

    Ian.
    We use a redirect to a mapped drive.

    I'll try playing with UNC paths, I haven't tried this yet although I have to admit I was contemplating it.

    Thanks, I'll have a play now.

  10. #10
    Number6's Avatar
    Join Date
    Feb 2009
    Location
    Worcester, UK
    Posts
    457
    Thank Post
    2
    Thanked 9 Times in 8 Posts
    Rep Power
    12
    Nope

    Changing connect.ini to a unc path made no difference.

  11. #11
    Ian_ICTDS's Avatar
    Join Date
    Jun 2009
    Location
    Warwickshire
    Posts
    70
    Thank Post
    11
    Thanked 15 Times in 12 Posts
    Rep Power
    12
    Next I would try putting the server details directly into the local connect.ini rather that an redirect just to completely rule that out.

    After that I would install SQL Management Studio Express from the Microsoft website on the workstation. Then use that to log into the SQL server just to see if youíve defiantly got SQL connectivity.

    Ian.

  12. #12
    Mcshammer_dj's Avatar
    Join Date
    Feb 2007
    Location
    Portsmouth
    Posts
    908
    Thank Post
    35
    Thanked 154 Times in 125 Posts
    Rep Power
    54
    on the server

    go to SQL 2005 and check that the surface configuration is set to allow remote access to the server

  13. #13
    Number6's Avatar
    Join Date
    Feb 2009
    Location
    Worcester, UK
    Posts
    457
    Thank Post
    2
    Thanked 9 Times in 8 Posts
    Rep Power
    12
    Quote Originally Posted by Ian_ICTDS View Post
    Next I would try putting the server details directly into the local connect.ini rather that an redirect just to completely rule that out.

    After that I would install SQL Management Studio Express from the Microsoft website on the workstation. Then use that to log into the SQL server just to see if youíve defiantly got SQL connectivity.

    Ian.
    Done the server details, no difference.

    Trying the SQL Management now.

  14. #14
    Ian_ICTDS's Avatar
    Join Date
    Jun 2009
    Location
    Warwickshire
    Posts
    70
    Thank Post
    11
    Thanked 15 Times in 12 Posts
    Rep Power
    12
    Good luck. If SQL Management Studio canít connect you usually get a decent error message to investigate.

  15. #15
    Number6's Avatar
    Join Date
    Feb 2009
    Location
    Worcester, UK
    Posts
    457
    Thank Post
    2
    Thanked 9 Times in 8 Posts
    Rep Power
    12
    Quote Originally Posted by Mcshammer_dj View Post
    on the server

    go to SQL 2005 and check that the surface configuration is set to allow remote access to the server
    Yep, remote access by TCP/IP (not named pipes) is enabled.

SHARE:
+ Post New Thread
Page 1 of 3 123 LastLast

Similar Threads

  1. Log users logging on to a laptop?
    By ICT_GUY in forum Windows Vista
    Replies: 1
    Last Post: 20th November 2009, 10:12 AM
  2. Can't log off SIMS users
    By timzim in forum MIS Systems
    Replies: 5
    Last Post: 13th November 2009, 08:35 AM
  3. Edugeek Joomla cant log in after install.
    By jamin100 in forum EduGeek Joomla 1.0 Package
    Replies: 8
    Last Post: 11th March 2008, 03:53 PM
  4. Staff laptops: Letting 'em install network software
    By eean in forum How do you do....it?
    Replies: 3
    Last Post: 13th September 2006, 08:08 PM
  5. Only allow certain users to log on to a machine?
    By wesleyw in forum How do you do....it?
    Replies: 7
    Last Post: 16th January 2006, 11:38 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •