+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 22
MIS Systems Thread, SIMS Learning Gateway Staff Timetable Issue in Technical; Hi all I wonder if any users who have the Learning Gateway have come across this problem. When browsing for ...
  1. #1

    Sylv3r's Avatar
    Join Date
    Jul 2005
    Location
    Co. Durham
    Posts
    3,204
    Thank Post
    372
    Thanked 376 Times in 334 Posts
    Rep Power
    147

    SIMS Learning Gateway Staff Timetable Issue

    Hi all

    I wonder if any users who have the Learning Gateway have come across this problem. When browsing for a member of staff you can see the teachers table for the day, but I would like to be able to click on the "Teacher's Timetable..." link to see their full timetable for the week.

    This works for students after a little tweaking with permissions etc, but I can't get it to work for staff timetables. I get the following error (see attached). The "Teacher Timetable Calendar Data" webpart has the error.

    I would also like to introduce the staff and student daily timetable on the main staff and student pages so the user can see straight away what their timetable for the day is - is this possible?
    Attached Images Attached Images

  2. #2

    EduTech's Avatar
    Join Date
    Aug 2007
    Location
    Reading
    Posts
    5,047
    Thank Post
    160
    Thanked 913 Times in 716 Posts
    Blog Entries
    3
    Rep Power
    271
    It appears to work ok for me, see attached image

    i just did a search for a staff member > click on the member of staff > show timetable



    James.
    Attached Images Attached Images

  3. #3

    Sylv3r's Avatar
    Join Date
    Jul 2005
    Location
    Co. Durham
    Posts
    3,204
    Thank Post
    372
    Thanked 376 Times in 334 Posts
    Rep Power
    147
    Quote Originally Posted by EduTech View Post
    It appears to work ok for me, see attached image

    i just did a search for a staff member > click on the member of staff > show timetable



    James.
    Thats what I am trying to do.... hmmm will have to have a little more play.

  4. #4

    EduTech's Avatar
    Join Date
    Aug 2007
    Location
    Reading
    Posts
    5,047
    Thank Post
    160
    Thanked 913 Times in 716 Posts
    Blog Entries
    3
    Rep Power
    271
    Quote Originally Posted by Sylv3r View Post
    Thats what I am trying to do.... hmmm will have to have a little more play.
    oki

    What webpart you using?

  5. #5

    Sylv3r's Avatar
    Join Date
    Jul 2005
    Location
    Co. Durham
    Posts
    3,204
    Thank Post
    372
    Thanked 376 Times in 334 Posts
    Rep Power
    147
    The page it links to is:

    https://********/sims/Teachers/SLGPa...darPeriod=week

    And the two webparts on the page are:

    My Timetable
    Teacher Timetable Calendar Data

  6. #6

    EduTech's Avatar
    Join Date
    Aug 2007
    Location
    Reading
    Posts
    5,047
    Thank Post
    160
    Thanked 913 Times in 716 Posts
    Blog Entries
    3
    Rep Power
    271
    Can you veiw the list, its located in veiw all site content on the Teachers Page.

    list is called: TeacherTimetable

    https://*************/Teachers/Lists.../calendar.aspx
    Last edited by EduTech; 5th July 2009 at 07:06 PM.

  7. #7

    Sylv3r's Avatar
    Join Date
    Jul 2005
    Location
    Co. Durham
    Posts
    3,204
    Thank Post
    372
    Thanked 376 Times in 334 Posts
    Rep Power
    147
    Yes, the calendar loads with that link. No data just the calendar webpart.

  8. #8

    EduTech's Avatar
    Join Date
    Aug 2007
    Location
    Reading
    Posts
    5,047
    Thank Post
    160
    Thanked 913 Times in 716 Posts
    Blog Entries
    3
    Rep Power
    271
    Quote Originally Posted by Sylv3r View Post
    Yes, the calendar loads with that link. No data just the calendar webpart.
    ok, well really you should have data there... i do anyhow.. even if i go there without searching for a teacher first.

    (if you search for someone who dont have a teaching timetable i.e. yourself you wont get any data)

    Give me a few minutes, just going to see if i can see any settings that should be set in the webpart view.. otherwise it might be a support call with your provider.

    James.

  9. Thanks to EduTech from:

    Sylv3r (5th July 2009)

  10. #9

    Sylv3r's Avatar
    Join Date
    Jul 2005
    Location
    Co. Durham
    Posts
    3,204
    Thank Post
    372
    Thanked 376 Times in 334 Posts
    Rep Power
    147
    Quote Originally Posted by EduTech View Post
    ok, well really you should have data there... i do anyhow.. even if i go there without searching for a teacher first.

    (if you search for someone who dont have a teaching timetable i.e. yourself you wont get any data)

    Give me a few minutes, just going to see if i can see any settings that should be set in the webpart view.. otherwise it might be a support call with your provider.

    James.
    Do you only have the one webpart on the list page? Or is one of the hidden ones assigned?

  11. #10

    EduTech's Avatar
    Join Date
    Aug 2007
    Location
    Reading
    Posts
    5,047
    Thank Post
    160
    Thanked 913 Times in 716 Posts
    Blog Entries
    3
    Rep Power
    271
    I have

    Teachers Timetable which is just a list veiw webpart, that pulls through the calendar

    and then a hidden webpart called "Teacher Timetable Calendar Data"

    James.

  12. #11

    Sylv3r's Avatar
    Join Date
    Jul 2005
    Location
    Co. Durham
    Posts
    3,204
    Thank Post
    372
    Thanked 376 Times in 334 Posts
    Rep Power
    147
    Quote Originally Posted by EduTech View Post
    I have

    Teachers Timetable which is just a list veiw webpart, that pulls through the calendar

    and then a hidden webpart called "Teacher Timetable Calendar Data"

    James.
    Thanks James

    I get the same error message even after I add the Teacher Timetable Calendar Data webpart manually.

    Ah well

  13. #12

    EduTech's Avatar
    Join Date
    Aug 2007
    Location
    Reading
    Posts
    5,047
    Thank Post
    160
    Thanked 913 Times in 716 Posts
    Blog Entries
    3
    Rep Power
    271
    Have you installed the June 2009 Update by anychance?

    If you have installed the June 2009 update on the server, but your webparts have not been updated this will also cause these kind of errors..

    James.

  14. #13

    Sylv3r's Avatar
    Join Date
    Jul 2005
    Location
    Co. Durham
    Posts
    3,204
    Thank Post
    372
    Thanked 376 Times in 334 Posts
    Rep Power
    147
    Quote Originally Posted by EduTech View Post
    Have you installed the June 2009 Update by anychance?

    If you have installed the June 2009 update on the server, but your webparts have not been updated this will also cause these kind of errors..

    James.
    Nope still running May. This is something that has never worked since we installed it, I am just getting round to having a play and trying to fix it this weekend.

  15. #14

    EduTech's Avatar
    Join Date
    Aug 2007
    Location
    Reading
    Posts
    5,047
    Thank Post
    160
    Thanked 913 Times in 716 Posts
    Blog Entries
    3
    Rep Power
    271
    Oh right, i would speak to capita/smis depending on who you deal with and they should be able to sort it for you.. something obviously is not setup correctly.

    I have found a licence error with ours now so i will be emailing our SMIS team in a minute lol

    James.

  16. #15
    meastaugh1's Avatar
    Join Date
    Jul 2006
    Location
    London/Hertfordshire
    Posts
    890
    Thank Post
    69
    Thanked 85 Times in 70 Posts
    Rep Power
    32
    Are you both referring to sites you have created using the SLG site creation procedure, or just plain sites you've added the SLG2 web parts to?

SHARE:
+ Post New Thread
Page 1 of 2 12 LastLast

Similar Threads

  1. SIMS Learning Gateway
    By Quackers in forum MIS Systems
    Replies: 13
    Last Post: 21st July 2009, 01:09 AM
  2. SIMS Learning Gateway
    By teckedd in forum MIS Systems
    Replies: 33
    Last Post: 20th July 2009, 08:56 PM
  3. Replies: 0
    Last Post: 17th June 2009, 02:19 PM
  4. Sims learning gateway
    By NewOrder in forum MIS Systems
    Replies: 0
    Last Post: 15th June 2009, 07:23 PM
  5. SIMS Learning Gateway
    By Quackers in forum MIS Systems
    Replies: 2
    Last Post: 15th May 2007, 11:18 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •