+ Post New Thread
Page 3 of 3 FirstFirst 123
Results 31 to 32 of 32
MIS Systems Thread, SIMS.Net - problem importing new reports [SOLVED] in Technical; @glensc: That's a very interesting point. The document server is certainly using HTTP1.1. Running SmartSniff while doing a (successful) connection ...
  1. #31
    Irazmus's Avatar
    Join Date
    Feb 2006
    Location
    Suffolk
    Posts
    307
    Thank Post
    11
    Thanked 15 Times in 13 Posts
    Rep Power
    20

    Re: SIMS.Net - problem importing new reports

    @glensc: That's a very interesting point. The document server is certainly using HTTP1.1.

    Running SmartSniff while doing a (successful) connection test gives the following.

    On the client:
    Code:
    HTTP/1.1 100 Continue
    
    HTTP/1.1 200 OK
    Content-Type: text/xml; charset="utf-8"
    Server: MS .NET Remoting, MS .NET CLR 1.1.4322.2300
    Content-Length: 611
    
    <SOAP-ENV:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/" xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:clr="http://schemas.microsoft.com/soap/encoding/clr/1.0" SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/">
    <SOAP-ENV:Body>
    <i2:PingResponse id="ref-1" xmlns:i2="http://schemas.microsoft.com/clr/nsassem/SIMS.DocumentServer.IDocumentServer/DocumentServerInterfaces">
    <return>true</return>
    </i2:PingResponse>
    </SOAP-ENV:Body>
    </SOAP-ENV:Envelope>
    On the server:
    Code:
    POST /DocumentServer.rem HTTP/1.1
    User-Agent: Mozilla/4.0+(compatible; MSIE 6.0; Windows 6.0.5384.0; MS .NET Remoting; MS .NET CLR 1.1.4322.2032 )
    Content-Type: text/xml; charset="utf-8"
    SOAPAction: "http://schemas.microsoft.com/clr/nsassem/SIMS.DocumentServer.IDocumentServer/DocumentServerInterfaces#Ping"
    Content-Length: 572
    Expect: 100-continue
    Host: odin:8080
    
    <SOAP-ENV:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/" xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:clr="http://schemas.microsoft.com/soap/encoding/clr/1.0" SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/">
    <SOAP-ENV:Body>
    <i2:Ping id="ref-1" xmlns:i2="http://schemas.microsoft.com/clr/nsassem/SIMS.DocumentServer.IDocumentServer/DocumentServerInterfaces">
    </i2:Ping>
    </SOAP-ENV:Body>
    </SOAP-ENV:Envelope>
    That might explain that oddity

  2. #32
    Irazmus's Avatar
    Join Date
    Feb 2006
    Location
    Suffolk
    Posts
    307
    Thank Post
    11
    Thanked 15 Times in 13 Posts
    Rep Power
    20

    Re: SIMS.Net - problem importing new reports

    After many long weeks of searching we finally have a solution.
    The problem was caused by a ghost entry for the old Document Server hiding in the system which only became visible after removing the current document server from the 'Document Server Setup' dialog, and therefore hadn't been noticed previously. Once this ghost record was removed and the current server added back, we were once again able to import reports, and my SIMS manager is happy again.

    Thanks again for all your help and suggestions.

SHARE:
+ Post New Thread
Page 3 of 3 FirstFirst 123

Similar Threads

  1. [SOLVED] Edugeek Joomla package logo problem
    By gh256 in forum EduGeek Joomla 1.0 Package
    Replies: 2
    Last Post: 16th November 2007, 01:36 PM
  2. Importing into SIMS Attendance
    By Jonsi in forum MIS Systems
    Replies: 12
    Last Post: 7th November 2007, 10:18 AM
  3. Solved one problem, another arises
    By Gambit in forum Windows
    Replies: 4
    Last Post: 31st March 2007, 04:28 PM
  4. Importing Users into Moodle from SIMS
    By Ric_ in forum Virtual Learning Platforms
    Replies: 16
    Last Post: 23rd January 2007, 08:34 AM
  5. Problem assigning printers at logon - SOLVED
    By richard in forum Wireless Networks
    Replies: 12
    Last Post: 4th January 2007, 09:14 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •