+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 20
MIS Systems Thread, Any ideas on how to tie AD username and Password to SIMS.net in Technical; Sorry if this has been posted before. We are running a vanilla windows 2003 network and was wondering is there ...
  1. #1

    timbo343's Avatar
    Join Date
    Dec 2005
    Location
    Leeds/York area, North Yorkshire
    Posts
    3,195
    Thank Post
    321
    Thanked 314 Times in 219 Posts
    Rep Power
    125

    Any ideas on how to tie AD username and Password to SIMS.net

    Sorry if this has been posted before. We are running a vanilla windows 2003 network and was wondering is there a way for SIMS to tie into Active Directory so staff can input their school logons to access SIMS instead of having a seperate log name and password?

    We have tried this already...
    In System Manager, if you view the properties of a user, there is a magnifying glass icon next to their username. If you click this and you should be able to link the username with one in active directory.

    That seemed to make sence, but when we tried to put our username and password for the domain into the SIMS.net logon box, SIMS throws an error up saying invalid user name/password. Even if you try it in the form of domain\username the username box turns red.

    Can someone help out??

    Thanks

    Tim

  2. #2
    Mcshammer_dj's Avatar
    Join Date
    Feb 2007
    Location
    Portsmouth
    Posts
    991
    Thank Post
    38
    Thanked 180 Times in 145 Posts
    Rep Power
    97
    you then need the change the connect.ini to use the trusted password from AD.

  3. #3
    Mcshammer_dj's Avatar
    Join Date
    Feb 2007
    Location
    Portsmouth
    Posts
    991
    Thank Post
    38
    Thanked 180 Times in 145 Posts
    Rep Power
    97
    ConnectionType=Trusted

    needs to be added

  4. Thanks to Mcshammer_dj from:

    timbo343 (4th December 2008)

  5. #4

    timbo343's Avatar
    Join Date
    Dec 2005
    Location
    Leeds/York area, North Yorkshire
    Posts
    3,195
    Thank Post
    321
    Thanked 314 Times in 219 Posts
    Rep Power
    125
    ahhhh.... thank you

  6. #5
    Vegas's Avatar
    Join Date
    Jul 2005
    Location
    Gloucestershire
    Posts
    374
    Thank Post
    21
    Thanked 38 Times in 31 Posts
    Rep Power
    36
    You will also need to change all your SIMS usernames to the following format:

    domain\username

  7. #6

    timbo343's Avatar
    Join Date
    Dec 2005
    Location
    Leeds/York area, North Yorkshire
    Posts
    3,195
    Thank Post
    321
    Thanked 314 Times in 219 Posts
    Rep Power
    125
    so our connect.ini file looks something like this:

    Code:
    [SIMSConnection]
    ServerName=ServerName\SQLName
    DatabaseName=nameofdatabase
    Then what would i add??

    Code:
    [SIMSConnection
    ServerName=ServerName\SQLName
    DatabaseName=nameofdatabase
    ConnectionType=trusted
    and where do i put in an AD username and password??

    Thanks so much

    Tim
    Last edited by timbo343; 4th December 2008 at 03:42 PM.

  8. #7
    Vegas's Avatar
    Join Date
    Jul 2005
    Location
    Gloucestershire
    Posts
    374
    Thank Post
    21
    Thanked 38 Times in 31 Posts
    Rep Power
    36
    Your SIMS usernames in System Manager need to be changed to:

    domain\adusername

    There is a thread somewhere on here about it.

  9. Thanks to Vegas from:

    timbo343 (4th December 2008)

  10. #8

    timbo343's Avatar
    Join Date
    Dec 2005
    Location
    Leeds/York area, North Yorkshire
    Posts
    3,195
    Thank Post
    321
    Thanked 314 Times in 219 Posts
    Rep Power
    125
    oh right i see... I thought i had to add an account in AD for SIMS to talk to... my mistake..

    Thanks again

  11. #9

    timbo343's Avatar
    Join Date
    Dec 2005
    Location
    Leeds/York area, North Yorkshire
    Posts
    3,195
    Thank Post
    321
    Thanked 314 Times in 219 Posts
    Rep Power
    125
    but just reading SIMS.Net Active Directory Integration, by adding ConnectionType=Trusted to the connect.ini file which is located on the SIMS server rather than locally to the machine, will this still disable the login box for SIMS.net???

    If so, that is not what i want to happen. I still want to use the SIMS.net logon box with the users AD username and password.

  12. #10
    Vegas's Avatar
    Join Date
    Jul 2005
    Location
    Gloucestershire
    Posts
    374
    Thank Post
    21
    Thanked 38 Times in 31 Posts
    Rep Power
    36
    It doesn't disable it, all it does is to give you 2 options to login to SIMS.
    The first option is just 'Current Windows User' this is checked by default so the SIMS username and password box are greyed out.
    Second is 'SIMS User'
    All staff need do is to click 'OK'
    Change your SIMS.ini on your local PC and see for yourself.

  13. #11

    timbo343's Avatar
    Join Date
    Dec 2005
    Location
    Leeds/York area, North Yorkshire
    Posts
    3,195
    Thank Post
    321
    Thanked 314 Times in 219 Posts
    Rep Power
    125
    ahhh, so it does... although that is all well and good, thats going one step too far for me.
    What i am wanting to do is get the user to put in their username and password instead of just clicking ok, if you see what i mean.
    Last edited by timbo343; 4th December 2008 at 05:33 PM.

  14. #12
    Vegas's Avatar
    Join Date
    Jul 2005
    Location
    Gloucestershire
    Posts
    374
    Thank Post
    21
    Thanked 38 Times in 31 Posts
    Rep Power
    36
    Am I missing something here. If you want your staff to use use the SIMS login box then don't modify your SIMS.ini file in the first place.

  15. #13

    timbo343's Avatar
    Join Date
    Dec 2005
    Location
    Leeds/York area, North Yorkshire
    Posts
    3,195
    Thank Post
    321
    Thanked 314 Times in 219 Posts
    Rep Power
    125
    lol, kinda... i thought that would come up.. Right...

    what i want is...
    1. the sim.net logon box to display
    2. the user has to input their AD username and password in them selves, not the SIMS username and password
    3. They cannot just click ok to logon.

    So, they click on sims.net -> log on box displays -> username: ADUsername Password: ADPassword


    Not what we are wanting:
    with the "connectiontype=trusted" added: you dont put in any ADusername & ADpassword, you Simply click ok. OR you log in with the SIMS.net username & password.

    with the "connectiontype=trustedauto" added: SIMS opens it self.


    Hope this makes sense.

  16. #14
    Vegas's Avatar
    Join Date
    Jul 2005
    Location
    Gloucestershire
    Posts
    374
    Thank Post
    21
    Thanked 38 Times in 31 Posts
    Rep Power
    36
    The only way I know to achieve this is to manually change you sims usernames to match your AD usernames

  17. #15

    timbo343's Avatar
    Join Date
    Dec 2005
    Location
    Leeds/York area, North Yorkshire
    Posts
    3,195
    Thank Post
    321
    Thanked 314 Times in 219 Posts
    Rep Power
    125
    I have posted a Change Request on the Capita website relating to this problem... If people could be be so kind and help me get this situation sorted out can you log into support.capitaes.co.uk. Hover over support and click on Change Request and type in this number... 0812-444118

    Thanks

    Tim Hobson



SHARE:
+ Post New Thread
Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 23
    Last Post: 3rd October 2009, 06:44 PM
  2. sending username and password via post
    By RabbieBurns in forum How do you do....it?
    Replies: 13
    Last Post: 17th June 2008, 11:31 PM
  3. Replies: 11
    Last Post: 30th October 2007, 07:05 PM
  4. Replies: 2
    Last Post: 23rd October 2007, 09:32 AM
  5. Replies: 3
    Last Post: 17th October 2007, 10:15 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •