OK, let's take a quick look at some of the SIMSPERM.BATfile...

take this line:

This means that the sims.ini file in your windows folder needs full permissions granted to your SIMS group.
(The %windir% is a system variable. To see all the system variables, open up a cmd window and type 'set' (without the quotes) and this will list all the variables)

So, in Active Directory, use the group policy management tool to create a new group policy. Call it something like SIMSSecurity.
In the policy, drill down to computer configuration/windows settings/Security settings/File system then right-click and choose 'add file'
Type in %windir%\sims.ini and set the security for the sims group to full rights.

Let's look at another line of the script:

This is a similar sort of thing, but concerning a registry key. Again, browse the policy object to computer configuration/windows settings/Security settings/registry and from here you can add registry keys you want to give rights to your SIMS group.
So it took me a while to sort it out but i think i finally have SIMS updating itself when users log in. I followed the above guide and linked the Policy to the Computer OU and it worked. Yey.

At first i tried to link the SIMSSecurity Policy to the Users OU to see if that worked but it did not. I thought it may be how i was applying the permissions at first so played with them. In the end i left them all at the first setting "apply permissions to inheritable files/folders. I think thats what its called.

This still did not work. I tried to enter the Registry key manually but could not click OK. You can't enter what is exactly written. You have to navigate down through the machine/software/classes etc and then choose that.

It was only when i linked the SIMSSecurity to the Computer OU that it worked.

I Hope that helps someone else if they need it. In the end it proved to be pretty simple. Just hadn't used the setting before so not sure how it worked entirely although i may need to tidy up some of the permission inheritance settings.

A big thanks to all of the help given from you guys. THANK YOU