+ Post New Thread
Results 1 to 8 of 8
MIS Systems Thread, FMS question, for those that run it in Technical; Hi guys, We use Sims .net and FMS (old SIMS), we have gotten sim .net to work via TS and ...
  1. #1
    wagnerk's Avatar
    Join Date
    Jun 2007
    Location
    Northants
    Posts
    792
    Thank Post
    61
    Thanked 160 Times in 131 Posts
    Rep Power
    44

    FMS question, for those that run it

    Hi guys,

    We use Sims .net and FMS (old SIMS), we have gotten sim .net to work via TS and VPN, however we are unable to get FMS to work via VPN, I don't really want to install FMS on our TS just yet.

    This is the error that I get when I try to run FMS via VPN:

    Unhandled Exception in SIMS FMS Module

    General SQL Error
    (Sybase)(ODBC Driver) Unable to conenct to database server:unable to start database engine
    Alias: dbInitialConnection


    Now if I connect internally, FMS works fine.

    If anyone has experienced this already, please let me know, if not I may have to install this onto my TS server..

    -Ken

    p.s. we use the TCP/IP protocol
    Last edited by wagnerk; 16th January 2008 at 03:13 PM. Reason: more info

  2. #2
    ChrisH's Avatar
    Join Date
    Jun 2005
    Location
    East Lancs
    Posts
    4,938
    Thank Post
    114
    Thanked 272 Times in 250 Posts
    Rep Power
    104
    Check the ODBC connection you are trying to run the program on. Make sure the path it is pointing to is as if its on the local server where the database is. The other thing that can cause it is file permissions. Also are you mapping the correct drives as well?

  3. #3

    Domino's Avatar
    Join Date
    Oct 2006
    Location
    Bromley
    Posts
    4,020
    Thank Post
    212
    Thanked 1,164 Times in 758 Posts
    Blog Entries
    4
    Rep Power
    481
    hmmm...could it be connected to LanID's?

  4. #4
    ChrisH's Avatar
    Join Date
    Jun 2005
    Location
    East Lancs
    Posts
    4,938
    Thank Post
    114
    Thanked 272 Times in 250 Posts
    Rep Power
    104
    I was told last week you dont need the LANIDs anymore but maybe if your using an older version?

  5. #5
    wesleyw's Avatar
    Join Date
    Dec 2005
    Location
    Kingswinford
    Posts
    2,202
    Thank Post
    223
    Thanked 50 Times in 44 Posts
    Blog Entries
    1
    Rep Power
    29
    You don't need LANID's for FMS. However there is no point in doing this if more than one person is going to use it remotely as until you've upgraded from sqlanywhere to MSSQL a lock file is created which means you would need to install a separate instance for every user that may want to connect via TS.

  6. #6
    wagnerk's Avatar
    Join Date
    Jun 2007
    Location
    Northants
    Posts
    792
    Thank Post
    61
    Thanked 160 Times in 131 Posts
    Rep Power
    44
    Hi guys,

    Quote Originally Posted by ChrisH View Post
    Check the ODBC connection you are trying to run the program on. Make sure the path it is pointing to is as if its on the local server where the database is. The other thing that can cause it is file permissions. Also are you mapping the correct drives as well?
    Thanks, checked that and it seems ok.

    Quote Originally Posted by Domino View Post
    hmmm...could it be connected to LanID's?
    Quote Originally Posted by ChrisH View Post
    I was told last week you dont need the LANIDs anymore but maybe if your using an older version?
    We haven't used lanID's since we upgraded to Sims .Net. FMS runs fine internally without them.

    Quote Originally Posted by wesleyw View Post
    You don't need LANID's for FMS. However there is no point in doing this if more than one person is going to use it remotely as until you've upgraded from sqlanywhere to MSSQL a lock file is created which means you would need to install a separate instance for every user that may want to connect via TS.
    Thanks for that.

    Thanks to all of you that are throwing things for me to check/do. We will not be defeated on this matter

    -ken

  7. #7
    sahmeepee's Avatar
    Join Date
    Oct 2005
    Location
    Greater Manchester
    Posts
    795
    Thank Post
    20
    Thanked 69 Times in 42 Posts
    Rep Power
    33
    There's a fairly hefty kb article on supportnet about these sorts of problems. You may be able to fix it by specifying the IP of the server in the connection string. I will try to dig up more details if you don't have a Supportnet acc set up

    EDIT: Hopefully there's no problem with me posting stuff from Supportnet on here. If there is I'm sure Phil will let me know and I'll edit it back out! Here are the suggested fixes for your error:

    Fix 1

    On the Server:

    1. At Start | Run type DBSVMN50


    2. If the service is not running, click the Start button to start service.


    3. If the service is running, check which protocols are being used by following the next fix:


    Fix 2


    On the Server:


    1. Stop the Database Server using Start | Run | DBSVMN50 and click Stop.


    2. At Start | Run type: DBSRV50 -n SIMS_Server


    This will try and broadcast on all protocols: make a note of which protocols are used.


    On the Workstation:


    1. At Start | Run type DBCLIENT -n SIMS_Server


    2. This will try all protocols and will display which are used


    3. Check if the protocol used by the client is also being used by the server, e.g TCPIP.


    Note: the server normally uses NamedPipes as a protocol to connect to itself.


    The protocol should be specified in the Database Server as follows:


    1. At Start | Run type: DBSVMN50 and open the SQL Anywhere Service Manager.


    2. Click Edit and then edit the parameter line. So, for example if protocols used are Named Pipes and TCP/IP it should read as follows:


    -n SIMS_Server -c 8192 -tl 1500 -x NamedPipes,TCPIP


    Note: The Service will need to be restarted for this to take effect.


    The protocol should be specified on the Client machine as follows:


    1. At Start | Run type: odbcad32


    2. Select the System DSN tab


    3. Select SIMS32


    4. Click the Configure button


    5. Click the Options button


    6. The parameter line for TCP/IP should read as follows:


    c:\sqlany50\win32\dbclient.exe -ta 600 -x TCPIP


    Fix 3


    Try pinging the IP address of the server from the workstation AND the IP address of the workstation from the server as follows:


    1. Start | Run | CMD


    2. Type PING [IP address of server/workstation]


    eg. Ping 192.168.2.1


    If two way connection is not possible this may be a problem with addressing on the network.


    Fix 4


    This error can also occur if the workstation or server are using 2 IP addresses, or are on a subnet. If this is the case, unplug, or disable one of the cards to confirm that this resolves the problem.


    To resolve the above issue, and other possible network issues, it is also possible to specify explicitly the hostname of the FMS Server the client is trying to connect to and for the FMS Server to only accept requests.


    To try this:


    1. Stop the Database Server using Start | Run type: DBSVMN50 and click Stop.


    2. On the Database Server at Start | Run type:


    dbsrv50 -n SIMS_server -x tcpip{Broadcast=FALSE}


    3. At the workstation at Start | Run type:


    dbclient -n SIMS_server -x TCPIP{host=10.128.2.226} (e.g ipaddress of Database Server)


    4. If both of these respond positively (server starts and dbclient can see server):


    5: At Start | Run type: DBSVMN50 and open the SQL Anywhere Service Manager.


    6: Click Edit and then Edit the parameter line. So, for example:


    -n SIMS_Server -c 8192 -tl 1500 -x NamedPipes,TCPIP{Broadcast=FALSE}


    Note: The Service will need to be restarted for this to take effect.


    The protocol should be specified on the Client machine as follows:


    1. At Start | Run type: odbcad32


    2. Select the System DSN tab


    3. Select SIMS32


    4. Click the Configure button


    5. Click the Options button


    6. The parameter line, for example should read as follows:


    c:\sqlany50\win32\dbclient.exe -ta 600 -x TCPIP{host=10.128.2.226}


    FIX 5


    The WIndows Firewall can interefere with FMS if enabled on the server machine. Please see KB38029 for instructions on adding exceptions to allow workstations to connect to an FMS server with Windows Firewall enabled.


    FIX 6
    Follow the route to the sims.db and check that System with Full control has been added if using NTFS

    right click on sims.db and select - Properties
    select - Security Tab
    click - [Add..]
    Type 'SYSTEM' into the object box, and then Check Names to verify
    click - [OK]
    Ensure that you Allow 'Full Control' for this SYSTEM user
    click - [OK]
    Each FMS user will also require 'Full Control' access rights to this file.
    Last edited by sahmeepee; 16th January 2008 at 06:44 PM. Reason: added kb info

  8. #8

    Join Date
    Nov 2007
    Location
    Cambridgeshire
    Posts
    2
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Oh, wow; i love this forum. Just come on to see if I can get a bit of help for a FMS6 issue after looking everywhere else - and 6 fixes are staring me in the face - and they worked!!!
    Thank you - I am a much relieved tech :-)

SHARE:
+ Post New Thread

Similar Threads

  1. Here's a question for you!
    By azrael78 in forum Hardware
    Replies: 15
    Last Post: 1st October 2007, 10:33 AM
  2. Win 2k PDC question
    By glennw in forum Windows
    Replies: 2
    Last Post: 27th September 2007, 12:17 PM
  3. dvd question
    By strawberry in forum Hardware
    Replies: 3
    Last Post: 24th August 2007, 04:17 PM
  4. Question
    By Elky in forum Recommended Suppliers
    Replies: 48
    Last Post: 7th November 2006, 01:02 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •