+ Post New Thread
Results 1 to 7 of 7
MIS Systems Thread, Deploying the SOLUS 3 Agent to Clients - Easy Way? in Technical; My brain has just died. We are starting now to looking to roll out and use Solus 3 on our ...
  1. #1

    tech_guy's Avatar
    Join Date
    May 2007
    Location
    That little bit in the middle of Little Old England
    Posts
    8,135
    Thank Post
    1,908
    Thanked 1,343 Times in 742 Posts
    Blog Entries
    3
    Rep Power
    395

    Deploying the SOLUS 3 Agent to Clients - Easy Way?

    My brain has just died.

    We are starting now to looking to roll out and use Solus 3 on our site. We tested initially with a half a dozen PCs with a manual install of the SOLUS 3 Agent and it works fine with no problems.

    However, as we have some 180-odd clients to work with, is there a way to deploy the firewallsolusrunthis.bat file provided by CAPITA other than manually on each machine? We canít seem to find a way to push this out to the machines via a GPO Ė the problem is that it needs to be run as Administrator.

    We donít really want to have to go round all the clients individually as we donít really have the time at the moment so your input would be much appreciated!

    Does anyone have another means / file at their disposal for making the necessary firewall changes that we can push out via a GPO? I can't think straight atm and everything I've tried goes pear-shaped (got a lot on my plate atm)

    Also if anyone has a new brain can I have it please?
    Last edited by tech_guy; 24th March 2014 at 12:20 PM.

  2. #2

    LeMarchand's Avatar
    Join Date
    Jan 2008
    Location
    The deepest pits of hell
    Posts
    2,169
    Thank Post
    303
    Thanked 332 Times in 236 Posts
    Rep Power
    141
    I thought that Startup (rather than login) scripts ran with Admin rights? Just checked at this site and that appears to be happening here with the Solus 3 .bat. (It's a load of netsh advfirewall add/set rule name/group commands).
    Last edited by ZeroHour; 24th March 2014 at 04:00 PM.

  3. #3
    fairm010's Avatar
    Join Date
    Jun 2010
    Location
    C:/Windows/System32/
    Posts
    1,143
    Thank Post
    47
    Thanked 146 Times in 128 Posts
    Rep Power
    45
    Startup runs as Local SYSTEM account yep.

    - - - Updated - - -

    Startup runs as Local SYSTEM account yep.

  4. #4

    synaesthesia's Avatar
    Join Date
    Jan 2009
    Location
    Northamptonshire
    Posts
    5,882
    Thank Post
    575
    Thanked 1,000 Times in 772 Posts
    Blog Entries
    15
    Rep Power
    461
    am I missing something? Is there a reason you don't use SOLUS3's push installation to active directory groups/containers?

    - - - Updated - - -

    am I missing something? Is there a reason you don't use SOLUS3's push installation to active directory groups/containers?

  5. #5

    LeMarchand's Avatar
    Join Date
    Jan 2008
    Location
    The deepest pits of hell
    Posts
    2,169
    Thank Post
    303
    Thanked 332 Times in 236 Posts
    Rep Power
    141
    Quote Originally Posted by synaesthesia View Post
    am I missing something? Is there a reason you don't use SOLUS3's push installation to active directory groups/containers?
    We had to run a script to set some firewall exceptions before S3 would install via the console.

    - - - Updated - - -

    Quote Originally Posted by synaesthesia View Post
    am I missing something? Is there a reason you don't use SOLUS3's push installation to active directory groups/containers?
    We had to run a script to set some firewall exceptions before S3 would install via the console.

  6. #6

    synaesthesia's Avatar
    Join Date
    Jan 2009
    Location
    Northamptonshire
    Posts
    5,882
    Thank Post
    575
    Thanked 1,000 Times in 772 Posts
    Blog Entries
    15
    Rep Power
    461
    I keep thinking we're doing something wrong because it always seems to easy; again, why scripts as opposed to GPO for such exceptions?

    - - - Updated - - -

    I keep thinking we're doing something wrong because it always seems to easy; again, why scripts as opposed to GPO for such exceptions?

  7. #7

    tech_guy's Avatar
    Join Date
    May 2007
    Location
    That little bit in the middle of Little Old England
    Posts
    8,135
    Thank Post
    1,908
    Thanked 1,343 Times in 742 Posts
    Blog Entries
    3
    Rep Power
    395
    Quote Originally Posted by LeMarchand View Post
    I thought that Startup (rather than login) scripts ran with Admin rights? Just checked at this site and that appears to be happening here with the Solus 3 .bat. (It's a load of netsh advfirewall add/set rule name/group commands).

    - - - Updated - - -

    I thought that Startup (rather than login) scripts ran with Admin rights? Just checked at this site and that appears to be happening here with the Solus 3 .bat. (It's a load of netsh advfirewall add/set rule name/group commands).
    Yes, that what I was expecting but something aint happening and I can't work out what atm

    - - - Updated - - -

    Quote Originally Posted by LeMarchand View Post
    I thought that Startup (rather than login) scripts ran with Admin rights? Just checked at this site and that appears to be happening here with the Solus 3 .bat. (It's a load of netsh advfirewall add/set rule name/group commands).

    - - - Updated - - -

    I thought that Startup (rather than login) scripts ran with Admin rights? Just checked at this site and that appears to be happening here with the Solus 3 .bat. (It's a load of netsh advfirewall add/set rule name/group commands).
    Yes, that what I was expecting but something aint happening and I can't work out what atm

    - - - Updated - - -

    Is there an echo in here?

    - - - Updated - - -

    Is there an echo in here?

SHARE:
+ Post New Thread

Similar Threads

  1. [SIMS] How to deploy solus 3 agent to a new machine
    By MrWu in forum MIS Systems
    Replies: 2
    Last Post: 25th September 2012, 05:43 PM
  2. [SIMS] [SOLUS3] - Adding the SOLUS3 Agent to a workstation image?
    By Rawns in forum MIS Systems
    Replies: 6
    Last Post: 31st January 2012, 12:18 PM
  3. Replies: 4
    Last Post: 10th January 2012, 06:33 PM
  4. How to Deploy the ICA Web Client Through Web Interface 4.5
    By cookie_monster in forum Thin Client and Virtual Machines
    Replies: 1
    Last Post: 30th April 2009, 11:14 AM
  5. Replies: 1
    Last Post: 28th August 2008, 03:13 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •