+ Post New Thread
Results 1 to 11 of 11
MIS Systems Thread, Overview type of question regarding getting specific aspect results out of the CLR in Technical; Hi Guys, Is there a simple way to get a list specific aspect results out of the general SIMS reporting ...
  1. #1

    Join Date
    Sep 2011
    Location
    Southampton
    Posts
    13
    Thank Post
    3
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Question Overview type of question regarding getting specific aspect results out of the CLR

    Hi Guys,

    Is there a simple way to get a list specific aspect results out of the general SIMS reporting mechanism, ultimately by the CLR?

    Ideally in a Student focussed report I would like to include the results for a number of specifically named aspects from the assessment manager. I can't find any obvious way to do this. I would like to be able to specify the aspect name at run time which would be supplied from a script elsewhere which I have done for other reports.

    I can't even find an obvious route to this via a new report based on a focus from the assessment manager list. I've tried looking at Resultset, Gradeset, Result and Aspect but as usual with SIMS it is completely unintuitive.

    Maybe I see this as a simple task in my head - get the results of specified aspects for all the students in a student focussed report - but apparently it is not.

    Can anyone at least point me in the direction of what documentation or walkthroughs or tips might be helpful? For example I couldn't find any way to produce the aspect name filter from this post 113407-how-would-you-do-sims-gurus from @LosOjos.

    Any thoughts gratefully received.

    Polski

  2. #2

    Join Date
    Sep 2006
    Location
    Reading
    Posts
    177
    Thank Post
    14
    Thanked 41 Times in 39 Posts
    Rep Power
    23
    aspects.png
    Not sure if this helps but I use the approach outlined above to get specific results into normal reports in SIMs that are fed into customised Excel templates to do all of the work.
    You can get any data you want so long as you can identify the aspect, result set etc.

  3. Thanks to number34 from:

    DoctorPolski (26th February 2014)

  4. #3

    vikpaw's Avatar
    Join Date
    Sep 2006
    Location
    Saudi Arabia
    Posts
    5,887
    Thank Post
    749
    Thanked 1,466 Times in 1,218 Posts
    Rep Power
    364
    A Sub-report on assessment is how we do it (as No.34 ^ ). If your naming convention is good enough, you can even just put in an aspect name starts with 'gcse..' or something like that, unless you really want to cherry pick the names. We normally also have to tie these to a resultset too, but they can be picked from a combo box so are easier to deal with.

  5. #4

    Join Date
    Mar 2011
    Location
    Bristol
    Posts
    136
    Thank Post
    27
    Thanked 26 Times in 22 Posts
    Rep Power
    18
    Does anyone else find that adding multiple sub reports (particular assessment results) increases the time the reports takes to run exponentially? Or is this just our environment?

    For this reason I tend to avoid having to run aspect reports like this, unless I only want 1 or 2 results.
    Last edited by Ecclesbury; 26th February 2014 at 03:42 PM.

  6. #5

    Join Date
    Sep 2011
    Location
    Southampton
    Posts
    13
    Thank Post
    3
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    @number34 that is exactly the kind of thing I expected to see. However, when I access the Assessment Results sub-report I only see Aspect and Resultset details which are the last 2 items on your list. Probably a permissions issue?

  7. #6

    LosOjos's Avatar
    Join Date
    Dec 2009
    Location
    West Midlands
    Posts
    5,664
    Thank Post
    1,484
    Thanked 1,263 Times in 857 Posts
    Rep Power
    803
    Quote Originally Posted by Ecclesbury View Post
    Does anyone else find that adding multiple sub groups (particular assessment results) increases the time the reports takes to run exponentially? Or is this just our environment?

    For this reason I tend to avoid having to run aspect reports like this, unless I only want 1 or 2 results.
    Adding any type of sub report definitely increases run time. For this reason, I try to make my reports as broad as possible and do additional filtering outside of SIMS if needed (e.g. run a report for all my target aspects, then pick out the specific ones I want after the fact)

  8. #7

    Join Date
    Sep 2006
    Location
    Reading
    Posts
    177
    Thank Post
    14
    Thanked 41 Times in 39 Posts
    Rep Power
    23
    Quote Originally Posted by DoctorPolski View Post
    @[URL="http://www.edugeek.net/members/number34.html"]... Probably a permissions issue?
    Maybe that, I am in the Assessment managers group and have green ticks against all of the options. worth checking perhaps?

  9. #8

    Join Date
    Sep 2011
    Location
    Southampton
    Posts
    13
    Thank Post
    3
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    @number34 I've just had Assessment Operator added to my list of privileges and I now get the same list as you and can run precisely the report I need too. Thanks again.

  10. #9

    vikpaw's Avatar
    Join Date
    Sep 2006
    Location
    Saudi Arabia
    Posts
    5,887
    Thank Post
    749
    Thanked 1,466 Times in 1,218 Posts
    Rep Power
    364
    There's a small permission needed to read results which can be given to all staff so anyone can run your final report.

  11. #10

    Join Date
    Sep 2011
    Location
    Southampton
    Posts
    13
    Thank Post
    3
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Hey vikpaw,

    In this case that won't be needed as the report will be run via the CLR via an account with the relevant credentials. But thanks as ever for everyone's input.

    [OT] How do you get the [ mention ]***[ /mention ] tags to work? At least on my message previews I see just an @ with no text after it.

  12. #11

    vikpaw's Avatar
    Join Date
    Sep 2006
    Location
    Saudi Arabia
    Posts
    5,887
    Thank Post
    749
    Thanked 1,466 Times in 1,218 Posts
    Rep Power
    364
    Quote Originally Posted by DoctorPolski View Post
    Hey vikpaw,

    In this case that won't be needed as the report will be run via the CLR via an account with the relevant credentials. But thanks as ever for everyone's input.

    [OT] How do you get the [ mention ]***[ /mention ] tags to work? At least on my message previews I see just an @ with no text after it.
    Sometimes the preview won't show the final parsed output.
    If you just click reply with quote, you should see the syntax it is using at least.
    Also, the button on the end will let you multi-quote and pick a few posts to include before you click the final reply-with-quote post.



SHARE:
+ Post New Thread

Similar Threads

  1. Replies: 17
    Last Post: 11th March 2011, 02:48 PM
  2. Question regarding screensavers
    By malcolm_kapadia in forum Windows
    Replies: 4
    Last Post: 20th October 2009, 11:21 AM
  3. WSUS - small question regarding GPO's
    By DanW in forum Windows
    Replies: 4
    Last Post: 10th April 2008, 03:12 PM
  4. Tips to (not) get the most out of your IT department
    By sidewinder in forum General Chat
    Replies: 74
    Last Post: 14th January 2008, 02:04 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •