+ Post New Thread
Page 2 of 2 FirstFirst 12
Results 16 to 29 of 29
MIS Systems Thread, Microsoft .net 4.5.1 update borking SIMS.net- anyone else? in Technical; I've had SIMS running on .NET 4.5 for quite some time now. Not sure if WSUS dishes out the 4.5.1 ...
  1. #16

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    9,262
    Thank Post
    242
    Thanked 1,572 Times in 1,252 Posts
    Rep Power
    340
    I've had SIMS running on .NET 4.5 for quite some time now. Not sure if WSUS dishes out the 4.5.1 update as yet as standard.

  2. #17

    3s-gtech's Avatar
    Join Date
    Mar 2009
    Location
    Wales
    Posts
    2,821
    Thank Post
    146
    Thanked 572 Times in 516 Posts
    Rep Power
    154
    I can confirm that we have 4.5.1 site-wide and SIMS is working fine. It does sound like there is a common issue though, which Capita need to look at.

  3. #18
    timbo343's Avatar
    Join Date
    Dec 2005
    Location
    Leeds/York area, North Yorkshire
    Posts
    3,035
    Thank Post
    305
    Thanked 293 Times in 203 Posts
    Rep Power
    120
    Still broken on my machine too with .net 4.5.1

  4. #19

    Join Date
    Sep 2006
    Location
    London
    Posts
    1,332
    Thank Post
    36
    Thanked 353 Times in 238 Posts
    Rep Power
    79
    We have a very small number of cases raised on this issue but cannot reproduce the issue which makes it very difficult to resolve. There seems to be a security addition in 4.5.1 that affects certain sites.

  5. #20

    Join Date
    Sep 2006
    Location
    London
    Posts
    1,332
    Thank Post
    36
    Thanked 353 Times in 238 Posts
    Rep Power
    79
    A little more detail from the service desk:

    What we can confirm is that basic .Net Framework 4.5.1 with no updates works with SIMS, however, a security update released by Microsoft causes a conflict

    As we donít know which security update is causing the issue we canít confirm anything in terms of dates compared to our testing etc (one of the comments on the post was regarding us not testing, we wanted to know if the update came out after the release which would mean that no amount of testing would have found it).

    The only other thing to say is SIMS is intended to work with .Net framework 4, and we see no need to upgrade to 4.5.1 so all our testing would be done using .Net framework 4Ö although other things on the same server might need it, and we donít explicitly not support 4.5.1

    The issue relating to .net framework 4.5.1 has been seen by the Service Desk and we have created a KB (KB404647) to allow us to keep everyone informed of the latest information and provide a basic workaround.

    This problem is very intermittent in its nature and has only occurs after an upgrade to .net 4.5.1 which we believe may be caused by a security update. To help us identify which update, and ultimately resolve the issue, can I please ask that you log incidents on the Service Desk (sims.support@capita.co.uk) which will allow us to isolate where the issue is and then produce a permanent fix. At present we only have a few examples to work on, so the more information that we are provided with the quicker we can resolve it.

  6. #21

    vikpaw's Avatar
    Join Date
    Sep 2006
    Location
    Saudi Arabia
    Posts
    6,009
    Thank Post
    680
    Thanked 1,398 Times in 1,158 Posts
    Rep Power
    353
    As it's not a blanket issue affecting all machines on a given site, i'd suspect it's a problem with the install or some conflict with other software that may be at fault.
    I don't think it's on my server, but the desktop clients have 4.5.1 and we've not had an issue.
    I'd want to see what happens when the affected machines are totally reinstalled, and set up the same way as other machines that do work.

  7. #22

    Join Date
    Dec 2012
    Posts
    10
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    We've been told that the only solution is to remove .Net 4.5.1 and install v4.5. We've installed the following reg key to stop the 4.5.1 update:

    Windows Registry Editor Version 5.00


    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP\WU]
    "BlockNetFramework451"=dword:00000001

  8. #23
    eejit's Avatar
    Join Date
    Jun 2005
    Location
    Ireland
    Posts
    606
    Thank Post
    52
    Thanked 12 Times in 12 Posts
    Rep Power
    22
    Hi guys,
    I see that 4.5.2 is out this morning. Anyone in a position to test that with SIMS?
    I don't have a machine that definitely doesn't work with 4.5.1 or I'd give it a go myself.

  9. #24
    timbo343's Avatar
    Join Date
    Dec 2005
    Location
    Leeds/York area, North Yorkshire
    Posts
    3,035
    Thank Post
    305
    Thanked 293 Times in 203 Posts
    Rep Power
    120
    Whoop!!!! SIMS is now working again on my machine with 4.5.2 installed!!! Dont have to keep logging onto the server just to use SIMS anymore.

  10. Thanks to timbo343 from:

    eejit (7th May 2014)

  11. #25

    Join Date
    Sep 2006
    Location
    London
    Posts
    1,332
    Thank Post
    36
    Thanked 353 Times in 238 Posts
    Rep Power
    79
    Microsoft had said this was caused by a conflict with network stack components injected by 3rd Party applications (most commonly Antivirus or Firewall products). The Microsoft KB article suggested that they viewed this as a bug in the 3rd Party software, not in the framework, and were not intending to fix it. Based on this the guidance the service desk directed customers with the issue to the KB article, which provided a process for determined the likely source of the faulty component.

    It appears that 4.5.2 fixes the issue, so perhaps Microsoft have revised their stance. We’ll see what we can find out.

  12. #26

    matt40k's Avatar
    Join Date
    Jun 2008
    Location
    Ipswich
    Posts
    4,433
    Thank Post
    368
    Thanked 646 Times in 528 Posts
    Rep Power
    159
    Quote Originally Posted by PhilNeal View Post
    The Microsoft KB article suggested that they viewed this as a bug in the 3rd Party software, not in the framework
    ...and the KB is....

  13. #27

    Join Date
    Sep 2006
    Location
    London
    Posts
    1,332
    Thank Post
    36
    Thanked 353 Times in 238 Posts
    Rep Power
    79

  14. Thanks to PhilNeal from:

    matt40k (9th May 2014)

  15. #28

    matt40k's Avatar
    Join Date
    Jun 2008
    Location
    Ipswich
    Posts
    4,433
    Thank Post
    368
    Thanked 646 Times in 528 Posts
    Rep Power
    159
    Bah, pesky third party client firewalls strikes again! Seems Sophos has a KB - How to fully disable the Sophos LSP

    Be interesting if the affect machines reports as having two firewalls (Windows and the AV).

  16. #29

    Join Date
    Sep 2006
    Location
    London
    Posts
    1,332
    Thank Post
    36
    Thanked 353 Times in 238 Posts
    Rep Power
    79

SHARE:
+ Post New Thread
Page 2 of 2 FirstFirst 12

Similar Threads

  1. [SIMS] SIMS.NET AUTUMN UPDATE
    By tech_guy in forum MIS Systems
    Replies: 4
    Last Post: 30th September 2013, 09:06 PM
  2. Replies: 4
    Last Post: 20th April 2010, 03:02 PM
  3. SIMS.net July update?
    By kingswood in forum MIS Systems
    Replies: 12
    Last Post: 10th July 2007, 11:54 AM
  4. SIMS.net September Update - Do you dare!
    By NetworkGeezer in forum MIS Systems
    Replies: 16
    Last Post: 10th October 2006, 10:06 PM
  5. Sims.net May Update
    By Sylv3r in forum MIS Systems
    Replies: 14
    Last Post: 5th June 2006, 08:17 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •