+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 16
MIS Systems Thread, [SIMS] Solus 3 Agents Stuck in Technical; Hi All, Recently began moving towards Solus 3, and naturally assumed I could add all of my teacher machines in ...
  1. #1

    Join Date
    Jun 2013
    Posts
    13
    Thank Post
    5
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    [SIMS] Solus 3 Agents Stuck

    Hi All,

    Recently began moving towards Solus 3, and naturally assumed I could add all of my teacher machines in one fell swoop. This of course resulted in the deployment service crashing and once restarted, I cannot do anything with the machines listed apart from Check Agent Status which fails as no agent is installed.

    The options to do anything are greyed out, with all of the client Agent Status being listed as: Install Active but I cannot stop, restart, remove, or do anything.

    The one way around it I have found is to manually go to the client, install Solus3 Agent manually, refresh the agent status so Solus UI can see it, try to uninstall from Solus UI which fails, this then allows me to remove computer, I can then manually remove the agent from the client, and finally re-add the computer to Solus and the Agent pushs out. A solution, but a very bad one on 150 computers.

    Is there some way to forcefully remove Agents from the Solus 3 Deployment UI?

  2. #2
    Guest

    Join Date
    Jun 2009
    Posts
    3,754
    Thank Post
    1,458
    Thanked 489 Times in 375 Posts
    Rep Power
    0
    Not when they have a status of Install Active. They are essentially stuck in limbo. Capita ESS have a tool that contains a number of SOLUS3 tools, one of them being a button that will modify the database entries and reset all 'Install Active' agents to 'Install Failed' allowing you to either remove them manually or use the reinstall function.

    Last edited by Rawns; 2nd October 2013 at 02:59 PM.

  3. Thanks to Rawns from:

    MrPARRman (3rd October 2013)

  4. #3

    Join Date
    Jun 2013
    Posts
    13
    Thank Post
    5
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Hmm. I did have a good search, and the ESSUpgrade tool does not appear to still be live on any links. Also phoned Capita and am now stuck waiting another indefinite amount of time. Do you have a link for that piece of software?

    At this point I am starting to wonder why I bothered upgrading... Solus 2 always seemed to just work. Tell staff an upgrade is going to occur, remote in and run upgrade overnight on the server, staff come in next day and SIMS takes a extra few minutes while it upgrades, the world keeps on spinning.

    We don't run any POL, and users use machines at varying times each day so it would be almost impossible to get all computers with one update - Is there any real advantage to upgrading to this new system?

    My only reason thus far was being told that we need it to install SIMs Discover... now I read Capita provide a MSI. One more issue away from a downgrade I fear.

  5. #4
    Guest

    Join Date
    Jun 2009
    Posts
    3,754
    Thank Post
    1,458
    Thanked 489 Times in 375 Posts
    Rep Power
    0
    I got it from @matt40k who kindly shared a link in this post: SOLUS3 RAGE!!!. If the link is dead, I would imagine that Capita could provide you with a copy.

    SOLUS2 End of Life is Spring next year and it will be no more. Though it really would not surprise me if it gets extended again...

  6. Thanks to Rawns from:

    MrPARRman (3rd October 2013)

  7. #5

    Join Date
    Jun 2013
    Posts
    13
    Thank Post
    5
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    That's the thread I found and the link is dead. :-(

    I am really at a loss - maybe I am jumping the gun but are there any advantages to this new version? Can I use Solus3 like I do Solus2, and just use it to upgrade the server and have the clients upgrade on there own? Seems like madness to have a system with so many points of failures. If the updates need to be pushed to each client, and the clients cannot be set to automatically update when first ran, every update would need me to run around and turn on every machine on site.

    Think I have had enough SIMS for one day.

  8. #6

    matt40k's Avatar
    Join Date
    Jun 2008
    Location
    Ipswich
    Posts
    4,377
    Thank Post
    368
    Thanked 637 Times in 519 Posts
    Rep Power
    158
    Looks like Capita ESS removed it, guess Capita CS got too much flack for it. Pretty sure it's on SupportNet??

    S3 better in the long run, especially as permissions get worse - no more giving staff local admin rights, running batch files, turning off UAC.

  9. #7

    Join Date
    Jun 2013
    Posts
    13
    Thank Post
    5
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Can anyone with this little application upload it for me please?

    Phoned Capita again and the only people available are their first line support who sound like they know Solus only in name.

  10. #8
    Guest

    Join Date
    Jun 2009
    Posts
    3,754
    Thank Post
    1,458
    Thanked 489 Times in 375 Posts
    Rep Power
    0
    Quote Originally Posted by MrPARRman View Post
    Can anyone with this little application upload it for me please?

    Phoned Capita again and the only people available are their first line support who sound like they know Solus only in name.
    Sorry, but I don't think we are allowed to as it's a in house Capita product. We we provided with a copy to fix a few SOLUS3 issues on condition we keep don't pass it on. The fact that it's also been taken down suggests that they no longer want it shared. I'd guess the Capita help desk is your best bet.

    I can tell you though which table and values it changes in the SOLUS3 database so you can manually fix it through SQL management studio? Obviously not a "supported" procedure though.

  11. Thanks to Rawns from:

    MrPARRman (3rd October 2013)

  12. #9

    Join Date
    Jun 2013
    Posts
    13
    Thank Post
    5
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    That would be fantastic if you could! :-)

  13. #10
    Guest

    Join Date
    Jun 2009
    Posts
    3,754
    Thank Post
    1,458
    Thanked 489 Times in 375 Posts
    Rep Power
    0
    You can run this SQL script via SQL Management Studio:

    Code:
    USE solus3_deployment_server
    GO
    UPDATE solus3.agent
    SET agent_status='16'
    WHERE agent_status='8'
    It resets all agents with a status of '8' (Install Active) to a status of 16 (Install Failed) allowing you to remove/reinstall. If you do this, back up your SOLUS3 database first as back end editing like this is unsupported by Capita (I would imagine).
    Last edited by Rawns; 3rd October 2013 at 09:18 AM.

  14. 2 Thanks to Rawns:

    MrPARRman (3rd October 2013), Sylv3r (3rd October 2013)

  15. #11

    Join Date
    Jun 2013
    Posts
    13
    Thank Post
    5
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Woohoo, that fixed the issue. All stuck users now showing as Install Failed and can be removed... one by one, but they can be removed! Thank you for the help!

    I think this thread now has the only solution on the internet to this issue that is active.

  16. #12
    Guest

    Join Date
    Jun 2009
    Posts
    3,754
    Thank Post
    1,458
    Thanked 489 Times in 375 Posts
    Rep Power
    0
    Be warned that 'some' devices may have actually had the agent successfully installed and when (or if) you re-add them and the agent has installed, it may return a message saying an unknown agent is already on this workstation. You'll have to uninstall the agent manually off the workstation, remove the workstation from SOLUS3 UI and then re-add it.

  17. #13
    Guest

    Join Date
    Jun 2009
    Posts
    3,754
    Thank Post
    1,458
    Thanked 489 Times in 375 Posts
    Rep Power
    0
    Also if you do re-add the devices into SOLUS3, as @matt40k reiterated to me many a time in previous threads, add a handful of devices at a time (10 max I'd say). There is less chance of the SOLUS3 Deployment Service becoming "overloaded" again when deploying the agents.

  18. #14

    Join Date
    Jun 2013
    Posts
    13
    Thank Post
    5
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    It looks here like the service failed almost instantly as I have yet to come across any where it had installed. I found with ones it did manage to install but didnt show, I could request the agent information and it would respond eventually and the remaining Install Active clients returned could not be contacted.

    Think the issue is due to the UI waiting for install confirmation from the Agent, and on a failed install never receiving anything back as if I manually visited the machine and installed the agent - it would suddently reply and show as ok. (Altho not able to check status of any installed roles.)

    Its all sorted now though, with those 5 lines my sanity returned and I am up to 90 clients successfully installed doing 10 at a time. Only another 100 to go.

  19. #15
    Guest

    Join Date
    Jun 2009
    Posts
    3,754
    Thank Post
    1,458
    Thanked 489 Times in 375 Posts
    Rep Power
    0
    @MrPARRman - For info, @matt40k has created a utility to reset 'Install Active' agents: SOLUS3 - Reset 'Install Active' Agents Utility by Matt40k

SHARE:
+ Post New Thread
Page 1 of 2 12 LastLast

Similar Threads

  1. [SIMS] Solus Agent Service wont start
    By Solus in forum MIS Systems
    Replies: 0
    Last Post: 1st May 2013, 02:46 PM
  2. [SIMS] SIMS Solus 3 bypassed for a manual install
    By winng in forum MIS Systems
    Replies: 4
    Last Post: 14th September 2012, 11:04 AM
  3. [SIMS] SOLUS Agent Flashing
    By NortyUK in forum MIS Systems
    Replies: 2
    Last Post: 11th January 2012, 12:05 PM
  4. SIMS SOLUS update failures
    By TheFopp in forum MIS Systems
    Replies: 5
    Last Post: 25th June 2008, 09:33 PM
  5. Proposed changes to SIMS SOLUS require firewall exceptions
    By NetworkGeezer in forum MIS Systems
    Replies: 2
    Last Post: 25th April 2007, 10:27 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •