+ Post New Thread
Results 1 to 7 of 7
MIS Systems Thread, SOLUS3 Agent tip in Technical; Apart from not installing it or giving it a boot in the funderments, came across a way to make life ...
  1. #1
    Ghostgame's Avatar
    Join Date
    Jun 2012
    Location
    Ipswich
    Posts
    281
    Thank Post
    30
    Thanked 66 Times in 39 Posts
    Rep Power
    20

    Lightbulb SOLUS3 Agent tip

    Apart from not installing it or giving it a boot in the funderments, came across a way to make life easier when trying to install the SOLUS3 agent on workstations on a school which does not have a domain or has separate domains (e.g admin and curric).
    Thought I would share the knowledge (even if it is simple) seeing as SOLUS3 is eventually going to become the only way to update SIMS software.

    1.Export the agent installer as usual from S3 System Settings.
    2.Edit the Solus3AgentInstaller.bat file.
    3.Replace the server name and domain with the server IP address.
    4.Use the .bat file to install the S3 agent manually.

    Once installed on the workstation you should be able to see it in the S3 console and add it into a channel.
    As usual make sure you have firewall exceptions or the firewall turned off.
    Quite good if someone wants to put a S3 agent on at least 20+ curriculum workstations.

    If anyone has a better way of putting S3 agents on workstations please post

  2. #2

    Steve21's Avatar
    Join Date
    Feb 2011
    Location
    Swindon
    Posts
    2,694
    Thank Post
    335
    Thanked 515 Times in 483 Posts
    Rep Power
    179
    How would that work with the seperate domain version? If the clients can't connect to the other domain. Or is this only for seperate domains, but not seperate IPs/VLAN etc?

    Pretty much every school here has two seperate IPs from the council switches, one for admin, one for curriculum. Most larger schools flattened it all to one, but the primaries/juniors still running split on a few.

    Steve

  3. #3
    Guest

    Join Date
    Jun 2009
    Posts
    3,754
    Thank Post
    1,458
    Thanked 489 Times in 375 Posts
    Rep Power
    0
    Quote Originally Posted by Ghostgame View Post
    Give it a boot in the funderments.
    I correct your post for you. Your welcome.

  4. Thanks to Rawns from:

    Ghostgame (1st July 2013)

  5. #4
    Ghostgame's Avatar
    Join Date
    Jun 2012
    Location
    Ipswich
    Posts
    281
    Thank Post
    30
    Thanked 66 Times in 39 Posts
    Rep Power
    20
    This is where my knowledge falls short not being in charge of a schools network.

    My understanding is if the workstation can ping the server on another domain, then this idea should work.
    Seems like I need to do a bit more research.

    Cheers @Rawns
    My spelling is bad even with the help of a computer.

  6. #5

    Steve21's Avatar
    Join Date
    Feb 2011
    Location
    Swindon
    Posts
    2,694
    Thank Post
    335
    Thanked 515 Times in 483 Posts
    Rep Power
    179
    Quote Originally Posted by Ghostgame View Post
    This is where my knowledge falls short not being in charge of a schools network.

    My understanding is if the workstation can ping the server on another domain, then this idea should work.
    Seems like I need to do a bit more research.

    Cheers @Rawns
    My spelling is bad even with the help of a computer.
    Unless I'm being silly the computers wouldn't have authentication to access the shares/data etc on the other domain (Think of it as not having a logon for the network), and if like here they have seperate IP ranges they aren't even pingable without work on the switches.

    If the domains were trusted you can install solus directly from the SIMs side as it would have full access everywhere.

    If it's standalone computers without a domain I'm guessing it would work as you said, just not sure how that works with the seperate domains, but hey I may be being dumb on a monday and missing the obvious

    Steve

  7. #6
    Ghostgame's Avatar
    Join Date
    Jun 2012
    Location
    Ipswich
    Posts
    281
    Thank Post
    30
    Thanked 66 Times in 39 Posts
    Rep Power
    20
    This idea was a solution to a problem I was getting with SOLUS3 on at a school.

    Basically the wanted SOLUS3 on a number of curric laptops (groan)
    We found that putting the IP address in S3 agent search resolved the name from the different domain and it could be added.
    You could not install the agent as you got the error "Unable to get IP address"
    It was by installing the SOLUS3 agent manually and then changing the server name with IP address in S3 agent config file that we got it to work properly.

    I'm not sure how they have their domains set up but this was the only way we could get the S3 agent to show up in the S3 console to add it into the SIMS channel.

  8. #7

    matt40k's Avatar
    Join Date
    Jun 2008
    Location
    Ipswich
    Posts
    4,406
    Thank Post
    368
    Thanked 639 Times in 521 Posts
    Rep Power
    158
    Yer your right, @Steve21 would only work if it was the same IP range, or your nice friendly lovely LA setup inter-VLAN routing

    Depends on the hardware however, I know from a few cases it would have to routed at the LA core, which is no good as your traffic would be leaving your network only to return with a butt load of latency. In most cases the hassle of flattening the network vs the cost of a good lv3 core switch might make the single IP range a good idea.
    @Ghostgame - you might want to add the firewall rules to the script maybe?

SHARE:
+ Post New Thread

Similar Threads

  1. [SIMS] [SOLUS3] Agent installed, device online, no agent version!
    By Rawns in forum MIS Systems
    Replies: 2
    Last Post: 10th January 2013, 04:55 PM
  2. [SIMS] [SOLUS3] - Adding the SOLUS3 Agent to a workstation image?
    By Rawns in forum MIS Systems
    Replies: 6
    Last Post: 31st January 2012, 12:18 PM
  3. [SIMS] Solus3 Agent will not install on server [Solved]
    By ianswalker in forum MIS Systems
    Replies: 12
    Last Post: 22nd December 2011, 01:59 PM
  4. [SIMS] Installing Solus3 Agents manually - problems
    By neathneathneath in forum MIS Systems
    Replies: 15
    Last Post: 24th August 2011, 08:45 PM
  5. [SIMS] Solus3 agent stop FMS from loading
    By adamf in forum MIS Systems
    Replies: 1
    Last Post: 5th June 2011, 09:24 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •