+ Post New Thread
Results 1 to 12 of 12
MIS Systems Thread, Moved Solus3 to new server in Technical; Hello I have had to move SOLUS3 to a new server which I have done following KB115891 and all has ...
  1. #1
    tech-man's Avatar
    Join Date
    Jul 2005
    Location
    The Pub
    Posts
    171
    Thank Post
    13
    Thanked 17 Times in 11 Posts
    Rep Power
    21

    Moved Solus3 to new server

    Hello

    I have had to move SOLUS3 to a new server which I have done following KB115891 and all has gone well. I am trying to remove the old server from the "SOLUS3 Agents" screen however when I click the remove computer I receive the following error:

    Solus remove error.jpg

    Does anyone know how I can clear this up?

    Thanks!

  2. #2
    Guest

    Join Date
    Jun 2009
    Posts
    3,754
    Thank Post
    1,458
    Thanked 491 Times in 375 Posts
    Rep Power
    0
    Yep, you cant remove the old server as it's had the UI against it.

    Does your new server have the same name as the old one, or is it different?

    If it has the same name:

    Load SQL Server management Studio, expand the SOLUS3 database > Tables, right click and select edit top 200 rows for the SOLUS3.Agent table. Find the old server in the list and in the agent_status cell for the old server, change the value from 2 (Offline) to 16 (Install Failed) and save. Back in the SOLUS3 UI, under the SOLUS3 Agents screen, the old server's status should now be listed as 'Install Failed' allowing you to highlight it and click on Reinstall Agent. SOLUS3 will now reinstall the agent onto the new server and you won't lose any links that have been set up in the your environment.

    If the server name is different:

    When you changed the Deployment Service Host Computer in the UI, it should have prompted you to install a new SOLUS3 agent. Load SQL Management Studio, expand the SOLUS3 database > Tables, right click and edit top 200 rows for the SOLUS3.Agent table. Find the old server in the list and make a note of the GUID for the server name and copy this. Go to c:\program files\Solus3\AgentService and edit the following file: Sims.Solus3.Agent.AgentService.exe.config

    Find where is says <agentInfo agentId="{ and replace the GUID with the one copied from Management Studio. Save and then restart the SOLUS3 Agent service.

    Back in SQL Server Management Studio expand the SOLUS3 database > Tables, right click and edit top 200 rows for the SOLUS3.Agent table. Find the new server in the list and edit the agent_status column to 16. Back in the SOLUS3 UI, this will now show the new server as having a status of agent install failed and the old server (with all the enviroment paramaters set) as back on-line. Remove the new computer. The computer name in SOLUS3 should automatically update to reflect the new server name. If not, back in SQL Server Management Studio in the SOLUS3.Agent table edit the name of the old server to reflect the name of the new server.
    Last edited by Rawns; 8th May 2013 at 04:19 PM.

  3. Thanks to Rawns from:

    tech-man (8th May 2013)

  4. #3

    matt40k's Avatar
    Join Date
    Jun 2008
    Location
    Ipswich
    Posts
    4,445
    Thank Post
    369
    Thanked 650 Times in 531 Posts
    Rep Power
    160
    What did I tell you @tech-man!! If you can't remove the UI, that's why I said you don't install it on your machine - cause this would happen more often. Have you logged a call cause Nick should be able to remote in and do it directly in the db.

  5. #4
    tech-man's Avatar
    Join Date
    Jul 2005
    Location
    The Pub
    Posts
    171
    Thank Post
    13
    Thanked 17 Times in 11 Posts
    Rep Power
    21
    Matt, had to move SIMS to another server because of the .net issue I then had to move SOLUS with it... Spoke to Nick but he's snowed said I'd post on here as well...

  6. #5
    tech-man's Avatar
    Join Date
    Jul 2005
    Location
    The Pub
    Posts
    171
    Thank Post
    13
    Thanked 17 Times in 11 Posts
    Rep Power
    21
    Thanks RAWNS will look at that...

  7. #6

    matt40k's Avatar
    Join Date
    Jun 2008
    Location
    Ipswich
    Posts
    4,445
    Thank Post
    369
    Thanked 650 Times in 531 Posts
    Rep Power
    160
    Ah yer, forgot about that little gem, sorry mate. Yer spoke with Nick on the way out, lots of teething issues at the mo. I assume you are renaming the server to match the former? What did you end up doing, install S3 then restoring the DB? Assuming so, doing like @Rawns said about setting then agent to failed then redeploying will sort it out.

  8. #7
    tech-man's Avatar
    Join Date
    Jul 2005
    Location
    The Pub
    Posts
    171
    Thank Post
    13
    Thanked 17 Times in 11 Posts
    Rep Power
    21
    Hi @Rawns

    The new SOLUS3 server has an agent installed on it already and appears in agents and is apparently responsible for the user interface as well as database etc. Still cant remove the old SOLUS3 server after failing it. Do you have any other ideas?

    Thanks

  9. #8
    Guest

    Join Date
    Jun 2009
    Posts
    3,754
    Thank Post
    1,458
    Thanked 491 Times in 375 Posts
    Rep Power
    0
    Quote Originally Posted by tech-man View Post
    Hi @Rawns

    The new SOLUS3 server has an agent installed on it already and appears in agents and is apparently responsible for the user interface as well as database etc. Still cant remove the old SOLUS3 server after failing it. Do you have any other ideas?

    Thanks
    Again, is the server name the same or different to the old one?

    You can't remove the server agent from the UI despite the server having the same name or a different name. You have to reuse the server entry and not add a brand new agent entry. You have to either re-deploy the agent to the server after marking it as failed in the database (if the new server name is the same as the old one),

    or

    If the server has a new name, once you load the UI and update the settings to reflect the new name, it will prompt you to install a new SOLUS3 agent on the server. You will then have two servers listed, the old (offline, with the SOLUS3 UI protection against it) and the new (online). The old one has all the SIMS/FMS database, sql, workstation settings etc set up and the new server entry will have nothing. You then have to get the GUID of the old offline server from the DB and put it into the new SOLUS3 agent config file and restart the agent. This will cause the old server entry to now come back online and the new server to go offline. You can then remove the offline new entry which has no settings against it so you can remove it without errors.

  10. Thanks to Rawns from:

    tech-man (9th May 2013)

  11. #9
    tech-man's Avatar
    Join Date
    Jul 2005
    Location
    The Pub
    Posts
    171
    Thank Post
    13
    Thanked 17 Times in 11 Posts
    Rep Power
    21
    Sorry it's a new server with a different name/ip.

  12. #10
    tech-man's Avatar
    Join Date
    Jul 2005
    Location
    The Pub
    Posts
    171
    Thank Post
    13
    Thanked 17 Times in 11 Posts
    Rep Power
    21
    Thanks @Rawns, think this is stuck - trouble is now I have two SOLUS3 servers in the DB with "UI installed"

  13. #11
    Guest

    Join Date
    Jun 2009
    Posts
    3,754
    Thank Post
    1,458
    Thanked 491 Times in 375 Posts
    Rep Power
    0
    Sounds like you jumped the gun and re-associated the new server agent with everything including SOLUS3 rather than modifying the config file to make it the "old" agent instead.

    Guess you'll need to log a call with Capita to get them to strip it out of the database.

  14. #12
    tech-man's Avatar
    Join Date
    Jul 2005
    Location
    The Pub
    Posts
    171
    Thank Post
    13
    Thanked 17 Times in 11 Posts
    Rep Power
    21
    Thanks... my good LA support have logged a call for me.

SHARE:
+ Post New Thread

Similar Threads

  1. [SIMS] Moving SIMS to new server
    By jasonb007 in forum MIS Systems
    Replies: 35
    Last Post: 10th June 2013, 12:27 PM
  2. [SIMS] Moving SIMS to new server
    By reggiep in forum MIS Systems
    Replies: 18
    Last Post: 1st May 2013, 12:43 PM
  3. Replies: 10
    Last Post: 1st June 2012, 05:54 PM
  4. [SIMS] move sims to new server
    By ful56_uk in forum MIS Systems
    Replies: 11
    Last Post: 2nd March 2011, 09:03 PM
  5. move mysql to new server
    By RabbieBurns in forum *nix
    Replies: 6
    Last Post: 20th June 2008, 05:48 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •