+ Post New Thread
Results 1 to 15 of 15
MIS Systems Thread, Sims 2013 Upgrade Issues in Technical; Morning All, Couple of issues regarding the new Spring Update 2013, Our team currently look after around 54 schools around ...
  1. #1

    Join Date
    Apr 2013
    Posts
    14
    Thank Post
    8
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Sims 2013 Upgrade Issues

    Morning All, Couple of issues regarding the new Spring Update 2013, Our team currently look after around 54 schools around our region, half of them are on central SIMS which have been upgraded no issues, the other half had to be done manually i.e. remote onto there servers log into SIMS, tools, check for updates and run the upgrade etc. All was going well until the last 2 schools. One of which when logging onto there server log into SIMS I got a Incompatible Database error(Same on there clients as well), this school has Solus3 so I thought ill go into Solus3 and deploy the new spring updates to clients and the server, but the Spring update wasn't listed or there I checked solus3 for updates but it didn't find any. Not sure whats going on, I restarted the solus deployment service which usually will then pull the updates down but that didnt work either, the school has been authorised ok on our central solus box etc. The other school doesn't have Solus3 so it was just a case of SIMS, tools, install the update which it did fine. When I then log back into SIMS it throws up this message 2 seconds after username and password has been entered " column current tier does not belong to table Table" then closes.?? Any help would be appreciated. As these 2 schools wont be able to access SIMS on Monday. Regards
    Last edited by Solus; 28th April 2013 at 08:25 AM.

  2. #2

    vikpaw's Avatar
    Join Date
    Sep 2006
    Location
    Saudi Arabia
    Posts
    5,589
    Thank Post
    638
    Thanked 1,305 Times in 1,088 Posts
    Rep Power
    336

    That error is usual of version inconsistency somewhere and incompatible database happens when the client version doesn't match the server version.
    Something has gone wrong somewhere. Sorry not too au fait with SOLUS 3. Is it possible the client has updated but not the server or the other way around? Something could be corrupt.

    I'd say you need to get the updates and reapply to both sides. Maybe that means starting with SOLUS 3 again from scratch, or sacking it and reverting to S2.

    There was a follow up version to Spring to include some Ampark stuff, but i don't think it changed the version number but that could be a factor.

  3. Thanks to vikpaw from:

    Solus (28th April 2013)

  4. #3

    Join Date
    Sep 2006
    Location
    London
    Posts
    1,245
    Thank Post
    33
    Thanked 334 Times in 224 Posts
    Rep Power
    75
    A wild guess but we did have an issue with schools that had previously defined tiers and then stopped using them. There is a patch available to fix this.
    Our desk opens @ 8:00

  5. Thanks to PhilNeal from:

    Solus (28th April 2013)

  6. #4

    Join Date
    Apr 2013
    Posts
    14
    Thank Post
    8
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Thanks for the replys guys, Vikpaw Ill have a go at that I've ran the fileserver upgrade manually and not through solus3 and its still reporting incompatible database, @PhilNeal your previous post is that regarding the second issue with " column current tier does not belong to table Table" again thanks for the replies.

  7. #5

    vikpaw's Avatar
    Join Date
    Sep 2006
    Location
    Saudi Arabia
    Posts
    5,589
    Thank Post
    638
    Thanked 1,305 Times in 1,088 Posts
    Rep Power
    336
    If the server is up to date, run dbupgrade to see if it finds any of the files and upgrades the system.
    The incompatible db errors is normally a client side error.
    You could force the client to update / or just reinstall to make sure it runs it. We always get incompatible DB, when the users fail to click YES to the UAC prompt asking if they want to allow the update. On rare occasions it just gets stuck because the simsload.ini has been updated so won't run the update anymore.

  8. #6

    Join Date
    Apr 2013
    Posts
    14
    Thank Post
    8
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Ive tried the dbupgrade and this is the message it presents me with :-
    You are logged into the database using: SQL Server based Authentication
    Your current SIMS database version is 3.61.873
    There are no files valid for this database version.
    What if I run the workstation setup from sims\setups would this then force the client

  9. #7

    vikpaw's Avatar
    Join Date
    Sep 2006
    Location
    Saudi Arabia
    Posts
    5,589
    Thank Post
    638
    Thanked 1,305 Times in 1,088 Posts
    Rep Power
    336
    yeah, try just reinstalling the client with simsinst - but if you're on the server pick the options carefully.
    actually, look at simsload.ini at the version of simsapplicationsetup and check the actual version of that file, will tell you if the client side needs updating.

  10. #8

    Join Date
    Apr 2013
    Posts
    14
    Thank Post
    8
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Ok thank you, I've managed to sort it all now, by running the setups. On the second issue I had I have now found a patch for that error hopefully, do I use dbattach or dbupgrade to apply the patch.. regards and thanks again

  11. #9

    vikpaw's Avatar
    Join Date
    Sep 2006
    Location
    Saudi Arabia
    Posts
    5,589
    Thank Post
    638
    Thanked 1,305 Times in 1,088 Posts
    Rep Power
    336
    dbupgrade for patches. It should back up first, but making your own is always wise too.

  12. 2 Thanks to vikpaw:

    Solus (28th April 2013)

  13. #10

    Join Date
    Sep 2006
    Location
    London
    Posts
    1,245
    Thank Post
    33
    Thanked 334 Times in 224 Posts
    Rep Power
    75
    Glad you're sorted!

  14. #11

    Join Date
    Apr 2010
    Posts
    1,832
    Thank Post
    62
    Thanked 161 Times in 133 Posts
    Rep Power
    64
    You can also get that error if the sims.ini file on the c/windows drive is pointing to \\server\sims$ when it is better to point at S:\Sims (edit)

    Reinstalling using the sims installer files may have just changes the Sims.ini file.

  15. Thanks to edutech4schools from:

    Solus (28th April 2013)

  16. #12

    Join Date
    Mar 2013
    Location
    west sussex
    Posts
    503
    Thank Post
    74
    Thanked 26 Times in 26 Posts
    Rep Power
    14
    Quote Originally Posted by vikpaw View Post
    If the server is up to date, run dbupgrade to see if it finds any of the files and upgrades the system.
    The incompatible db errors is normally a client side error.
    You could force the client to update / or just reinstall to make sure it runs it. We always get incompatible DB, when the users fail to click YES to the UAC prompt asking if they want to allow the update. On rare occasions it just gets stuck because the simsload.ini has been updated so won't run the update anymore.
    we use app-v and package the SIMS client with that, because if the app-v client is working on the machine sims will work (and all other app-vd apps), no inconsistencies between machines.
    It does take longer at upgrade time (later today, *fingers crossed*) i.e. an hour or two to package it and is a little fiddly especially to get things like exams and NT6 to work, you really do have to sacrifice to the gods to get it to work,

    but there is no worrying / running round machines that users have managed to
    a. cancel the upgrade
    b. redirect the shortcut so it points straight to puslar.exe
    c. also removes the need to give the users full control over HKEY_LOCAL_MACHINE\Classes_Root (CAPITA YOU SHOULD BE ASHAMED OF YOURSELVES FOR THIS, simsperms.bat)

  17. #13

    vikpaw's Avatar
    Join Date
    Sep 2006
    Location
    Saudi Arabia
    Posts
    5,589
    Thank Post
    638
    Thanked 1,305 Times in 1,088 Posts
    Rep Power
    336
    It's a major PITA that Windows 7 will quite happily create a 'SIMS' shortcut to pulsar and call it SIMS and the user won't even know they did something wrong.
    I'm happy with our manual updates and SOLUS2, for the most part it works fine. It's usually the primary school where they use SIMS 1 week of the year where they don't bother to update when told to and have this issue.

  18. #14

    Join Date
    Mar 2013
    Location
    west sussex
    Posts
    503
    Thank Post
    74
    Thanked 26 Times in 26 Posts
    Rep Power
    14
    Quote Originally Posted by vikpaw View Post
    It's a major PITA that Windows 7 will quite happily create a 'SIMS' shortcut to pulsar and call it SIMS and the user won't even know they did something wrong.
    I'm happy with our manual updates and SOLUS2, for the most part it works fine. It's usually the primary school where they use SIMS 1 week of the year where they don't bother to update when told to and have this issue.
    How do you feel about hkey_classes_root ?

  19. #15

    vikpaw's Avatar
    Join Date
    Sep 2006
    Location
    Saudi Arabia
    Posts
    5,589
    Thank Post
    638
    Thanked 1,305 Times in 1,088 Posts
    Rep Power
    336
    Quote Originally Posted by ConradJones View Post
    How do you feel about hkey_classes_root ?
    I'm indifferent. Is that in your SIMSPERM? It's not in mine, plus we don't use it. We just gave permissions to certain files and folders on the C drive by Group Policy, works fine. The UAC prompts are a pain but safer that way.

SHARE:
+ Post New Thread

Similar Threads

  1. [SIMS] Re: SIMS MIS reporting error
    By philserre in forum MIS Systems
    Replies: 3
    Last Post: 28th January 2013, 11:00 AM
  2. [SIMS] SIMs Reason 0 error message
    By AJRussell in forum MIS Systems
    Replies: 15
    Last Post: 27th June 2012, 11:54 AM
  3. [SIMS] Another Sims Server install error. grrrrr
    By edutech4schools in forum MIS Systems
    Replies: 10
    Last Post: 3rd December 2011, 07:32 AM
  4. [SIMS] Strange SIMS Pulsar.exe error
    By cookie_monster in forum MIS Systems
    Replies: 14
    Last Post: 16th September 2011, 08:28 PM
  5. [SIMS] SIMS Print Preview Error
    By Spuddyboy in forum MIS Systems
    Replies: 8
    Last Post: 3rd December 2009, 12:37 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •