+ Post New Thread
Results 1 to 4 of 4
MIS Systems Thread, B2B in Technical; Having problems with B2B in Sims.net Immediate task runs OK and generates XML file and posts it. However, scheduled tasks ...
  1. #1
    seanmh's Avatar
    Join Date
    Apr 2007
    Location
    Devon
    Posts
    114
    Thank Post
    6
    Thanked 15 Times in 14 Posts
    Rep Power
    18

    Unhappy B2B

    Having problems with B2B in Sims.net

    Immediate task runs OK and generates XML file and posts it. However, scheduled tasks don't work. Scheduled task runs OK and launches the B2B application but get error in SIMS of "error while generating file". on checking B2BTransaction.log the following is the cause. System.IndexOutOfRangeException: There is no row at position 0.

    Been through the whole reconfiguring scheduled tasks etc, but I get the same result if I open an elevated command prompt and then run the NONUIB2B.exe with arguments. Support have suggested that I didn't have all versions of .net installed, checked this have 2.0, 3.5 and 4 installed (Server 2008 R2).

    Anyone had similar or know what is causing this as it's driving me mad.

  2. #2

    Join Date
    Sep 2007
    Location
    Somerset
    Posts
    63
    Thank Post
    6
    Thanked 18 Times in 13 Posts
    Rep Power
    18
    Does the version of NONUIB2B match the version of SIMS .net? Also worth checking the DataExports User hasn't been deleted (worth trying to log into SIMS .net at this user to ensure the account is OK)

  3. Thanks to splattthecat from:

    seanmh (21st December 2012)

  4. #3

    matt40k's Avatar
    Join Date
    Jun 2008
    Location
    Ipswich
    Posts
    4,445
    Thank Post
    369
    Thanked 650 Times in 531 Posts
    Rep Power
    160
    Stupid question, are the paths the same for scheduled and immediate tasks?

  5. #4
    GazN's Avatar
    Join Date
    Oct 2011
    Location
    St Aspah
    Posts
    23
    Thank Post
    2
    Thanked 7 Times in 6 Posts
    Rep Power
    8
    Hi I've had this same problem in several schools and the solution I found was to run SQLApplicationsetup from the SIMS Setups folder and point it to the BINN folder of the SQL Instance you are using on the server. This worked for about 16 schools which weren't generating B2B files, on 1 school I did have to detach and reattach the database for B2B to start running again. Hope this helps you

SHARE:
+ Post New Thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •