+ Post New Thread
Results 1 to 9 of 9
MIS Systems Thread, Discover: Transfer failed - appears to timeout in Technical; Hi all Part of me wishes I hadn't been checking things tonight, but in a way glad I have. We ...
  1. #1
    Cache's Avatar
    Join Date
    Apr 2008
    Location
    Cumbria
    Posts
    1,223
    Thank Post
    454
    Thanked 177 Times in 174 Posts
    Blog Entries
    3
    Rep Power
    65

    Angry Discover: Transfer failed - appears to timeout

    Hi all

    Part of me wishes I hadn't been checking things tonight, but in a way glad I have.

    We have a consultancy booked on Thursday focusing arround assessment and discover, however logged into the Discover configuration tonight assuming all is hunkydory to discover that it hasn't transfered any data successfully since 1st October. Having scavanged arround I found the discover log file viewer and I get an unhelpfull error saying there was an error transfering details between the discover and sims database. It retried 5 times and then gives up.

    Found the log file and opened it up, it looks like it's hitting a timeout. Searched supportnet and found an article about increasing the discover timeout, so followed that and set it to 10 minutes, however same error. Increased to 20 minutes and still the same error.

    I'm running through one more run through with the time out set to 40 minutes, however something is obviously seriously wrong somewhere. It's got 20 minutes before it'll hit the timeout again if it's going to, however has anyone any pointers I can run through before I go and try the helpdesk in the morning?

    Thanks!

    Edit: 25 minutes the transfer took.
    Last edited by Cache; 23rd October 2012 at 10:20 PM.

  2. #2

    Join Date
    Jan 2007
    Posts
    100
    Thank Post
    0
    Thanked 34 Times in 23 Posts
    Rep Power
    21
    Try the SIMS reindex patch, this has speeded up transfers at some of our schools considerably

  3. Thanks to Greg from:

    Cache (24th October 2012)

  4. #3
    Guest

    Join Date
    Jun 2009
    Posts
    3,754
    Thank Post
    1,458
    Thanked 490 Times in 375 Posts
    Rep Power
    0
    As @Greg says, reindex patch. Works wonders with failed transfers.

    Also may be worth re-running the commands to grant transfer rights. We found after the last upgrade, some services stopped transferring data because for some reason, they lost the transfer rights! Rerunning the commands restored the data transfer.

    Edit: These commands...

    Discover.SqlUserManager.Console /operation=SynchroniseWithSims /Server=SERVER\SIMS2008 /SimsDatabase=sims /DiscoverDatabase=discover /Username=sa /Password=****** /Verbose

    Discover.SqlUserManager.Console /operation=GrantTransferAccountRights /AccountName="NT AUTHORITY\SYSTEM" /Server=SERVER\SIMS2008 /SimsDatabase=sims /DiscoverDatabase=discover /Username=sa /Password=****** /Verbose

    Discover.SqlUserManager.Console /operation=GrantDataViewMonitorAccountRights /AccountName="NT AUTHORITY\SYSTEM" /Server=SERVER\SIMS2008 /SimsDatabase=sims /DiscoverDatabase=discover /Username=sa /Password=****** /Verbose
    Last edited by Rawns; 24th October 2012 at 09:45 AM.

  5. Thanks to Rawns from:

    Cache (24th October 2012)

  6. #4
    zag
    zag is online now
    zag's Avatar
    Join Date
    Mar 2007
    Posts
    3,828
    Thank Post
    914
    Thanked 421 Times in 354 Posts
    Blog Entries
    12
    Rep Power
    88
    Yeh we had same problem with the summer upgrade.

    Had to apply some patch to fix it.

  7. #5

    Join Date
    Nov 2011
    Location
    Rayleigh
    Posts
    119
    Thank Post
    23
    Thanked 21 Times in 21 Posts
    Blog Entries
    1
    Rep Power
    9
    I've got the same issue here with Discover. Only found out today that it wasn't up to date.

    I've tried the command lines above but the second one fails with: "an erro occurred during right granting. a network-related or instance-specific error occurred while establishing a connect to sql server. the server was not found or was not accessible ....

    Any ideas please?

    Thanks, Graeme

  8. #6

    tmcd35's Avatar
    Join Date
    Jul 2005
    Location
    Norfolk
    Posts
    5,706
    Thank Post
    855
    Thanked 901 Times in 746 Posts
    Blog Entries
    9
    Rep Power
    329
    I had the same problem after the summer upgrade. IIRC it turned out I was running an old copy of Discover with a new copy of SIMS, the summer upgraded didn't automatically upgrade Discover.

  9. Thanks to tmcd35 from:

    Cache (24th October 2012)

  10. #7
    Guest

    Join Date
    Jun 2009
    Posts
    3,754
    Thank Post
    1,458
    Thanked 490 Times in 375 Posts
    Rep Power
    0
    Quote Originally Posted by winng View Post
    I've got the same issue here with Discover. Only found out today that it wasn't up to date.

    I've tried the command lines above but the second one fails with: "an erro occurred during right granting. a network-related or instance-specific error occurred while establishing a connect to sql server. the server was not found or was not accessible ....

    Any ideas please?

    Thanks, Graeme
    Another good point. Ensure the Discover and SIMS versions match, otherwise the transfer will stop.


    Sounds like incorrect details somewhere. Double check the username, password, server name and instance, and the database names too. Also be sure to use the correct account name. We're running the services as system but if your using the network account, amend the account name appropriately.

  11. Thanks to Rawns from:

    Cache (24th October 2012)

  12. #8
    Cache's Avatar
    Join Date
    Apr 2008
    Location
    Cumbria
    Posts
    1,223
    Thank Post
    454
    Thanked 177 Times in 174 Posts
    Blog Entries
    3
    Rep Power
    65
    Right, I've requested the Reindex patch and have that to apply shortly, double checked the discover services directory and it's all on the right version, but haven't run those other transfer rights commands yet.

    I just find it odd that it started failing on 1st October with nothing obvious having being changed. But it's SIMS/IT - who needs logic?

  13. #9
    Cache's Avatar
    Join Date
    Apr 2008
    Location
    Cumbria
    Posts
    1,223
    Thank Post
    454
    Thanked 177 Times in 174 Posts
    Blog Entries
    3
    Rep Power
    65
    and the winner is...... the Reindexing patch.

    Transfer takes less then 2 minutes and CPU usage is something reasonable, rather then sitting at 99% for the whole time it's transfering it's now only 25%.

    I guess it must have just hit satuartion point.

    Thanks again!

SHARE:
+ Post New Thread

Similar Threads

  1. [SIMS] Hosted Discover Transfer Failing
    By Rawns in forum MIS Systems
    Replies: 6
    Last Post: 3rd October 2012, 02:06 PM
  2. [SIMS] Discover Transfer Timeout [Solved]
    By Cruiser_Scotland in forum MIS Systems
    Replies: 1
    Last Post: 22nd January 2012, 08:24 PM
  3. Transferring Ghost Images to FOG
    By farquea in forum O/S Deployment
    Replies: 7
    Last Post: 24th March 2010, 03:43 PM
  4. SOAP initialization failed (related to LimitLogin, not personal hygiene)
    By b.cline in forum Network and Classroom Management
    Replies: 8
    Last Post: 18th August 2009, 04:27 PM
  5. Transferring W2k3 drive to Raid
    By SimpleSi in forum Windows
    Replies: 13
    Last Post: 9th July 2009, 01:25 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •