+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 22
MIS Systems Thread, Office 2010 and Individual Reports in Technical; Hi all! Has anyone experienced the issue where reports are being generated with only some of the tags being filled ...
  1. #1
    Jamo's Avatar
    Join Date
    Jan 2009
    Posts
    1,355
    Thank Post
    66
    Thanked 175 Times in 147 Posts
    Rep Power
    60

    Unhappy Office 2010 and Individual Reports

    Hi all!

    Has anyone experienced the issue where reports are being generated with only some of the tags being filled in? All our reports work in 2003 but when exported using 2010 they just don't fill out correctly. This is made even more strange as 'some' of the reports work with no issues, whereas some just put in the surname and nothing else!

    Rather frustrating, I did some digging on the capita site and issue number 1 on their known issues document says that to get around this issue you have to disable 'spell check as you type' enable ALL macros, and a host of other options. I can't believe I would have to disable spell check so that staff could print a report, it seems totally mad! Has anyone else seen this and got a workaround?

    This problem seems to have existed since Oct 2010, so isn't new, just the fix doesn't really seem like a fix to me.

  2. #2


    Join Date
    Sep 2007
    Location
    UK
    Posts
    5,463
    Thank Post
    1,462
    Thanked 892 Times in 573 Posts
    Rep Power
    647
    I've just started using Office 2010 and have not noticed any problems but I've only done simple reports into Excel. 3-4 fields. I'll be happy to do a test if you let me have some info.

  3. #3
    Jamo's Avatar
    Join Date
    Jan 2009
    Posts
    1,355
    Thank Post
    66
    Thanked 175 Times in 147 Posts
    Rep Power
    60
    Quote Originally Posted by laserblazer View Post
    I've just started using Office 2010 and have not noticed any problems but I've only done simple reports into Excel. 3-4 fields. I'll be happy to do a test if you let me have some info.
    Its the Assessment Manager individual reports which seem to be the problem, the normal SIMS reporting modules work fine :s

    (Focus\Assessment\Indivudal Reports)

  4. #4

    Join Date
    May 2011
    Location
    Chester, England
    Posts
    9
    Thank Post
    0
    Thanked 3 Times in 3 Posts
    Rep Power
    0
    I've always had to enable allow all macros to get this working, never had to disable spell checker or anything else though, but unfortunately i never found another way around it :s

  5. #5
    Jamo's Avatar
    Join Date
    Jan 2009
    Posts
    1,355
    Thank Post
    66
    Thanked 175 Times in 147 Posts
    Rep Power
    60
    Quote Originally Posted by mgs1990 View Post
    I've always had to enable allow all macros to get this working, never had to disable spell checker or anything else though, but unfortunately i never found another way around it :s
    Got macros fully enabled on mine and testing with some reports generated. Still not working with them atm, for a user called John Doe I get <<ChosenName>> Doe Tutor Group: <<reg>>

    Either something is wrong with the way reports are being generated or written atm, v confusing!

  6. #6

    Join Date
    Jun 2008
    Posts
    731
    Thank Post
    118
    Thanked 66 Times in 54 Posts
    Rep Power
    31
    This affects us here at my school. As we have Office 2010 installed across the whole site, I just re-save it using Office 2003 which is installed on the SIMS server and that's what cures it for us.

    As get have a SIMS maintenance contract with the LA, I have logged it with them but they have not gotten back to me with a solution.

  7. #7
    Jamo's Avatar
    Join Date
    Jan 2009
    Posts
    1,355
    Thank Post
    66
    Thanked 175 Times in 147 Posts
    Rep Power
    60
    Quote Originally Posted by Chuckster View Post
    This affects us here at my school. As we have Office 2010 installed across the whole site, I just re-save it using Office 2003 which is installed on the SIMS server and that's what cures it for us.

    As get have a SIMS maintenance contract with the LA, I have logged it with them but they have not gotten back to me with a solution.
    Same with us in terms of LA support contract, I think they are doing as much as they can with Capita as its a problem which has existed since Oct 2010 (an MS update broke it apparently).

    'Fix' is as follows from their site: (Personally I don't class this as a fix, more of a bodge)

    Word Icon | Word Options | Trust Centre | Trust Centre Settings | Macro Settings | Check to make
    sure Enable all Macros is selected.


    Word Icon | Word Options | Trust Centre | Trust Centre Settings | Privacy Options | Under
    Document-specific settings make sure Store random number to improve Combine accuracy is
    unticked


    Word Icon | Word Options | Proofing | Under When correcting spelling and Grammar in Word make
    sure that Check spelling as you type is unticked.


    Word Icon | Word Options | Advanced | Under Show document content make sure Show smart tags
    is unticked.


    Smart Tags have been renamed Actions in Office 2010
    Right click Table | Table Properties | Row - take the tick out of "allow rows to break across pages"
    for each row that crosses a page.


    Click View | Outline and change all the text to “Body Text” as some writing in there may be listed
    under “Level 1” which will not work.


    Any Images\Graphics present within the template will need the following modification - Right click
    image | Format Picture | Layout - Select "In front of text" instead of "In line with text"

  8. #8
    Jamo's Avatar
    Join Date
    Jan 2009
    Posts
    1,355
    Thank Post
    66
    Thanked 175 Times in 147 Posts
    Rep Power
    60
    Quote Originally Posted by Chuckster View Post
    This affects us here at my school. As we have Office 2010 installed across the whole site, I just re-save it using Office 2003 which is installed on the SIMS server and that's what cures it for us.

    As get have a SIMS maintenance contract with the LA, I have logged it with them but they have not gotten back to me with a solution.
    Thanks for the idea of using Office 2003 on the server, just tested and works great with that! Will have to resave the reports and go from there for now! Not much of a long term solution though, Office 2003 is going to be out of support in a year and a bit!

  9. #9

    vikpaw's Avatar
    Join Date
    Sep 2006
    Location
    Saudi Arabia
    Posts
    5,784
    Thank Post
    715
    Thanked 1,439 Times in 1,192 Posts
    Rep Power
    359
    @Jamo - did the fix work? With all those settings?
    I've never had to do all that, though some might be through choice.
    I have Macros Enabled.
    Store Random number is unticked - this was a valid setting for something, not necessarily SIMS.
    Spell check as you type is ticked.
    Smart Tags / Actions found under Proofing | Autocorrect Options, i have two options ticked : Address + Instant Messaging.
    My tables always allow rows to break across pages.
    The text is Body Text but probably by fluke over any thing else.
    We don't have pictures apart from the logo at the top on certain templates.

    The usual fix for tags coming through is to save twice. So do your edit, verify (if it lets you) and save. Then save in SIMS. Re-open template in Word, save. Save in SIMS.
    The alternative is after editing the template, click the X to close, and save when prompted. When doing this it usually just works.

    I think there must be some strange interaction between their built in macros that resolve the tags and all those automagic Word features. Somehow, for most people one of the save settings above does the trick.

    In addition, it's worth applying the Office Hotfix rollup. There's one hotfix in particular that is needed to allow the individual reports to bulk print, if you haven't tried it already, start testing, as it caused us huge delays. However it's worth just taking the rollup. It's mentioned in a sticky on SupportNet homepage.

  10. Thanks to vikpaw from:

    AmandaLambert (26th October 2012)

  11. #10
    Jamo's Avatar
    Join Date
    Jan 2009
    Posts
    1,355
    Thank Post
    66
    Thanked 175 Times in 147 Posts
    Rep Power
    60
    Quote Originally Posted by vikpaw View Post
    @Jamo - did the fix work? With all those settings?
    I've never had to do all that, though some might be through choice.
    I have Macros Enabled.
    Store Random number is unticked - this was a valid setting for something, not necessarily SIMS.
    Spell check as you type is ticked.
    Smart Tags / Actions found under Proofing | Autocorrect Options, i have two options ticked : Address + Instant Messaging.
    My tables always allow rows to break across pages.
    The text is Body Text but probably by fluke over any thing else.
    We don't have pictures apart from the logo at the top on certain templates.

    The usual fix for tags coming through is to save twice. So do your edit, verify (if it lets you) and save. Then save in SIMS. Re-open template in Word, save. Save in SIMS.
    The alternative is after editing the template, click the X to close, and save when prompted. When doing this it usually just works.

    I think there must be some strange interaction between their built in macros that resolve the tags and all those automagic Word features. Somehow, for most people one of the save settings above does the trick.

    In addition, it's worth applying the Office Hotfix rollup. There's one hotfix in particular that is needed to allow the individual reports to bulk print, if you haven't tried it already, start testing, as it caused us huge delays. However it's worth just taking the rollup. It's mentioned in a sticky on SupportNet homepage.

    I did notice the following with ours:

    If you enable spell check as normal reports don't generate properly when you save them and preview, the report tags aren't resolved.

    Removing spell check as you type fixes that problem, but ONLY if you re-edit the document and save, just disabling the option and rerunning the report doesn't work.

    Interesting point though, if you enable spell check as normal and add all the works which are underlined in red to the custom dictionary and resave.... it works.

    I am going to retest this a few times to make sure its not an effect of something else but this is a seriously weird issue and I am suprised that Capita have not taken more of an interest in this, it is number 1 in their known issues list and has been affecting this part of SIMS for 2 years now!

  12. #11
    Jamo's Avatar
    Join Date
    Jan 2009
    Posts
    1,355
    Thank Post
    66
    Thanked 175 Times in 147 Posts
    Rep Power
    60
    Quote Originally Posted by Jamo View Post
    I did notice the following with ours:

    If you enable spell check as normal reports don't generate properly when you save them and preview, the report tags aren't resolved.

    Removing spell check as you type fixes that problem, but ONLY if you re-edit the document and save, just disabling the option and rerunning the report doesn't work.

    Interesting point though, if you enable spell check as normal and add all the works which are underlined in red to the custom dictionary and resave.... it works.

    I am going to retest this a few times to make sure its not an effect of something else but this is a seriously weird issue and I am suprised that Capita have not taken more of an interest in this, it is number 1 in their known issues list and has been affecting this part of SIMS for 2 years now!

    Just tested this on a couple more documents seems the fix for us was to:

    * Open the word template
    * Right click and add every spelling error (red underlined text, this includes tags) to the dictionary so that no red underline is seen on the document
    * Save the document in word
    * Save in SIMS

    The report then works again.

    Now its time for coffee to celebrate.

  13. #12

    vikpaw's Avatar
    Join Date
    Sep 2006
    Location
    Saudi Arabia
    Posts
    5,784
    Thank Post
    715
    Thanked 1,439 Times in 1,192 Posts
    Rep Power
    359
    Can you try it without adding to dictionary, but just the second save process. I'm pretty sure the second save is what's doing it. It's not a great workaround to have to add random errors to the dictionary. Our system doesn't like a single student's name, and our db is full of random typos and weird spellings, adding them to the dictionary would be ludicrous.

  14. #13
    Jamo's Avatar
    Join Date
    Jan 2009
    Posts
    1,355
    Thank Post
    66
    Thanked 175 Times in 147 Posts
    Rep Power
    60
    Quote Originally Posted by vikpaw View Post
    Can you try it without adding to dictionary, but just the second save process. I'm pretty sure the second save is what's doing it. It's not a great workaround to have to add random errors to the dictionary. Our system doesn't like a single student's name, and our db is full of random typos and weird spellings, adding them to the dictionary would be ludicrous.
    I tried that on ours and it didn't seem to work, couple of reports tried the same on both, open save save, then open save save. Didn't work on either. The dictionary thing works regardless of macro settings or anything else so is definitely causing different behavior somewhere along the lines. As soon as it is saved the report with no red spelling errors works for everyone, the one without doesn't

    We have had some seriously weird problems this year, I am hoping for a simple rest of week!

  15. #14
    Guest

    Join Date
    Jun 2009
    Posts
    3,754
    Thank Post
    1,458
    Thanked 491 Times in 375 Posts
    Rep Power
    0
    Our tried and tested solution to fix all Office 2010 reporting issues is as follows:

    1. Only use Office 2010 32-bit even if on a 64-bit machine
    2. Enable ALL macros in Word and Excel
    3. Add ALL network drives used for word document storage H:, S:, P:, etc to the trusted locations and enable all sub folders as trusted too! Specifically, ensure the users home drive which will most likely be on the network as H: is added too as it's where SIMS will be generating the temp report files.
    4. Install Office 2010 KB2553912
    5. Install the Office 2010 Primary Interop Assemblies
    6. If on Windows 7, ensure Windows 7 Offline File Sync is disabled on the user's home ( H: ) drive.

    We compiled this into a document that distributed it to all schools and IT support teams and the call volumes for SIMS Reporting and Office 2010 have dropped to one or two a week.
    Last edited by Rawns; 16th October 2012 at 03:37 PM.

  16. #15
    Jamo's Avatar
    Join Date
    Jan 2009
    Posts
    1,355
    Thank Post
    66
    Thanked 175 Times in 147 Posts
    Rep Power
    60
    Can't we just print reports using default settings please Capita??????????????????????????????????????


    I'm just waiting for someone to come on with the advice:
    "You must be wearing green socks and have one trouser leg rolled up for individual reports to work!"

SHARE:
+ Post New Thread
Page 1 of 2 12 LastLast

Similar Threads

  1. [MS Office - 2010] Office 2010 and Windows 7
    By kevin_lane in forum Office Software
    Replies: 17
    Last Post: 18th November 2011, 05:28 AM
  2. Office 2010 and Printer Issue
    By gl3nnym in forum Windows
    Replies: 8
    Last Post: 27th September 2011, 03:07 PM
  3. [Windows Software] Office 2010 and Citrix
    By keogk in forum Licensing Questions
    Replies: 6
    Last Post: 13th October 2010, 05:31 PM
  4. [MS Office - 2010] Office 2010 and page setup.
    By FunkMaster_J in forum Office Software
    Replies: 0
    Last Post: 21st September 2010, 11:35 AM
  5. [MS Office - 2010] Office 2010 and Adobe Pro 8
    By RabbieBurns in forum Office Software
    Replies: 0
    Last Post: 18th May 2010, 08:09 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •