+ Post New Thread
Results 1 to 13 of 13
Mac Thread, MAC Time wandering causing issues with authentication with AD in Technical; Please if there is a God someone have and answer to this question. We were bullied by our Music Department ...
  1. #1

    Join Date
    Sep 2009
    Location
    shrewsbury
    Posts
    2
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Angry MAC Time wandering causing issues with authentication with AD

    Please if there is a God someone have and answer to this question.

    We were bullied by our Music Department into buying MAC's. (Snow Leopard)

    To ensure we could track user logins we have joined them to our Active Directory Domain, this all worked out fine until we noticed that the clock was wandering randomly so much so it stopped people logging on to the domain.

    The upshot is we are getting phone calls some times weekly with complaints people cannot log on.

    Once you log on locally reset the clock all is well.

    Tried setting the time service to point at Apple and our own Time Server to no avail.

    Our Senior tech is about to throw them in the bin (or make shiny book ends), very frustrating.

    Anyone with an answer - greatly appreciated.

    P.S any MAC lovers about to blame windows or say it's not really broken it's a feature please do not post.

    Don't get me wrong I think MACs have a place but it is worrying when a device cannot keep it's clock in sync.

  2. #2


    Join Date
    Feb 2007
    Location
    Northamptonshire
    Posts
    4,691
    Thank Post
    352
    Thanked 796 Times in 715 Posts
    Rep Power
    347
    Hi there.

    I'd work out why NTP isn't working properly to keep the time in check.

  3. #3

    SYNACK's Avatar
    Join Date
    Oct 2007
    Posts
    11,174
    Thank Post
    868
    Thanked 2,702 Times in 2,289 Posts
    Blog Entries
    11
    Rep Power
    773
    Add one or more of the DC ip addresses into DHCP under the time servers option, this will point them at the servers for NTP and should get it going again nicely. You can also set your timezone etc in there aswell for some nice easy setups of compatible devices that need to access stuff via kerberos.

  4. #4

    SYNACK's Avatar
    Join Date
    Oct 2007
    Posts
    11,174
    Thank Post
    868
    Thanked 2,702 Times in 2,289 Posts
    Blog Entries
    11
    Rep Power
    773
    Oh and your right, Macs do have their uses :

  5. #5

    Join Date
    Sep 2009
    Location
    shrewsbury
    Posts
    2
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    MMM not a bad thought

  6. #6

    Join Date
    Jul 2010
    Location
    Shrewsbury
    Posts
    7
    Thank Post
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0

    Think I have cracked it

    At the end of the day it all comes down to config files.

    Looks like you can't edit the ntp.conf file because after a reboot it reverts same with loads of other ntp and ntpd file which I have tried to hack.

    However I have changed the hostconfig file to read in /etc to read

    TIMESYNC=-YES-

    I then restart the ntp service and the time changed to the correct time.

    To be honest not sure what has happened, me thinks I have stop it using NTP so it has reverted to it's Hardware Clock - which is obviously right.

    I may be completly wrong, however it seems to be working - watch this space.

    Going to join the machine to AD and we'll see

  7. Thanks to cheshireguy from:

    dave.81 (2nd May 2011)

  8. #7

    Join Date
    Mar 2007
    Location
    Devon
    Posts
    1,042
    Thank Post
    226
    Thanked 63 Times in 56 Posts
    Rep Power
    30
    We are having the same issue and it's been driving me up the wall having to reset them each time they are booted to windows. Off to try your fix now......

  9. #8

    Join Date
    Jul 2010
    Location
    Shrewsbury
    Posts
    7
    Thank Post
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0
    OK - over the weekend, the time did slip, however I have found another bit of info which seems to set the ntp.conf file and fix it.

    NTP Clients
    Again the following should be done in the described order.
    On Mac OS X Clients and on those Mac OS X Servers that are to act as NTP clients (that means they query a time server but do not answer NTP queries) the following needs to be done:
    In System Preferences ("Date and Time" pref pane) "synchronize time automatically" must be ticked; then the first tab of this pref pane must be activated and the window left open. Then in Terminal a time server to sync with must be added to /etc/ntp.conf like so (as to finding the right time server see above):
    server mein.zeitserver.de prefer iburst minpoll 12 maxpoll 15
    Now /etc/ntp.conf must be saved and made unchangeble:
    sudo chflags uchg /etc/ntp.conf
    After that the System Preferences can be closed.
    On a Mac OS X Client that is all. On a Mac OS X Server the file /etc/hostconfig must be edited to contain:
    TIMESYNC=-YES-

    Still working on it

  10. #9

    Join Date
    Mar 2007
    Location
    Devon
    Posts
    1,042
    Thank Post
    226
    Thanked 63 Times in 56 Posts
    Rep Power
    30
    Ours doesn't move unless we boot to windows, then we end up a whole hour out... Driving me mad resetting them.

  11. #10

    Join Date
    Apr 2009
    Posts
    4
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Had the same issue previously and this is what I did to resolve it. Never had a time sync problem since.
    Xserve points to win 2008 time server
    Mac clients point to Xserve for time

    This certainly has resolved our mac time related issues.

  12. #11

    Join Date
    Jul 2010
    Location
    Shrewsbury
    Posts
    7
    Thank Post
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0
    Checked with the MAC today all seems well.

    We don't have a MAC server or boot camp/parallels etc.

    The trick I posted above does seem to be working


    Open Terminal
    Sudo vi /etc/ntp.conf

    change server to server your time server

    Make /etc/ntp.conf unchangeble:

    sudo chflags uchg /etc/ntp.conf


    Edit the /etc/hostconfig must be edited to contain:

    TIMESYNC=-YES-

    Save and close out of terminal

    Ensure in preferences on date and time that the use time server is ticked - don't worry which Apple server it points to that is irrelevant.

    Wne I get 5 mins I will post the proper process but I want to check it works over a longer period

  13. #12
    nonmonotonic's Avatar
    Join Date
    Nov 2010
    Location
    Dun Laoghaire, Republic of Ireland
    Posts
    30
    Thank Post
    0
    Thanked 5 Times in 5 Posts
    Rep Power
    8
    This has been discussed before and here is my suggestion.

    Interesting stuff from the NTP people themselves.

    I'm in a mixed Mac/PC environment and have no problems syncing to our Windows Domain Controller (NTP server). Tick set time & date automatically in preferences and point to your NTP server I do use the IP address not the name.

  14. #13
    nonmonotonic's Avatar
    Join Date
    Nov 2010
    Location
    Dun Laoghaire, Republic of Ireland
    Posts
    30
    Thank Post
    0
    Thanked 5 Times in 5 Posts
    Rep Power
    8
    This has been discussed before and here is my suggestion.

    Interesting stuff from the NTP people themselves.

    I'm in a mixed Mac/PC environment and have no problems syncing to our Windows Domain Controller (NTP server). Tick set time & date automatically in preferences and point to your NTP server. I do use the IP address not the server name.

SHARE:
+ Post New Thread

Similar Threads

  1. Replies: 15
    Last Post: 10th June 2010, 02:28 PM
  2. Replies: 5
    Last Post: 21st April 2010, 10:05 AM
  3. Windows 7 causing sound syning issues?
    By Sonicboom in forum Windows 7
    Replies: 3
    Last Post: 12th March 2010, 10:17 AM
  4. Wrong time causing online login problem
    By SimpleSi in forum Windows
    Replies: 5
    Last Post: 12th December 2007, 08:33 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •