+ Post New Thread
Results 1 to 4 of 4
Mac Thread, screen capture location ? in Technical; I have tried the relevant commands from terminal to change / update the location of where screen captures go yet ...
  1. #1

    mac_shinobi's Avatar
    Join Date
    Aug 2005
    Posts
    9,909
    Thank Post
    3,435
    Thanked 1,084 Times in 1,000 Posts
    Rep Power
    370

    screen capture location ?

    I have tried the relevant commands from terminal to change / update the location of where screen captures go yet it doesn't make any difference, they keep going into a folder either in my documents or on the desktop named "original images"

    either

    sudo defaults write com.apple.screencapture location ~/Desktop

    OR

    defaults write com.apple.screencapture location ~/Users/<USERNAME>/Desktop

    then the

    killall SystemUIServer

    and try again to do a screen grab and it goes to the desktop for about 3 seconds and then vanishes back into the folder and off the desktop

    What am I doing wrong ??

  2. #2

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    16,234
    Thank Post
    894
    Thanked 1,780 Times in 1,534 Posts
    Blog Entries
    12
    Rep Power
    462
    I have dont it. I used Onyx. Go into the Parameters tab and it is in there. It will let you set the default name, file format and location.

    Easy, not need to mess about in terminal.

  3. #3


    Join Date
    Feb 2007
    Location
    51.403651, -0.515458
    Posts
    9,416
    Thank Post
    243
    Thanked 2,825 Times in 2,084 Posts
    Rep Power
    814
    You have to use the full path for it to work i.e. do not use ~.

    Code:
    sudo defaults write com.apple.screencapture location /Users/MacShinobi/Desktop

  4. #4

    mac_shinobi's Avatar
    Join Date
    Aug 2005
    Posts
    9,909
    Thank Post
    3,435
    Thanked 1,084 Times in 1,000 Posts
    Rep Power
    370
    Tried all of those and then remembered I had set a folder action on the said folder, disabled the folder action and it now works fine

    Thanks :-)

    Hate to say it but this was user error, doh !!

SHARE:
+ Post New Thread

Similar Threads

  1. Replies: 5
    Last Post: 17th June 2010, 12:22 PM
  2. WMI Screen Capture
    By somabc in forum Scripts
    Replies: 6
    Last Post: 7th July 2008, 08:27 PM
  3. Screen Capture
    By angelikaalston in forum How do you do....it?
    Replies: 11
    Last Post: 29th November 2007, 08:56 AM
  4. JING - Screen capture software
    By mighty.grey.eagle in forum General Chat
    Replies: 12
    Last Post: 19th August 2007, 05:40 PM
  5. screen capture software
    By beeswax in forum Educational Software
    Replies: 12
    Last Post: 6th November 2006, 12:22 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •