+ Post New Thread
Page 2 of 4 FirstFirst 1234 LastLast
Results 16 to 30 of 57
Mac Thread, How to create an OS X Default Profile/Template & Bind to AD - 10.5 - 10.8 in Technical; Does this work for Login Items under accounts? For instance I a have a script that maps the userfolder from ...
  1. #16

    Join Date
    Jul 2011
    Location
    Orlando
    Posts
    3
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Snow Leopard 10.6.8

    Does this work for Login Items under accounts? For instance I a have a script that maps the userfolder from AD to the desktop. Having been able to get it to run when it's setup in the default profile. Doesn't seem to work for the desktop background either. I'm logging in with an AD account.

  2. #17
    Carter's Avatar
    Join Date
    Sep 2010
    Location
    Canada
    Posts
    269
    Thank Post
    10
    Thanked 66 Times in 41 Posts
    Rep Power
    19
    I can give this a quick try in a few mins here if you don't mind me trying the script. At least that way I can let you know? Just let me know.

  3. #18

    Join Date
    Jul 2011
    Location
    Orlando
    Posts
    3
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    You'll just need to change the server. It's still not even setting the desktop background either.

    delay 10
    set strUserName to do shell script "whoami"
    set strFileServer to "net222.net.ucf.edu/userfolders$"
    set strMount to "smb://" & strFileServer & "/" & strUserName
    mount volume strMount

  4. #19
    Carter's Avatar
    Join Date
    Sep 2010
    Location
    Canada
    Posts
    269
    Thank Post
    10
    Thanked 66 Times in 41 Posts
    Rep Power
    19
    I'll give it a test but one thing I should mention or ask .... do you plan to have people saving files to this share? It's easy to open files from the share but if someone creates a new file they cannot browse the share? They will see the server and not the actually mounted share unless you have something else in place. I've tried and wanted to do this for a few years but Mac OS X only puts the server in the finder which then makes it harder for users as they then need to browse, well at least hear they have to browse through 100's and 100's of folders (they can't access them, just their own) but a nightmare to scroll and find their folder/share.


  5. #20

    Join Date
    Jul 2011
    Location
    Orlando
    Posts
    3
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Snow Leopard

    We're going to look at using Jampf Casper Suite as a better solution. Thanks for your help.

  6. #21

    Join Date
    Aug 2011
    Posts
    1
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Steps 2 and 3 need to be done in that order?

    I've already joined our entire Mac Lab to our Active Directory, but have not set up the profile template yet. Will I have to unjoin before doing that or can I still do the profile work after joining to AD?

  7. #22
    Carter's Avatar
    Join Date
    Sep 2010
    Location
    Canada
    Posts
    269
    Thank Post
    10
    Thanked 66 Times in 41 Posts
    Rep Power
    19
    Quote Originally Posted by davemccall View Post
    I've already joined our entire Mac Lab to our Active Directory, but have not set up the profile template yet. Will I have to unjoin before doing that or can I still do the profile work after joining to AD?
    Upi can leave them bound but you will need to trash the home folders of those already logged in that you want to have the new folder. If not when they login they will get their old folder that they already had in place. new default profiles will only be created for new users.

  8. #23
    Carter's Avatar
    Join Date
    Sep 2010
    Location
    Canada
    Posts
    269
    Thank Post
    10
    Thanked 66 Times in 41 Posts
    Rep Power
    19
    I just updated the script download links above & below. Please make note of the OS X Lion 10.7 script. This one has a small additional command to run which removes the files located in folder ~/Library/Application Support/Ubiquity/ "Ubiquity" is a name codename used for iCloud with Apple. This will not hurt anything as the folder contents will be re-created once the user goes to login. The script would not run because the contents in this folder could not be copied.


    OS X Leopard 10.5 - OS X Snow Leopard 10.6 - http://dl.dropbox.com/u/121843/OSX10...lt_profile.zip
    OS X Lion 10.7 - http://dl.dropbox.com/u/121843/OSX_1...lt_profile.zip

  9. #24

    Join Date
    Feb 2010
    Location
    United Kingdom
    Posts
    8
    Thank Post
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0
    Concerning the mounting of AD student shares, I use a script that puts an alias of the user's folder, which is inside the share, on the desktop.
    Our student shares are divided alphabetically, so a path for a student whose username starts with "h" would be
    /volumes/studenth/hfacebookuser

    Note that AD mounts the actual server so one doesn't have to use its actual name.

    Here is the script :-

    #!/bin/sh

    me=$(logname)
    x=$(echo $me | cut -c1)
    /bin/ln -s /volumes/STUDENT$x/$me /Users/$me/Desktop/$me"'s H Drive"

  10. Thanks to Karamoja from:

    Carter (17th November 2011)

  11. #25

    Join Date
    Mar 2012
    Posts
    3
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    getting this error

    Quote Originally Posted by kahnibus View Post
    Hi Carter,
    I got this to work, however....

    When an LDAP user logins into the computer they get prompted with "The System was Unable to unlock your Keychain" .....any ideas?

    I have gone into the "default" user and deleted the Keychain, restarted and ran your script again. The keychain error is still present.

    thanks for any help
    Hi how did you get the script to work as Im getting the same error as you originally did when you first ran the Default script. Thank you

    JC

  12. #26

    Join Date
    Jun 2012
    Posts
    2
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    These links are no longer valid. Is there somewhere else to download the scripts (specifically the one for 10.7)?

  13. #27
    Carter's Avatar
    Join Date
    Sep 2010
    Location
    Canada
    Posts
    269
    Thank Post
    10
    Thanked 66 Times in 41 Posts
    Rep Power
    19
    Sorry about that. I moved the files by mistake. They are back now

    .

  14. #28

    Join Date
    Mar 2009
    Posts
    1
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I am getting the same error on 10.7.4. Suggestions?

  15. #29

    Join Date
    Jul 2012
    Location
    United States
    Posts
    6
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Carter, first wanted to thank you for putting the time into this. This is exactly what I am looking for. Much Appreciate! I currently support an organization that is moving from a Windows to OS X environment (Maintaining our AD backend) and we we're doing the same thing with the Default profile albeit for Windows as we plan now to do with OS X. My concern is doing it correctly and I have a few concerns, questions, etc.
    1.) We will be using AdmitMac for binding our AD with OS X, should this be installed and setup during the creation of the Default User? I would assume yes?
    2.) We will be also using DeepFreeze for Mac, I would assume we install and freeze workstations once we have completed the whole process?
    3.) We currently Map (I know, Mount) several shares based on user profile, anything to take in consideration or be aware of on the Mac side of things?
    4.) We will be using Jamf Composer and Imaging suite, anything here to take into consideration or be aware of?
    5.) Sounds like you install all the software and configure to your taste, then go though the process of creating the default profile, quite similar to Windows creation of default profile.

    Thanks for your prompt assistance and support.

    Much appreciated
    Andrew

  16. #30
    Carter's Avatar
    Join Date
    Sep 2010
    Location
    Canada
    Posts
    269
    Thank Post
    10
    Thanked 66 Times in 41 Posts
    Rep Power
    19
    Quote Originally Posted by teachelr View Post
    I am getting the same error on 10.7.4. Suggestions?
    What error are you getting?

SHARE:
+ Post New Thread
Page 2 of 4 FirstFirst 1234 LastLast

Similar Threads

  1. Has anyone used Access to create a school report template?
    By laserblazer in forum General Chat
    Replies: 1
    Last Post: 24th May 2011, 09:25 PM
  2. Edit the Default User Template?
    By Zoom7000 in forum Mac
    Replies: 3
    Last Post: 5th September 2010, 11:34 PM
  3. Mandatory Profile & Default Printer
    By chrisjako in forum Windows Server 2000/2003
    Replies: 0
    Last Post: 25th February 2010, 10:11 AM
  4. Create Custom ADM Template
    By robbied69 in forum Windows
    Replies: 5
    Last Post: 5th September 2008, 05:37 PM
  5. Default template user 4 module
    By crazy in forum EduGeek Joomla 1.0 Package
    Replies: 2
    Last Post: 11th January 2008, 09:40 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •