+ Post New Thread
Page 2 of 2 FirstFirst 12
Results 16 to 22 of 22
Mac Thread, Mac Update Service (WSUS 4 MAC) in Technical; When i get a second, I will try this at home where i have a completely windows free mac installation. ...
  1. #16

    Join Date
    May 2006
    Location
    West Bromwich
    Posts
    2,192
    Thank Post
    300
    Thanked 215 Times in 185 Posts
    Rep Power
    57
    When i get a second, I will try this at home where i have a completely windows free mac installation. I will test and return my findings to the group

    Although IIRC using ARD with 10.4.11 yielded the same results as mentioned previously. What i can't remember though is whether i tried both before i removed the Tiger systems from the AD and afterwards.

  2. #17

    Join Date
    May 2006
    Location
    West Bromwich
    Posts
    2,192
    Thank Post
    300
    Thanked 215 Times in 185 Posts
    Rep Power
    57
    Ok. I have just looked at the software update on my machines as i have now got to update iTunes. I went to one client (client A) and ran the software update tool. It failed. eh? I checked the machine connected to the whiteboard (client B). This one worked fine.

    Now i know for a fact that the 2 machines are in different computer lists. I checked the settings on the network prefs and then i checked the settings on the software update.

    Here's the problem. The URL entered into the field on client A was:
    http://myserver.domain.com:8088

    The URL entered into the field for client B was:
    http://myserver.domain.com:8088/

    I added the slash at the end and then restarted the client B after i had applied the changes. The client updated straight away fine. So don't forget the "/". Its very important.

  3. #18

    Join Date
    May 2006
    Location
    West Bromwich
    Posts
    2,192
    Thank Post
    300
    Thanked 215 Times in 185 Posts
    Rep Power
    57
    I have just re-visited this and have found that the above doesn't really matter. Yes, it matters if the slash is not added to the end but the main issue with sending out the ARD command to do the softwareupdate -i -a is that the clients need to have the bypass proxy domains set for the computer. Managing these settings using WGM for the computer groups does not work. You will have to manually add these settings to each machine. Luckily you can also do this using ARD

    Use the command
    Code:
    networksetup -setproxybypassdomains "network-device being used" *.local 169.254/16 192.168.0.* *.your domain.name.com
    Replace network device being used with the device you wish to set the proxy settings for, the IP with your IP address range and the domain name with your own.

    Now you should be able to run the softwareupdate -i -a as root without each machine needing to be logged in and software updates done manually.

    You could also configure the softwareupdate -i -a to run as a schedule in ARD and then have automatic updates downloaded and installed.

    HOWEVER, i do have one strange issue. If i log in as an admin on a client and run software update it sees itunes 9.0. even though if i list the updates using root from ARD after i have just installed some updates, it sees nothing to install.

  4. #19

    Join Date
    May 2009
    Location
    UK
    Posts
    107
    Thank Post
    3
    Thanked 10 Times in 10 Posts
    Rep Power
    13
    on my servers i have the address as http://myserver.domain.com:8088/index.sucatalog i then use either ARD or a manual software update.

  5. #20

    Join Date
    May 2006
    Location
    West Bromwich
    Posts
    2,192
    Thank Post
    300
    Thanked 215 Times in 185 Posts
    Rep Power
    57
    I will change my settings in WGM to use the full path. See if that sorts the itunes problem.

  6. #21

    Join Date
    May 2008
    Posts
    213
    Thank Post
    2
    Thanked 27 Times in 27 Posts
    Rep Power
    18
    I can't get this working at all, when on the login screen software update -i -a (or -l) just state 'no updates are available' - when logged in on the actual machine running the same command with sudo displays the 6/7 updates that are available - I tried the 'fix' of setting proxy bypasses for root but my sucatalog URL is just an IP anyway so I don't see why that would help (it didnt).

    What is causing this?

  7. #22

    Join Date
    May 2009
    Location
    UK
    Posts
    107
    Thank Post
    3
    Thanked 10 Times in 10 Posts
    Rep Power
    13
    if you run software update from the apple does it show the local server address in brackets at the top of the box?



SHARE:
+ Post New Thread
Page 2 of 2 FirstFirst 12

Similar Threads

  1. recent MS update knackered WSUS?
    By Oops_my_bad in forum Windows
    Replies: 6
    Last Post: 16th October 2007, 11:08 PM
  2. Server 2003 stalls after wsus update
    By pooley in forum Windows
    Replies: 2
    Last Post: 13th July 2007, 02:56 PM
  3. No Instance for WSUS in SQL service manager
    By petectid in forum Windows
    Replies: 1
    Last Post: 6th February 2007, 01:05 PM
  4. Replies: 5
    Last Post: 16th October 2006, 11:02 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •