+ Post New Thread
Results 1 to 2 of 2
Mac Thread, OS X Leopard RADIUS Server for AD users in Technical; Good afternoon, I am currently looking at getting the RADIUS server running. I have configured the Extreme Base Stations (which ...
  1. #1

    Join Date
    May 2006
    Location
    West Bromwich
    Posts
    2,190
    Thank Post
    299
    Thanked 215 Times in 185 Posts
    Rep Power
    56

    Question OS X Leopard RADIUS Server for AD users

    Good afternoon,

    I am currently looking at getting the RADIUS server running. I have configured the Extreme Base Stations (which consisted adding them to the list) and then added the allowed users to the SACL list. I added the AD group into the list of allowed users.

    I logged in as an admin on a macbook. I imported the RADIUS config. It prompted me for a username and password. I enter an allowed users' username and password and it accepts it and doesn't say anything else but it doesn't work. Looking at the RADIUS logs on the server reveals a little more:

    Wed Nov 5 13:49:45 2008 : Auth: rlm_opendirectory: User is authorized.
    Wed Nov 5 13:49:45 2008 : Auth: rlm_opendirectory: User is authorized.
    Wed Nov 5 13:49:45 2008 : Auth: rlm_opendirectory: User is authorized.
    Wed Nov 5 13:49:45 2008 : Auth: rlm_opendirectory: User is authorized.
    Wed Nov 5 13:49:45 2008 : Auth: rlm_opendirectory: User is authorized.
    Wed Nov 5 13:49:45 2008 : Error: rlm_mschap: authentication failed -14091
    Wed Nov 5 13:49:45 2008 : Auth: Login incorrect: [ADuser/] (from client localhost port 0)
    Wed Nov 5 13:49:45 2008 : Auth: Login incorrect: [ADuser/] (from client ICT Access Point port 0 cli 00-19-E3-04-63-48)
    Now if i use an account in the Open Directory it works fine. What could be the problem?

  2. #2

    Join Date
    Jul 2005
    Location
    Corby
    Posts
    1,056
    Thank Post
    12
    Thanked 20 Times in 18 Posts
    Rep Power
    24
    Apple chose freeRADIUS when they configured RADIUS support in OS X, and for that reason I believe they have inherited a freeRADIUS config file error that leads to this situation!

    Resetting the user's password in WGM fixes the problems temporarily, but like I said, MS-CHAP support in freeRADIUS is a bit "wobbly" right now...

    Sorry I can't be of more help!

    If you *do* get it working let me know how you fixed it!

    Paul

SHARE:
+ Post New Thread

Similar Threads

  1. [Sold/Traded] Leopard Server Media
    By FN-GM in forum Classified Adverts
    Replies: 8
    Last Post: 12th August 2008, 09:49 AM
  2. Joomla 1.5 installation on Leopard server 10.5.3
    By HodgeHi in forum EduGeek Joomla 1.5 Package
    Replies: 4
    Last Post: 1st June 2008, 02:59 PM
  3. Replies: 3
    Last Post: 2nd April 2008, 09:00 PM
  4. Wireless 802.1x RADIUS authentication using IAS server
    By spc-rocket in forum Wireless Networks
    Replies: 0
    Last Post: 3rd January 2008, 06:15 PM
  5. ISA Server 2004 and RADIUS
    By spc-rocket in forum Wireless Networks
    Replies: 0
    Last Post: 11th December 2005, 12:48 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •