+ Post New Thread
Results 1 to 3 of 3
Mac Thread, Mbp hd upgrade gone wrong :( in Technical; can anyone recommend a good place to get an out of warranty MacBook pro repaired in London? I tried to ...
  1. #1
    somabc's Avatar
    Join Date
    Oct 2007
    Location
    London
    Posts
    2,337
    Thank Post
    83
    Thanked 388 Times in 258 Posts
    Rep Power
    111

    Mbp hd upgrade gone wrong :(

    can anyone recommend a good place to get an out of warranty MacBook pro repaired in London? I tried to upgrade the hd. When I booted with the new drive it kernel panicked with the storage drivers I think. I put the old hd back but it now boots up to the chime with a grey screen and hangs with no message. I can hear the hd spinning up and down. I think I may have bent the sata cable perhaps?

  2. #2

    Join Date
    May 2006
    Location
    West Bromwich
    Posts
    2,190
    Thank Post
    299
    Thanked 215 Times in 185 Posts
    Rep Power
    56
    You could perhaps try this to see where you went wrong or what ever happened that resulted in it not working. It may be that you need a certain type of drive?

    iFixit - Installing MacBook Pro 15" Core Duo Hard Drive

    Good luck

  3. #3
    somabc's Avatar
    Join Date
    Oct 2007
    Location
    London
    Posts
    2,337
    Thank Post
    83
    Thanked 388 Times in 258 Posts
    Rep Power
    111
    I think this cable is damaged?

    MacBook Pro 15.4inch Intel Core Duo 1.83GHz 922-7264 MacBook Pro 15-inch Core Duo Hard Drive / Bluetooth / IR Cable Apple Mac Parts and Repairs from VIS Ltd

    I booted off another Mac in firewire disk mode, the original disk is not seen at all by the mac. I cant access the disk on any other computers by usb either. The brand new disk is seen but has a SMART error. All the files seem to be there though. I don't see how both drives would have failed at the same time so hopefully its the cable that's damaged.

    Went to an appler dealer on the strand who quoted 125 just to look at it! FFS!

SHARE:
+ Post New Thread

Similar Threads

  1. hosting? or am i doing something wrong?
    By apoth0r in forum EduGeek Joomla 1.0 Package
    Replies: 4
    Last Post: 19th January 2008, 01:17 PM
  2. Robocopy Gone Wrong
    By fawkers in forum Windows
    Replies: 2
    Last Post: 17th September 2007, 06:50 AM
  3. please ignore wrong place
    By callumtuckey in forum Mac
    Replies: 11
    Last Post: 19th March 2007, 03:08 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •