+ Post New Thread
Results 1 to 6 of 6
Mac Thread, Another Firefox 3 question in Technical; Hello, I'm just setting up FFox 3 on a room of iMacs (10.5.4). I have edited the global prefs.js file ...
  1. #1

    Join Date
    Jan 2007
    Location
    The Console
    Posts
    236
    Thank Post
    22
    Thanked 29 Times in 23 Posts
    Rep Power
    22

    Another Firefox 3 question

    Hello,

    I'm just setting up FFox 3 on a room of iMacs (10.5.4). I have edited the global prefs.js file with our various settings to force homepages / proxy settings etc using "user_pref". This works fine, but I would like to use "lockPref" so that students cannot remove proxy settings. If i chage user_pref for lockPref, the entire line of code is ignored so students are left with a default mozilla home page and no proxy at all. If i change it back to user_pref, it all works fine?! Is lockPref the correct syntax for this, or am I missing something?

    Also, we use the system proxy plugin so that FFox picks up the system proxy from Mac OS X. However, when FFox launches, it insists on a compatibility check of the plugin which is a pain. I installed a second plugin that disables compatibility checking but this will not run properly when I send the app out to our iMacs (says the file is malformed). Is there another way I can set FFox to NOT check compatibility of installed plugins / addons?

    Thanks again!

  2. #2

    Geoff's Avatar
    Join Date
    Jun 2005
    Location
    Fylde, Lancs, UK.
    Posts
    11,804
    Thank Post
    110
    Thanked 583 Times in 504 Posts
    Blog Entries
    1
    Rep Power
    224
    The file must be encoded, and renamed. There's an online encoder you can use here:

    Automatic Mozilla Configurator

    Once you've encoded it, you need to rename it to mozilla.cfg and put it in your Firefox program folder.

    Finally, in the greprefs folder there’s a file called all.js. Add the following line at the end of it:

    pref("general.config.filename", "mozilla.cfg");

  3. Thanks to Geoff from:

    iSteve (27th August 2008)

  4. #3

    Join Date
    Jan 2007
    Location
    The Console
    Posts
    236
    Thank Post
    22
    Thanked 29 Times in 23 Posts
    Rep Power
    22
    Thanks! I had a look at the mozilla.cfg generator thing yesterday, but I think my original file had bad line endings. It works now.

  5. #4

    Join Date
    Aug 2008
    Posts
    1
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I'm trying to accomplish locked preferences for Firefox as well. I've found various web sites detailing how to do this, but no matter what I try, I'm getting "Configuration Error: Failed to read the configuration file. Please contact your system administrator."

    I have a perl script which is "encrypting" the file with rot13, and I'm placing it in /Applications/Firefox.app/Contents/MacOS/grepprefs/

    Any idea where I'm going wrong?

    Thanks.

  6. #5

    Join Date
    Jan 2007
    Location
    The Console
    Posts
    236
    Thank Post
    22
    Thanked 29 Times in 23 Posts
    Rep Power
    22
    In greprefs, all.js, you add the line

    pref("general.config.filename", "mozilla.cfg");

    as Geoff said. You then make a text file with your config options/locks in. This goes in Firefox.app/Contents/MacOS after you have changed it to rot13 format and called it mozilla.cfg.

    The first time I tried this, I had the same error message. I then remade the text file in SubEthaEdit and changed the line endings to Windows line endings, saved it out as a .txt, then used the online configurator mentioned above to get the .cfg file.

    Hope that makes sense!

  7. #6

    Join Date
    Dec 2008
    Location
    San Luis Obispo, CA
    Posts
    1
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Has anyone actually gotten this to work in Firefox 3?

    I used Automatic Mozilla Configurator to byteshift my mozilla.txt and create a mozilla.cfg file.

    I have this working on my systems for Mozilla 1.7 and Firefox 2.18 and have so for years now. Ever since Firefox 1.0x I believe.

    It ignores the file in Firefox 3.04

    I've tried putting

    Code:
    pref("general.config.filename", "mozilla.cfg");
    at the end of

    /opt/sfw/lib/firefox3/defaults/pref/firefox.js

    and

    /opt/sfw/lib/firefox3/greprefs/all.js

    with no luck.

SHARE:
+ Post New Thread

Similar Threads

  1. Firefox 3
    By Domino in forum Other Stuff
    Replies: 33
    Last Post: 20th June 2008, 08:42 AM
  2. Firefox 3 Beta 4
    By mattx in forum General Chat
    Replies: 7
    Last Post: 12th March 2008, 06:41 PM
  3. Firefox instead of IE
    By DevilsAdvocate in forum Windows
    Replies: 14
    Last Post: 8th December 2007, 12:45 PM
  4. Firefox
    By ndavies in forum Educational Software
    Replies: 3
    Last Post: 31st October 2007, 02:10 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •