+ Post New Thread
Page 2 of 2 FirstFirst 12
Results 16 to 18 of 18
Mac Thread, Workgroup Manager permissions in Technical; You can also force refresh the MCX settings if you hold down the option key when logging in with an ...
  1. #16

    Join Date
    Sep 2013
    Location
    Oakville, ON
    Posts
    43
    Thank Post
    0
    Thanked 6 Times in 5 Posts
    Rep Power
    4
    You can also force refresh the MCX settings if you hold down the option key when logging in with an admin account (I think it's the option key!) which might be enough to kick things over. Also you can run the command line option: mcxquery (as the currently logged in user) to see what exactly is being done permissions wise by what user/group/computer/etc in WGM.

  2. #17

    Join Date
    Apr 2012
    Posts
    50
    Thank Post
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    They don't have access to terminal currently so I'll have to see how else I can do that.

    Edit: Scratch that, looks like they do have permission for terminal. (I should probably change that)

    Ok I found the issue. Looks like the person before me had permissions set for both the usergroup AND the computer group for applications. So when I turned off the usergroup permissions it then defaulted to the computer group. Not sure why she set both of them. Applications should only be controlled by the usergroup correct?
    Last edited by Stryker412; 30th September 2013 at 07:16 PM.

  3. #18
    stevehp's Avatar
    Join Date
    Jul 2008
    Location
    Ohio
    Posts
    102
    Thank Post
    13
    Thanked 19 Times in 16 Posts
    Rep Power
    16
    Quote Originally Posted by Stryker412 View Post
    They don't have access to terminal currently so I'll have to see how else I can do that.

    Edit: Scratch that, looks like they do have permission for terminal. (I should probably change that)

    Ok I found the issue. Looks like the person before me had permissions set for both the usergroup AND the computer group for applications. So when I turned off the usergroup permissions it then defaulted to the computer group. Not sure why she set both of them. Applications should only be controlled by the usergroup correct?
    Correct. System settings such as login window banners, time server, software update, etc. should be set for computer groups. Settings such as of course app restrictions, dock, system preference panes should be in the user group realm. Some can cross over as well such as printing which in a lab setting can be set on the computer level and in other instances at the user group level.

    If you set your users login shell to none instead of /bin/bash it wouldn't matter much if terminal.app was still allowed through your mcx app restrictions. They can open the app but the prompt to run commands won't display.

SHARE:
+ Post New Thread
Page 2 of 2 FirstFirst 12

Similar Threads

  1. Replies: 3
    Last Post: 9th November 2010, 08:56 AM
  2. Replies: 10
    Last Post: 26th March 2009, 06:17 PM
  3. Workgroup Manager / Managing Macs
    By brahma in forum Mac
    Replies: 3
    Last Post: 3rd December 2008, 12:02 PM
  4. Moneysoft Money Manager - permissions problems.
    By boomam in forum How do you do....it?
    Replies: 1
    Last Post: 22nd August 2008, 06:04 PM
  5. Replies: 3
    Last Post: 11th January 2008, 07:02 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •