+ Post New Thread
Page 2 of 14 FirstFirst 12345612 ... LastLast
Results 16 to 30 of 202
Internet Related/Filtering/Firewall Thread, YouTube for Schools launched in Technical; Anybody managed to implement this with Dansguardian/Squid?...
  1. #16

    Join Date
    Dec 2005
    Posts
    524
    Thank Post
    34
    Thanked 87 Times in 77 Posts
    Rep Power
    39
    Anybody managed to implement this with Dansguardian/Squid?

  2. #17
    tudorcrisp's Avatar
    Join Date
    Apr 2009
    Location
    Penrith
    Posts
    80
    Thank Post
    35
    Thanked 5 Times in 5 Posts
    Rep Power
    11
    I would be very interested to hear if somebody had managed to get this working with the RM Smartcache 2!

  3. #18

    AngryTechnician's Avatar
    Join Date
    Oct 2008
    Posts
    3,730
    Thank Post
    698
    Thanked 1,211 Times in 761 Posts
    Rep Power
    394
    The SmartCache 2 does not support either of the required methods for this, and given the stagnant development of the product, I suspect it never will.

  4. 2 Thanks to AngryTechnician:

    Moohorse (13th December 2011), tudorcrisp (13th December 2011)

  5. #19

    GrumbleDook's Avatar
    Join Date
    Jul 2005
    Location
    Gosport, Hampshire
    Posts
    9,930
    Thank Post
    1,337
    Thanked 1,781 Times in 1,105 Posts
    Blog Entries
    19
    Rep Power
    594
    EMBC are looking at this already (as part of the NEN tech Group) and I'll feedback on EMBC specific stuff shortly.

  6. #20
    zag
    zag is offline
    zag's Avatar
    Join Date
    Mar 2007
    Posts
    3,762
    Thank Post
    897
    Thanked 416 Times in 350 Posts
    Blog Entries
    12
    Rep Power
    86
    Also looking for a way to do this on the Sophos web filter. Anyone done it yet?

  7. #21

    GrumbleDook's Avatar
    Join Date
    Jul 2005
    Location
    Gosport, Hampshire
    Posts
    9,930
    Thank Post
    1,337
    Thanked 1,781 Times in 1,105 Posts
    Blog Entries
    19
    Rep Power
    594
    As an idea ... it might be worth those who have their own filters (Sophos, etc) if you email those companies to ask for instructions ... and then link to them on here.

  8. #22
    mrbios's Avatar
    Join Date
    Jun 2007
    Location
    Stroud, Gloucestershire
    Posts
    2,450
    Thank Post
    349
    Thanked 255 Times in 210 Posts
    Rep Power
    98
    Can anyone tell me what i should see exactly when it works? Currently i don't think it's working and i'm not having a lot of luck :/

  9. #23
    tudorcrisp's Avatar
    Join Date
    Apr 2009
    Location
    Penrith
    Posts
    80
    Thank Post
    35
    Thanked 5 Times in 5 Posts
    Rep Power
    11
    I think the obvious thing would be the user comments have disappeared.

  10. #24


    tom_newton's Avatar
    Join Date
    Sep 2006
    Location
    Leeds
    Posts
    4,462
    Thank Post
    866
    Thanked 845 Times in 667 Posts
    Rep Power
    195
    Quote Originally Posted by mrbios View Post
    Can anyone tell me what i should see exactly when it works? Currently i don't think it's working and i'm not having a lot of luck :/
    Depends how you're doing it.
    By URL, you will see an error if you go to youtube.com. That Error will link to /education
    By Header, you will be redirected to /education automatically

  11. #25


    tom_newton's Avatar
    Join Date
    Sep 2006
    Location
    Leeds
    Posts
    4,462
    Thank Post
    866
    Thanked 845 Times in 667 Posts
    Rep Power
    195
    Quote Originally Posted by mrbios View Post
    Well, as much as i hate third party programs, especially for a system such as ISA, this one seems ok. I've got it installed, and I've setup my header rule but i can't get it to work, someone else with ISA come and start setting yours up so you can find what i'm doing wrong!

    EDIT: this is what i've set, can anyone point out what i've done wrong? (see image - ignore the difference in the "applies to" i was messing around with settings)
    {Caveat: ISA expert I am not} It looks like you are trying to *modify* a header here - you need to be able to *add* the header, as it won't already exist. dansguardian users may find the same limitation applies.

  12. #26
    mrbios's Avatar
    Join Date
    Jun 2007
    Location
    Stroud, Gloucestershire
    Posts
    2,450
    Thank Post
    349
    Thanked 255 Times in 210 Posts
    Rep Power
    98
    Quote Originally Posted by tom_newton View Post
    {Caveat: ISA expert I am not} It looks like you are trying to *modify* a header here - you need to be able to *add* the header, as it won't already exist. dansguardian users may find the same limitation applies.
    Ah, well that's a slight problem then changed it now, just going to do some testing....

    Does anyone know exactly what i need to be using out of these 4 selections:
    Raw request header
    Raw response header
    Processed request header
    Processed response header

    ?

    EDIT:
    Raw request headers are headers received from the client, but not yet processed by Microsoft ISA Server (Forefront TMG). These headers come from the client browser to ISA Server (Forefront TMG).
    Processed request headers are headers received from the client and processed by Microsoft ISA Server (Forefront TMG). These headers are passed to the remote web server that will process the request.
    Raw response headers are headers received from the remote web server and not yet processed by ISA Server (Forefront TMG).
    Processed response headers are headers processed by ISA Server (Forefront TMG) and sent to the client browser.

    Found that, i'd assume that i needed the processed request header going by that, but i just don't really know.

    EDIT: Also where i'm asked for "Header Name:" in one box and "Header Value:" In another, do i split up the "X-YouTube-Edu-Filter:###########" so that the "X-YouTube-Edu-Filter" bit is in the name and the "#######" in the other or is the name not important and i just need to put the whole thing in to the value field.
    Last edited by mrbios; 13th December 2011 at 11:33 AM.

  13. #27
    sister_annex's Avatar
    Join Date
    Jan 2009
    Location
    Wolverhampton
    Posts
    593
    Thank Post
    99
    Thanked 135 Times in 119 Posts
    Rep Power
    49
    Quote Originally Posted by mrbios View Post
    someone else with ISA come and start setting yours up so you can find what i'm doing wrong!
    hmmm... will do once we move to TMG (we're still on ISA 2006)

  14. #28
    mrbios's Avatar
    Join Date
    Jun 2007
    Location
    Stroud, Gloucestershire
    Posts
    2,450
    Thank Post
    349
    Thanked 255 Times in 210 Posts
    Rep Power
    98
    Quote Originally Posted by sister_annex View Post
    hmmm... will do once we move to TMG (we're still on ISA 2006)
    ISA2006 is what i'm using here, this header modifier program works on all versions

  15. Thanks to mrbios from:

    sister_annex (13th December 2011)

  16. #29
    sister_annex's Avatar
    Join Date
    Jan 2009
    Location
    Wolverhampton
    Posts
    593
    Thank Post
    99
    Thanked 135 Times in 119 Posts
    Rep Power
    49
    OOOOhhhh

    cheers!

  17. #30
    mrbios's Avatar
    Join Date
    Jun 2007
    Location
    Stroud, Gloucestershire
    Posts
    2,450
    Thank Post
    349
    Thanked 255 Times in 210 Posts
    Rep Power
    98
    Ok everyone using ISA/TMG i can help you!

    1) Install this program: http://www.redline-software.com/pub/tkSetup.exe - Run that on your ISA server installing just the "Headers modifier" section (requires the firewall service to restart during install, so 60 seconds loss of internet connection!)

    2) Go to Configuration > Add-ins > Web filters and go to the properties of "Headers Modifier" > Parameters > Add

    3) Name the rule whatever you want and select "applies to: Processed request headers"

    4) Click Add at the bottom, leave action set to "add header", set header name to "X-YouTube-Edu-Filter" and Header value to whatever the set of letters and numbers is assigned to you on your school profile

    5) Go to Conditions, set the first condition to be a "policy rule" and have it "Equal" with the value of your outbound web access policy. Now add a second condition with the following settings: "AND" "Web Site Name" "Contains" "youtube" That should do it.

    And that should hopefully work Quite a rough set of instructions. Here's a screenshot of my settings to give you a better idea.... (IGNORE THE FIRST SET OF CONDITIONS, THEY'RE WRONG, SEE CORRECTED SECOND IMAGE)
    Attached Images Attached Images
    Last edited by mrbios; 13th December 2011 at 02:13 PM.

  18. 4 Thanks to mrbios:

    Alis_Klar (20th November 2012), drdos256 (14th December 2012), sister_annex (13th December 2011), TheScarfedOne (13th December 2011)

SHARE:
+ Post New Thread
Page 2 of 14 FirstFirst 12345612 ... LastLast

Similar Threads

  1. PC Pro - OpenSource is no good for schools?
    By Ric_ in forum General Chat
    Replies: 60
    Last Post: 21st August 2012, 12:16 PM
  2. LNL Free Printers for Schools
    By OverWorked in forum General Chat
    Replies: 19
    Last Post: 20th September 2006, 07:16 PM
  3. Survey for schools at Computer active.
    By tosca925 in forum General Chat
    Replies: 0
    Last Post: 28th March 2006, 08:04 PM
  4. Which CMS for School Website?
    By Ric_ in forum How do you do....it?
    Replies: 19
    Last Post: 10th November 2005, 12:41 PM
  5. Microsoft tool for schools
    By russdev in forum Windows
    Replies: 8
    Last Post: 28th July 2005, 06:15 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •