+ Post New Thread
Results 1 to 13 of 13
Internet Related/Filtering/Firewall Thread, [Smoothwall] Dropbox not working in Technical; Hi, We cant get our smoothwall to work with dropbox... we're on unfiltered access but it still wont connect. It ...
  1. #1
    linkazoid's Avatar
    Join Date
    May 2007
    Location
    London
    Posts
    643
    Thank Post
    118
    Thanked 89 Times in 73 Posts
    Rep Power
    78

    [Smoothwall] Dropbox not working

    Hi,

    We cant get our smoothwall to work with dropbox... we're on unfiltered access but it still wont connect. It keeps telling me that I have invalid proxy settings.

    Has anyone got it working with smoothwall with NTLM Auth? I've just seen on Dropbox's KB that it does not work with NTLM Auth, so can I bodge it?

    Michael

  2. #2

    rob_f's Avatar
    Join Date
    May 2008
    Location
    Leeds
    Posts
    224
    Thank Post
    15
    Thanked 73 Times in 56 Posts
    Rep Power
    25
    If it doesn't support NTLM Auth you might want to try putting the domains it requires into Guardian > Authentication > Settings "Do not require auth for" box - not sure off the top of my head which ones it may be, but dropbox.com would be a good start.

    Hope this helps,


    Rob.

  3. Thanks to rob_f from:

    linkazoid (29th April 2010)

  4. #3
    linkazoid's Avatar
    Join Date
    May 2007
    Location
    London
    Posts
    643
    Thank Post
    118
    Thanked 89 Times in 73 Posts
    Rep Power
    78
    Thanks Rob.. Didn't actually think of putting it in there. Will try tomorrow and let you know.

    Michael

  5. #4

    Sylv3r's Avatar
    Join Date
    Jul 2005
    Location
    Co. Durham
    Posts
    3,203
    Thank Post
    372
    Thanked 376 Times in 334 Posts
    Rep Power
    147
    I have it working here and I can't remember making any changes to our Smoothwall config to get it to work - thats not to say we didn't - Ive probably just forgot!

  6. #5
    badders's Avatar
    Join Date
    Apr 2007
    Location
    Cumbria
    Posts
    170
    Thank Post
    44
    Thanked 11 Times in 10 Posts
    Rep Power
    21
    Did anybody get this working? I've added dropbox.com to the "Do not require auth" box which has stopped the initial proxy error but dropbox is still not connecting.

  7. #6

    Sylv3r's Avatar
    Join Date
    Jul 2005
    Location
    Co. Durham
    Posts
    3,203
    Thank Post
    372
    Thanked 376 Times in 334 Posts
    Rep Power
    147
    Quote Originally Posted by badders View Post
    Did anybody get this working? I've added dropbox.com to the "Do not require auth" box which has stopped the initial proxy error but dropbox is still not connecting.
    I'll check our config on our box tomorrow and see if I can find anything obvious.

  8. #7
    hil
    hil is offline
    hil's Avatar
    Join Date
    Nov 2009
    Location
    Devon
    Posts
    80
    Thank Post
    5
    Thanked 4 Times in 4 Posts
    Rep Power
    10
    I have it working at my school and did not change anything in Smoothwall. I have got the filterend proxy in as well.

  9. Thanks to hil from:

    tom_newton (27th September 2010)

  10. #8
    CJF
    CJF is offline

    CJF's Avatar
    Join Date
    Aug 2010
    Location
    Leeds, UK
    Posts
    250
    Thank Post
    26
    Thanked 85 Times in 67 Posts
    Rep Power
    22
    Hi Guys...
    To get dropbox working smoothly on our test network I had to add the domain exception as suggested by Rob_F and also added the domain to the Custom allowed content category in [guardian filtering user defined categories].
    Hope this helps...

  11. #9

    Sylv3r's Avatar
    Join Date
    Jul 2005
    Location
    Co. Durham
    Posts
    3,203
    Thank Post
    372
    Thanked 376 Times in 334 Posts
    Rep Power
    147
    Quote Originally Posted by CJF View Post
    Hi Guys...
    To get dropbox working smoothly on our test network I had to add the domain exception as suggested by Rob_F and also added the domain to the Custom allowed content category in [guardian filtering user defined categories].
    Hope this helps...
    Bit late in replying but these were the changes we had made also.

  12. Thanks to Sylv3r from:

    tom_newton (27th September 2010)

  13. #10
    badders's Avatar
    Join Date
    Apr 2007
    Location
    Cumbria
    Posts
    170
    Thank Post
    44
    Thanked 11 Times in 10 Posts
    Rep Power
    21
    I've added dropbox.com to the custom allowed and it's still not connecting. The smoothwall logs show "DENIED Your username is not allowed to web browse".

  14. #11


    tom_newton's Avatar
    Join Date
    Sep 2006
    Location
    Leeds
    Posts
    4,461
    Thank Post
    866
    Thanked 845 Times in 667 Posts
    Rep Power
    195
    Aha! That's the root of your problem.
    When you put a site in do-not-auth-for, it doesn't get authenticated, so for that single request, you don't have a username - and for that single request, your group becomes "Unauthenticated IPs" - because most of our auth methods are stateless, and rely on re-assessing authentication details on every transaction. More secure, but quite intensive - and prone to fail for bad software. Anyway.

    Because you have "unauthenticated IPs" as "no browsing" (see guardian/auth/settings) you will get blocked when you don't authenticate. To fix this, you will need to:
    1. allow unauth' IPs to browse
    2. Create a rule: Unauthenticated IPS, Everything, All the time, Block (this re-instates the "no browsing" rule in an overridable way)
    3. Create a rule "Unauthenticated IPs, Custom Allowed Content, All the time, Allow"

    Assuming dropbox is in CAC, you'll be golden.

    HTH,

    Tom

  15. 2 Thanks to tom_newton:

    badders (28th September 2010), zag (3rd July 2013)

  16. #12
    badders's Avatar
    Join Date
    Apr 2007
    Location
    Cumbria
    Posts
    170
    Thank Post
    44
    Thanked 11 Times in 10 Posts
    Rep Power
    21
    That's got it working, thanks Tom.

  17. #13

    TechMonkey's Avatar
    Join Date
    Dec 2005
    Location
    South East
    Posts
    3,286
    Thank Post
    225
    Thanked 405 Times in 302 Posts
    Rep Power
    162
    In case anyone comes looking here for how to do this in the new interface I created a new User Defined group & called it Bypass Auth. Then went to Web proxy Authentication Exceptions and added Bypass Auth. Seems happy though beware, when setting up Dropbox it kept bringing up the Proxy page or telling me it hadn't connected, making me think it had failed, but carried on quite happily if I clicked reconnect.

SHARE:
+ Post New Thread

Similar Threads

  1. [Website] Dropbox Invites
    By russdev in forum Jokes/Interweb Things
    Replies: 7
    Last Post: 16th August 2010, 11:27 AM
  2. DropBox
    By Ecalpemos2000 in forum Virtual Learning Platforms
    Replies: 4
    Last Post: 29th April 2010, 05:18 PM
  3. Anyone using Dropbox for students?
    By m0nty in forum Windows
    Replies: 2
    Last Post: 5th March 2010, 11:50 AM
  4. Dropbox
    By somabc in forum *nix
    Replies: 0
    Last Post: 10th September 2008, 12:09 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •