+ Post New Thread
Results 1 to 7 of 7
Internet Related/Filtering/Firewall Thread, IE Authentication... in Technical; So... Just got round to putting our smoothwall box in, setup was fine, but i'm struggling with authentication, can anyone ...
  1. #1
    Dom_'s Avatar
    Join Date
    Dec 2008
    Posts
    1,009
    Thank Post
    151
    Thanked 138 Times in 115 Posts
    Rep Power
    55

    IE Authentication...

    So...

    Just got round to putting our smoothwall box in, setup was fine, but i'm struggling with authentication, can anyone help me?

    Currently, when log in and open internet explorer i'm greeted by the cache error message saying my login details are incorrect... however if I open firefox i'm greeted by a login box, where i can authenticate my details. Once i authenticate through firefox internet explorer works fine.

    We've gone a step further with firefox, changing the config to allow NTLM, this has taken away the login box and authenticates itself, which then allows ie to work.

    But... most of the machines here just run IE, so using firefox to authenticate as a workaround isn't really an option...

    Does anyone have any ideas how I can authenticate using internet explorer? (without a popup box)

    Smoothwall support has been great so far, but 21000 heads are better than 2 :-)

    Dom

  2. #2

    rob_f's Avatar
    Join Date
    May 2008
    Location
    Leeds
    Posts
    220
    Thank Post
    15
    Thanked 73 Times in 56 Posts
    Rep Power
    25
    Hey Dom,

    Two quick things that might help - when using Internet Explorer how are you setting your proxy details? If using manual configuration ensure that you do not proxy for the SmoothWall itself - might need to do this by IP, hostname and FQDN depending on how IE feels today Alternatively if you use the auto configuration script at http://smoothwall.address/proxy.pac this should set it up for you.

    Also, if you're not intending on doing inline transparent filtering, make sure that transparent isn't ticked on Guardian > Proxy > Web Proxy (towards the top) then save and restart.

    Hope this helps, if not please let me know.

    Thanks,



    Rob.

  3. #3
    Dom_'s Avatar
    Join Date
    Dec 2008
    Posts
    1,009
    Thank Post
    151
    Thanked 138 Times in 115 Posts
    Rep Power
    55
    Cheers Rob, I've tried the things you suggested, I was using manual proxy, but tried the proxy.pac (no difference).

    I then disabled the transparent filtering, which now prompts a login box for IE (which is a bit better, but still not perfect!)

    Dom

  4. #4

    rob_f's Avatar
    Join Date
    May 2008
    Location
    Leeds
    Posts
    220
    Thank Post
    15
    Thanked 73 Times in 56 Posts
    Rep Power
    25
    Good stuff. Assuming you're using NTLM Authentication - is this a domain workstation on the same domain as the SmoothWall? Are you logged-in with a domain user account?

    Ta,


    Rob.

  5. #5

    rob_f's Avatar
    Join Date
    May 2008
    Location
    Leeds
    Posts
    220
    Thank Post
    15
    Thanked 73 Times in 56 Posts
    Rep Power
    25
    Actually just seen you say that Firefox automatically and invisibly logs you in without asking for username and password. In which case is there anything that might make IE think that the SmoothWall isn't a local system, hence not automatically sending login details to it? Like it being on a non-local subnet or by non-standard local intranet zone settings?

  6. #6
    Dom_'s Avatar
    Join Date
    Dec 2008
    Posts
    1,009
    Thank Post
    151
    Thanked 138 Times in 115 Posts
    Rep Power
    55
    Ah, disabling transparent seems to have foobed all authentication, firefox pops the login box too now, but won't accept any of the stuff i enter...

  7. #7


    Join Date
    Dec 2005
    Location
    In the server room, with the lead pipe.
    Posts
    4,534
    Thank Post
    271
    Thanked 752 Times in 590 Posts
    Rep Power
    218
    Can you log into your domain using username@FQDN? Is that info populated in AD Users and Computers for all user accounts under user logon name?

    It may be (depending on how you're bulk creating accounts) that you're missing info SW relies on to authenticate you.

    You can bulk add the FQDN using ADModify if that's the case.

SHARE:
+ Post New Thread

Similar Threads

  1. Becta - Authentication
    By danIT in forum General Chat
    Replies: 1
    Last Post: 8th January 2009, 09:23 AM
  2. URL Authentication
    By kerlj001 in forum EduGeek Joomla 1.0 Package
    Replies: 4
    Last Post: 10th December 2008, 09:08 PM
  3. Squid authentication
    By localzuk in forum *nix
    Replies: 21
    Last Post: 14th February 2007, 08:08 AM
  4. OS X AD Authentication
    By Ric_ in forum Mac
    Replies: 8
    Last Post: 29th August 2006, 02:13 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •