+ Post New Thread
Results 1 to 14 of 14
Internet Related/Filtering/Firewall Thread, Ubuntu Server Wordpress Proxy Settings Not Working in Technical; Hi, Hopefully someone knows the answer to this as it's driving me mad. I can't get wordpress to see the ...
  1. #1
    Trojan's Avatar
    Join Date
    Aug 2007
    Location
    Sutton Coldfield
    Posts
    191
    Thank Post
    137
    Thanked 31 Times in 18 Posts
    Rep Power
    20

    Ubuntu Server Wordpress Proxy Settings Not Working

    Hi,

    Hopefully someone knows the answer to this as it's driving me mad. I can't get wordpress to see the internet via the proxy server.

    I have edited wp-config.php as per: WordPress Proxysupport |

    But this doesn't work, RSS feeds don't load and plugins/themes cant be retrieved.

    Has anybody come across this before?

    Thanks.

  2. #2
    Cache's Avatar
    Join Date
    Apr 2008
    Location
    Cumbria
    Posts
    1,305
    Thank Post
    488
    Thanked 190 Times in 184 Posts
    Blog Entries
    3
    Rep Power
    67
    I had a nightmare getting this working too, one install I couldn't work out what was happening so had to flatten and reinstall.

    Sounds daft, but positioning is critical in the wp-config.php file, make sure it isn't below the "That's all, stop editing" line, not the bottom of the file otherwise it won't apply them and also don't rely on the Frontpage widgets to see if it's working or not - I found some blogs took a day or 2 before the widgets started to update correctly. Searching for a plugin/theme was always a better test.

  3. Thanks to Cache from:

    Trojan (14th July 2014)

  4. #3
    Trojan's Avatar
    Join Date
    Aug 2007
    Location
    Sutton Coldfield
    Posts
    191
    Thank Post
    137
    Thanked 31 Times in 18 Posts
    Rep Power
    20
    Thanks for this. I'll take a look at the config file on Monday. I have a feeling I have the proxy settings right at the bottom of the file.

  5. #4
    Trojan's Avatar
    Join Date
    Aug 2007
    Location
    Sutton Coldfield
    Posts
    191
    Thank Post
    137
    Thanked 31 Times in 18 Posts
    Rep Power
    20
    Mixed success, the frontpage widgets work but can't search for a theme or plugin. I am about to give up on this ! It's so annoying.. bloody proxy server ..mumble grumble..

  6. #5
    Marci's Avatar
    Join Date
    Jun 2008
    Location
    Wakefield, West Yorkshire
    Posts
    897
    Thank Post
    84
    Thanked 235 Times in 194 Posts
    Rep Power
    83
    See Intranet - Wordpress behind Smoothwall

    Some bits are done client-side, others are done server side.

  7. Thanks to Marci from:

    Trojan (15th July 2014)

  8. #6
    Cache's Avatar
    Join Date
    Apr 2008
    Location
    Cumbria
    Posts
    1,305
    Thank Post
    488
    Thanked 190 Times in 184 Posts
    Blog Entries
    3
    Rep Power
    67
    Strange....

    If your still having issues tomorrow I'll try and take a look at the config I've used for our internal Wordpress Networks and post it up, I did get it down to a fine art but can't remember the details.

  9. Thanks to Cache from:

    Trojan (15th July 2014)

  10. #7
    Trojan's Avatar
    Join Date
    Aug 2007
    Location
    Sutton Coldfield
    Posts
    191
    Thank Post
    137
    Thanked 31 Times in 18 Posts
    Rep Power
    20
    Quote Originally Posted by Cache View Post
    Strange....

    If your still having issues tomorrow I'll try and take a look at the config I've used for our internal Wordpress Networks and post it up, I did get it down to a fine art but can't remember the details.
    Yep, still not working. Would be great if you could post up what you have.. Thanks.

  11. #8
    Cache's Avatar
    Join Date
    Apr 2008
    Location
    Cumbria
    Posts
    1,305
    Thank Post
    488
    Thanked 190 Times in 184 Posts
    Blog Entries
    3
    Rep Power
    67
    I don't think I've done anything that you wouldn't have done, however the wp-config is attached if it helps.
    Attached Images Attached Images

  12. Thanks to Cache from:

    Trojan (17th July 2014)

  13. #9
    Cache's Avatar
    Join Date
    Apr 2008
    Location
    Cumbria
    Posts
    1,305
    Thank Post
    488
    Thanked 190 Times in 184 Posts
    Blog Entries
    3
    Rep Power
    67
    Spotted today, I don't have a space after the comma proxy_host and proxy_port

    I don't think that'll make a difference, however thinking about it there was something very particular about getting it to work. I'll keep on thinking, however it was something like that...

  14. Thanks to Cache from:

    Trojan (17th July 2014)

  15. #10
    Trojan's Avatar
    Join Date
    Aug 2007
    Location
    Sutton Coldfield
    Posts
    191
    Thank Post
    137
    Thanked 31 Times in 18 Posts
    Rep Power
    20
    My WP-config looks the same. I'll try it without the space..

    Thanks again.

  16. #11
    Cache's Avatar
    Join Date
    Apr 2008
    Location
    Cumbria
    Posts
    1,305
    Thank Post
    488
    Thanked 190 Times in 184 Posts
    Blog Entries
    3
    Rep Power
    67
    Another question, have you installed php5-curl?

    Just spotted it at the bottom of my notes... Sorry

  17. #12
    Trojan's Avatar
    Join Date
    Aug 2007
    Location
    Sutton Coldfield
    Posts
    191
    Thank Post
    137
    Thanked 31 Times in 18 Posts
    Rep Power
    20
    Hi, no I didn't install that.. is it required ?

    Thanks.

  18. #13

    Join Date
    Dec 2005
    Posts
    548
    Thank Post
    38
    Thanked 90 Times in 80 Posts
    Rep Power
    40
    I cannot really answer related to wordpress and proxies

    But whenever I have setup ubuntu for squid/dansguardian behind our LA proxy I always have issues with getting wget to work.

    So I always set server wide proxy settings in /etc/environment

    See example details here

    Everything then seems to work fine after that!

  19. #14
    Cache's Avatar
    Join Date
    Apr 2008
    Location
    Cumbria
    Posts
    1,305
    Thank Post
    488
    Thanked 190 Times in 184 Posts
    Blog Entries
    3
    Rep Power
    67
    Yeah, I'm pretty sure Wordpress uses Curl to try and pull the files it requires.

    Code:
    sudo apt-get install php5-curl
    should hopefully get you sorted.



SHARE:
+ Post New Thread

Similar Threads

  1. IE 10 Proxy Settings not working
    By bwestlake in forum Internet Related/Filtering/Firewall
    Replies: 2
    Last Post: 25th April 2014, 03:49 PM
  2. Replies: 3
    Last Post: 26th August 2010, 07:09 PM
  3. Proxy settings not there on second logon.
    By robinhood in forum Learning Network Manager
    Replies: 7
    Last Post: 6th October 2007, 12:14 PM
  4. Ubuntu Server FQ Domain name not set
    By mark in forum *nix
    Replies: 6
    Last Post: 26th July 2007, 12:35 PM
  5. Proxy Settings Not Applied
    By dezt in forum Wireless Networks
    Replies: 16
    Last Post: 3rd October 2006, 09:26 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •