+ Post New Thread
Results 1 to 10 of 10
Internet Related/Filtering/Firewall Thread, Cisco 1941 as adsl router - ISP username and password change in Technical; I have a cisco 1941 as our adsl router as we have a bonded adsl connection with 2 ADSL wic ...
  1. #1
    timbo343's Avatar
    Join Date
    Dec 2005
    Location
    Leeds/York area, North Yorkshire
    Posts
    2,975
    Thank Post
    287
    Thanked 266 Times in 191 Posts
    Rep Power
    115

    Cisco 1941 as adsl router - ISP username and password change

    I have a cisco 1941 as our adsl router as we have a bonded adsl connection with 2 ADSL wic cards in.

    We have just changed our ISP line rental provider over to talktalk business and i was wondering if someone could talk me through how to change the ISP connection username and password.

    The config part of the router for the adsl is here:

    Code:
    interface ATM0/0/0
     description dsl1
     bandwidth 8000
     no ip address
     no atm ilmi-keepalive
     pvc SHS1 0/38
      encapsulation aal5mux ppp dialer
      dialer pool-member 1
     !
    !
    interface ATM0/1/0
     bandwidth 8000
     no ip address
     no atm ilmi-keepalive
     pvc SHS2 0/38
      encapsulation aal5mux ppp dialer
      dialer pool-member 1
     !
    !
    interface Dialer0
     ip address negotiated
     ip accounting output-packets
     ip nat outside
     ip virtual-reassembly in
     encapsulation ppp
     dialer pool 1
     dialer idle-timeout 0
     dialer persistent
     dialer-group 1
     ppp authentication chap callin
     ppp chap hostname gotadsl.co.uk/xxxxxxxxxxx
     ppp chap password 7 xxxxxxxxxxxxxxxxxxxx
     ppp ipcp dns request
     ppp multilink
     ppp multilink fragment disabled
    Thanks

  2. #2

    Join Date
    Apr 2012
    Location
    Leeds
    Posts
    292
    Thank Post
    0
    Thanked 63 Times in 51 Posts
    Rep Power
    35
    sure do this

    en (this puts you into enable mode)
    conf t (this allows you to change the config)
    int dialer0 (selects the dialer0 interface)
    no ppp chap hostname gotadsl.co.uk/xxxxxxxxxxxx (removes the line)
    ppp chap hostname <PUT YOUR DSL USERNAME HERE> (puts in a replacement line)
    ppp chap password 7 <PUT YOUR DSL PASSWORD HERE> (puts in replacement line)
    exit (takes you out of config mode)
    exit (takes you out of enable mode)
    wr m (writes the config to memory. Make sure you've already taken a backup of it!)

    How ever there are a few issues with your config. I highly suspect that TalkTalk Business does not support multi-link PPP which is going to be a big problem as this is what is used to do bonding.

    Also if you go to 1 x ADSL line get rid of the bandwidth 8000 lines under the atm interfaces. In fact thinking about it you only want 1 x ATM interface. Best put up the whole config as this will screw stuff up later too.

    Thanks

    Dave

  3. #3
    timbo343's Avatar
    Join Date
    Dec 2005
    Location
    Leeds/York area, North Yorkshire
    Posts
    2,975
    Thank Post
    287
    Thanked 266 Times in 191 Posts
    Rep Power
    115
    Thanks i thought that was how i did it but i couldn't find the bit where i needed to put each adsl connection until i was on the phone to them and sure enough they dont support multi-link PPP lines, feels like i have just taken a massive step backwards. Might have to look at fibre instead of 2 lines. Turns out that one of our lines has been transfered over without any problems however the second line was rejected by the original company, PITA!! All this as school thought they could make savings.
    Last edited by timbo343; 8th April 2013 at 04:21 PM.

  4. #4

    Join Date
    Nov 2012
    Location
    Lancashire
    Posts
    40
    Thank Post
    2
    Thanked 4 Times in 4 Posts
    Rep Power
    4
    Hi. I have a cisco 877w which I use for home use. I'm also with TalkTalk. Hope my settings can help you. I used cisco configuration professional to do most of the work for me and to additionally lock down my router.
    Code:
    !
    interface ATM0
     no ip address
     no ip redirects
     no ip unreachables
     no ip proxy-arp
     ip flow ingress
     no atm ilmi-keepalive
     dsl operating-mode itu-dmt
    !
    !
    interface ATM0.1 point-to-point
     no ip redirects
     no ip unreachables
     no ip proxy-arp
     ip flow ingress
     pvc 0/38
      pppoe-client dial-pool-number 1
     !
    !
    interface Dialer0
     description $FW_OUTSIDE$
     ip address negotiated
     ip access-group 102 in
     no ip redirects
     no ip unreachables
     no ip proxy-arp
     ip mtu 1452
     ip flow ingress
     ip nat outside
     ip inspect CCP_LOW out
     ip virtual-reassembly max-fragments 64 max-reassemblies 512
     encapsulation ppp
     dialer pool 1
     dialer-group 1
     no cdp enable
     ppp authentication chap callin
     ppp chap hostname xxxxxxxxxx@talktalk.net
     ppp chap password 7 06275A111466592D503C30
     ppp ipcp dns request
    Last edited by techsup1983; 8th April 2013 at 09:42 PM.

  5. #5
    timbo343's Avatar
    Join Date
    Dec 2005
    Location
    Leeds/York area, North Yorkshire
    Posts
    2,975
    Thank Post
    287
    Thanked 266 Times in 191 Posts
    Rep Power
    115
    Quote Originally Posted by techsup1983 View Post
    Hi. I have a cisco 877w which I use for home use. I'm also with TalkTalk. Hope my settings can help you. I used cisco configuration professional to do most of the work for me and to additionally lock down my router.
    Code:
    !
    interface ATM0
     no ip address
     no ip redirects
     no ip unreachables
     no ip proxy-arp
     ip flow ingress
     no atm ilmi-keepalive
     dsl operating-mode itu-dmt
    !
    !
    interface ATM0.1 point-to-point
     no ip redirects
     no ip unreachables
     no ip proxy-arp
     ip flow ingress
     pvc 0/38
      pppoe-client dial-pool-number 1
     !
    !
    interface Dialer0
     description $FW_OUTSIDE$
     ip address negotiated
     ip access-group 102 in
     no ip redirects
     no ip unreachables
     no ip proxy-arp
     ip mtu 1452
     ip flow ingress
     ip nat outside
     ip inspect CCP_LOW out
     ip virtual-reassembly max-fragments 64 max-reassemblies 512
     encapsulation ppp
     dialer pool 1
     dialer-group 1
     no cdp enable
     ppp authentication chap callin
     ppp chap hostname xxxxxxxxxx@talktalk.net
     ppp chap password 7 06275A111466592D503C30
     ppp ipcp dns request
    Thanks, are you bonding the lines together in the router?

  6. #6

    Join Date
    Nov 2012
    Location
    Lancashire
    Posts
    40
    Thank Post
    2
    Thanked 4 Times in 4 Posts
    Rep Power
    4
    hi, im not sorry. i just have regular adsl

  7. #7
    timbo343's Avatar
    Join Date
    Dec 2005
    Location
    Leeds/York area, North Yorkshire
    Posts
    2,975
    Thank Post
    287
    Thanked 266 Times in 191 Posts
    Rep Power
    115
    I need some help on this please.

    I have just changed my PPP Chap hostname to the new hostname talktalkbusiness gave me along with the password and guess what, things dont work.

    The cisco 1941 router can ping 8.8.8.8 without any problems and can also ping my smoothwall box however. My smoothwall box can also ping the router however, i cannot get my network or the smoothwall to ping 8.8.8.8 or anything on the net.

    Here is my original config:


    Code:
    UNAUTHORISED ACCESS IS NOT PERMITTED
    1941#sh run
    Building configuration...
    
    Current configuration : 4500 bytes
    !
    ! Last configuration change at 16:34:33 UTC Thu Jan 26 2012 by enable
    ! NVRAM config last updated at 16:34:35 UTC Thu Jan 26 2012 by enable
    ! NVRAM config last updated at 16:34:35 UTC Thu Jan 26 2012 by enable
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname 1941
    !
    boot-start-marker
    boot-end-marker
    !
    !
    logging buffered 51200 warnings
    !
    no aaa new-model
    !
    no ipv6 cef
    ip source-route
    ip cef
    !
    !
    !
    !
    !
    ip domain name xxxxxx
    ip name-server 212.139.132.5
    multilink bundle-name authenticated
    !
    crypto pki token default removal timeout 0
    !
    crypto pki trustpoint TP-self-signed-2726665327
     enrollment selfsigned
     subject-name cn=IOS-Self-Signed-Certificate-2726665327
     revocation-check none
     rsakeypair TP-self-signed-2726665327
    !
    !
    crypto pki certificate chain TP-self-signed-2726665327
     certificate self-signed 01
      3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
      31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
      69666963 6174652D 32373236 36363533 3237301E 170D3131 30393234 30373538
      34345A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
      4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 37323636
      36353332 3730819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
      8100C932 CCB5F76C 1FBE016E 2428CB92 A59A8145 93A58C3C 8F5FAC0C 80645C26
      32B1AA71 52262B91 BDA3EB3C 177BC599 4E3CA567 37369251 D7FBA7FA 0097F738
      3961AD4D 89EF4C7A 2AF85F28 6C5268CA 3E8CDBE5 A70930F0 988DD20B 5E0D290F
      35E7A346 90B71279 5434F55C 1C9364F5 17E81760 8996CFDF BCEDA44E 23CC11D7
      0BC30203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
      551D2304 18301680 14CA9EDB C192460D 06647B98 04E4D2E9 A839CB61 76301D06
      03551D0E 04160414 CA9EDBC1 92460D06 647B9804 E4D2E9A8 39CB6176 300D0609
      2A864886 F70D0101 05050003 81810062 95E460FC 38F9DDEE 4C2F966D 5F1D8D4D
      7346B6C9 DC25CB4A 90B76BA9 981416D9 8AB8FDBB E9E86A7A 89908920 9534CCD6
      8F6152BD 44FB8AEF FAC75DD5 457E7293 DD1F4720 E0430FAA 1F1E55AA 26F9F91D
      0EF4A875 31CB142D 03FBB107 92D49AA0 2A9B3C31 67298D7B 690E59D4 EC64B162
      3360A8E8 40446591 750A1329 5D393A
            quit
    license udi pid CISCO1941/K9 sn FGL153927JM
    !
    !
    username enable privilege 15 secret 5 $1$V//F$yvPq2ahgHXOZPl.4N5gVW/
    username admin privilege 15 secret 5 $1$CJ6q$Qd5TCnrjbLVDyCZu3MvC90
    !
    !
    !
    !
    !
    !
    interface Embedded-Service-Engine0/0
     no ip address
     shutdown
    !
    interface GigabitEthernet0/0
     description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$
     ip address 10.10.10.1 255.255.255.248
     shutdown
     duplex auto
     speed auto
    !
    interface GigabitEthernet0/1
     description $ES_LAN$
     ip address x.x.x.x 255.255.255.248
     duplex auto
     speed auto
    !
    interface ATM0/0/0
     description dsl1
     bandwidth 8000
     no ip address
     no atm ilmi-keepalive
     pvc SHS1 0/38
      encapsulation aal5mux ppp dialer
      dialer pool-member 1
     !
    !
    interface ATM0/1/0
     bandwidth 8000
     no ip address
     no atm ilmi-keepalive
     pvc SHS2 0/38
      encapsulation aal5mux ppp dialer
      dialer pool-member 1
     !
    !
    interface Dialer0
     ip address negotiated
     ip accounting output-packets
     ip nat outside
     ip virtual-reassembly in
     encapsulation ppp
     dialer pool 1
     dialer idle-timeout 0
     dialer persistent
     dialer-group 1
     ppp authentication chap callin
     ppp chap hostname [old username]
     ppp chap password 7 00171C05165A1F031C
     ppp ipcp dns request
     ppp multilink
     ppp multilink fragment disable
    !
    ip forward-protocol nd
    !
    ip http server
    ip http access-class 2
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    !
    ip route 0.0.0.0 0.0.0.0 Dialer0
    ip route 172.16.24.0 255.255.248.0 GigabitEthernet0/1
    !
    ip access-list standard TELNETGROUP
     permit x.x.x.x
     permit 172.0.0.0 0.255.255.255
    !
    access-list 1 permit 0.0.0.0 255.255.0.0
    access-list 2 permit any
    access-list 23 permit 10.10.10.0 0.0.0.7
    !
    !
    snmp-server community public RO
    snmp-server enable traps tty
    !
    control-plane
    !
    !
    banner exec ^C
    UNAUTHORISED ACCESS IS NOT PERMITTED^C
    !
    line con 0
     login local
    line aux 0
    line 2
     no activation-character
     no exec
     transport preferred none
     transport input all
     transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
     stopbits 1
    line vty 0 4
     access-class TELNETGROUP in
     password 7 105D061A1716060E1F
     login local
     transport input ssh
    line vty 5 15
     access-class 23 in
     privilege level 15
     login local
     transport input telnet ssh
    !
    scheduler allocate 20000 1000
    end
    and here is the config that is running now which doesn't work however will ping 8.8.8.8 and the smoothwall:

    Code:
    1941#sh run
    Building configuration...
    
    Current configuration : 4403 bytes
    !
    ! Last configuration change at 14:19:53 UTC Wed Apr 10 2013 
    ! NVRAM config last updated at 14:19:58 UTC Wed Apr 10 2013 
    ! NVRAM config last updated at 14:19:58 UTC Wed Apr 10 2013 
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname 1941
    !
    boot-start-marker
    boot-end-marker
    !
    !
    enable secret 5 $1$fOVs$qOdYmvG2CM0.A38ylGgqP.
    !
    aaa new-model
    !
    !
    aaa authentication login default local
    !
    !
    !
    !
    !
    aaa session-id common
    !
    no ipv6 cef
    ip source-route
    ip cef
    !
    !
    !
    !
    !
    ip domain name xxxxx
    ip name-server 8.8.8.8
    ip name-server 8.8.4.4
    ip name-server 62.24.128.17
    ip name-server 62.24.128.18
    multilink bundle-name authenticated
    !
    crypto pki token default removal timeout 0
    !
    crypto pki trustpoint TP-self-signed-2726665327
     enrollment selfsigned
     subject-name cn=IOS-Self-Signed-Certificate-2726665327
     revocation-check none
     rsakeypair TP-self-signed-2726665327
    !
    !
    crypto pki certificate chain TP-self-signed-2726665327
     certificate self-signed 01
      3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
      31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
      69666963 6174652D 32373236 36363533 3237301E 170D3133 30323138 31333031
      33385A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
      4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 37323636
      36353332 3730819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
      81009C60 E1E40508 797AE4C5 D8C8445F B47E54C1 930F5503 0B5359A4 D6B42A96
      FCC5803F 4A673D82 B3D5EF6C 3B1328D2 3C87D3E4 B745B1E6 9C497721 1F240D0B
      C0A701B8 68A999A7 5A05CFDE EBC8A7D5 B52C2C1A B9165D6A 17681DA5 0CCA3395
      14406087 09CC9F7F 133281E4 ECB40CAD D4667479 3149B5D5 414D7393 5A253200
      AB770203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
      551D2304 18301680 14D6B171 5D47AC89 C99FFFE0 AA5755AB CCAC1AED 29301D06
      03551D0E 04160414 D6B1715D 47AC89C9 9FFFE0AA 5755ABCC AC1AED29 300D0609
      2A864886 F70D0101 05050003 81810095 1E85FD11 0C5435D1 854FD37F 35C162CC
      E8DFEB63 C35EA6D4 250AEAEC D67AFDFF AD16D283 646DF54A 4D0BFF35 B0187D5B
      D80AFD0C 386409DA 6432D32F 23C2B953 308CECDB D6AF3281 1B3CD6BF 9E4F2C69
      10CB0A91 20E5F591 68E3D1FE 4BEBC656 CF9A7DBA 9124C5B0 5AF87F70 53E423DB
      DE9E4DE6 FFA441D2 11CDB5F1 8E6353
            quit
    license udi pid CISCO1941/K9 sn FGL153927JM
    !
    !
    username xx password xx
    !
    !
    !
    !
    !
    !
    interface Embedded-Service-Engine0/0
     no ip address
     shutdown
    !
    interface GigabitEthernet0/0
     no ip address
     duplex auto
     speed auto
    !
    interface GigabitEthernet0/1
     description $ES_LAN$
     ip address x.x.x.x 255.255.255.248
     duplex auto
     speed auto
    !
    interface ATM0/0/0
     description Live
     no ip address
     no atm ilmi-keepalive
     pvc SHS2 0/38
      encapsulation aal5mux ppp dialer
      dialer pool-member 1
     !
    !
    interface ATM0/1/0
     description 01977684270
     bandwidth 8000
     no ip address
     shutdown
     no atm ilmi-keepalive
     pvc SHS2 0/38
      encapsulation aal5mux ppp dialer
      dialer pool-member 1
     !
    !
    interface Dialer0
     ip address negotiated
     ip accounting output-packets
     ip nat outside
     ip virtual-reassembly in
     encapsulation ppp
     dialer pool 1
     dialer idle-timeout 0
     dialer persistent
     dialer-group 1
     ppp authentication chap callin
     ppp chap hostname xxxxxxxxxx@talktalkbusiness.net
     ppp chap password xxxxxxxxxx
     ppp ipcp dns request
    !
    ip forward-protocol nd
    !
    ip http server
    ip http access-class 2
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    !
    ip route 0.0.0.0 0.0.0.0 Dialer0
    ip route 172.16.24.0 255.255.248.0 GigabitEthernet0/1
    !
    ip access-list standard TELNETGROUP
     permit x.x.x.x
     permit 172.0.0.0 0.255.255.255
    !
    access-list 1 permit 0.0.0.0 255.255.0.0
    access-list 2 permit any
    access-list 23 permit 10.10.10.0 0.0.0.7
    !
    !
    snmp-server community public RO
    snmp-server enable traps tty
    !
    !
    !
    control-plane
    !
    !
    banner exec ^CC
    UNAUTHORISED ACCESS IS NOT PERMITTED^C
    !
    line con 0
    line aux 0
    line 2
     no activation-character
     no exec
     transport preferred none
     transport input all
     transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
     stopbits 1
    line vty 0 4
     access-class TELNETGROUP in
     password 7 105D061A1716060E1F
     transport input ssh
    line vty 5 15
     access-class 23 in
     privilege level 15
     transport input telnet ssh
    !
    scheduler allocate 20000 1000
    end
    Ive tried to take out the Multilink Bundle-name authenticated but the command completes but the line doesn't remove.

    Also, i had a static IP address for the lines however i have had no paper work what so ever telling me this.

    All i had was the list of IP addresses which we own, and for some reason the ethernet connection to the smoothwall internally has a public IP as does the Smoothwall box. Could this be the problem?

    I will be really gratefull if someone could help me out as we have no internet connectivity at the mo at work.

    Thanks
    Last edited by timbo343; 10th April 2013 at 05:07 PM.

  8. #8
    timbo343's Avatar
    Join Date
    Dec 2005
    Location
    Leeds/York area, North Yorkshire
    Posts
    2,975
    Thank Post
    287
    Thanked 266 Times in 191 Posts
    Rep Power
    115
    I guess ive found out that Multilink Bundle-name authenticated is there for show.

  9. #9
    timbo343's Avatar
    Join Date
    Dec 2005
    Location
    Leeds/York area, North Yorkshire
    Posts
    2,975
    Thank Post
    287
    Thanked 266 Times in 191 Posts
    Rep Power
    115
    GULP! HELP!! Anyone??

    Ok so i have plugged in my router from home and seen i get an IP from talktalk of 92.19.215.1. My cisco 1941 router when connected will talk to the outside world however im not sure what IP address this is getting from my ISP. Im also not sure what my IP address was before i moved to talktalkbusiness.

    My router's ethernet connection to the smoothie was 84.12.68.105 and the smoothies IP address was 84.12.68.107. The router when plugged in cannot see 84.12.68.105 as it says reverse lookup failed. I have a bank of public IP addresses as we host exchange inside and again these are not working.

    When i do i traceroute to 84.12.68.107 i am getting a result of 85.210.255.2. Before all this, i think (even though i said i didnt know what my ip address was) 82.133.96.211 was my static IP as this translated to shs3.gotadsl.co.uk which possibly meant that my bank of IP addresses would work.

    When i now do a speedtest i get 92.19.215.1 but before i got 84.12.68.107.

    Is that right or am i going off at a tangent?
    Last edited by timbo343; 11th April 2013 at 10:09 AM.

  10. #10
    timbo343's Avatar
    Join Date
    Dec 2005
    Location
    Leeds/York area, North Yorkshire
    Posts
    2,975
    Thank Post
    287
    Thanked 266 Times in 191 Posts
    Rep Power
    115
    OK, it turns out moving from a tiscali network to a talktalk network they have removed our static IP Addresses.... great!

SHARE:
+ Post New Thread

Similar Threads

  1. Replies: 19
    Last Post: 5th December 2008, 12:26 PM
  2. Replies: 12
    Last Post: 29th September 2008, 10:57 AM
  3. HELP "Username and password do not match"
    By dhasmet in forum EduGeek Joomla 1.5 Package
    Replies: 3
    Last Post: 3rd August 2008, 09:40 AM
  4. sending username and password via post
    By RabbieBurns in forum How do you do....it?
    Replies: 13
    Last Post: 17th June 2008, 10:31 PM
  5. Replies: 3
    Last Post: 17th October 2007, 09:15 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •