+ Post New Thread
Results 1 to 4 of 4
Internet Related/Filtering/Firewall Thread, Squid Proxy. Forward IP of computer and not proxy? in Technical; Hi, Ive setup squid proxy in a Ubuntu virtual machine and websites are accessible. The problem we have is that ...
  1. #1

    Join Date
    Nov 2011
    Posts
    628
    Thank Post
    87
    Thanked 21 Times in 19 Posts
    Rep Power
    10

    Squid Proxy. Forward IP of computer and not proxy?

    Hi,

    Ive setup squid proxy in a Ubuntu virtual machine and websites are accessible.

    The problem we have is that the squid proxy isnt passing on the ip address of the client machine.

    This causes issues with filtering as the LEA gives us two IP address ranges. One for the pupil filter and the other for staff.

    Is it possible to forward the clients IP address rather than the proxy server address? I've read about x-forwarded but cant get my head round it.

    The other issue is that the virtual host, virtual adapter, and virtual machine are all on the staff range but the filter still seems to be set on the pupil filter on the other range. Is there another ip address that you can think of? Firefox inside the Virtual uses the staff filter which is the weird thing.

    Thanks
    Last edited by dany2010; 26th October 2012 at 02:43 PM.

  2. #2
    Duke5A's Avatar
    Join Date
    Jul 2010
    Posts
    806
    Thank Post
    83
    Thanked 132 Times in 115 Posts
    Blog Entries
    8
    Rep Power
    32
    That's great that you got it working; now comes the fun part of tweaking it!

    As far as version 3.0 is concerned, it is Squid's default behavior to pass on the internal client's address onto the cache peer (upstream proxy) unless it is explicitly disabled. Does your LEA give you one proxy only and traffic filtered differently based on originating address?

    Wait a sec, you're running Dans Guardian right? If so, Dan's gets the request first, passes it to Squid, and Squid in turn passes it to the LEA proxy. Unless Dan's is also setup for x-forwarding then the LEA is only seeing the IP address of your proxy as the origination for the request.

    Try dropping these lines in your Dans config file.

    Code:
    forwardedfor = on
    usexforwardedfor = on
    You may have to read up on it a bit more since I don't use DG, but if you are this is most likely the cause of your x-forwarding issue.

  3. Thanks to Duke5A from:

    dany2010 (29th October 2012)

  4. #3

    Join Date
    Nov 2011
    Posts
    628
    Thank Post
    87
    Thanked 21 Times in 19 Posts
    Rep Power
    10
    Brill, thanks.

    Will give it a go Monday.

    Yeah we have the one proxy and it depends on the range of the computer as to which filter you get.

    Just reading about how to that with dansguardian here
    group_configuration | DansGuardian Documentation Wiki

  5. #4

    Join Date
    Nov 2011
    Posts
    628
    Thank Post
    87
    Thanked 21 Times in 19 Posts
    Rep Power
    10
    Perfect.

    Problem solved.

    Thanks again

SHARE:
+ Post New Thread

Similar Threads

  1. Replies: 4
    Last Post: 18th July 2012, 02:26 PM
  2. GPO does not apply on one model of computer
    By netadmin in forum Windows
    Replies: 14
    Last Post: 15th April 2010, 07:45 PM
  3. Broadband Speed and # of Computers
    By ictstbenedicts in forum Wireless Networks
    Replies: 21
    Last Post: 13th October 2008, 01:42 PM
  4. Age of Computer for Teaching and learning?
    By nicholab in forum Hardware
    Replies: 12
    Last Post: 7th October 2007, 08:54 PM
  5. Squid and RM proxies
    By HodgeHi in forum Wireless Networks
    Replies: 6
    Last Post: 1st November 2006, 11:02 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •