+ Post New Thread
Results 1 to 5 of 5
How do you do....it? Thread, Configuring regional settings for all users in Live@edu in Technical; Hi guys, Another live@edu query for you: How do you set the regional and time options for all users? I've ...
  1. #1

    Join Date
    Feb 2007
    Posts
    313
    Thank Post
    93
    Thanked 25 Times in 22 Posts
    Rep Power
    22

    Configuring regional settings for all users in Live@edu

    Hi guys,

    Another live@edu query for you:

    How do you set the regional and time options for all users? I've tried following James Marshall's detailed instructions from his live@edu blog, but I must be missing something.

    I've attached a screenshot of the error.

    Many thanks for your help.
    Attached Images Attached Images

  2. #2

    Join Date
    Feb 2007
    Posts
    313
    Thank Post
    93
    Thanked 25 Times in 22 Posts
    Rep Power
    22
    Just to follow this up, the issue is due to the absence of the following parameters “DateFormat” and “TimeFormat” in the PowerShell command.

  3. #3
    jamesbmarshall's Avatar
    Join Date
    Feb 2010
    Location
    Reading, UK
    Posts
    499
    Thank Post
    25
    Thanked 222 Times in 153 Posts
    Rep Power
    83
    Quote Originally Posted by dgardner View Post
    Just to follow this up, the issue is due to the absence of the following parameters “DateFormat” and “TimeFormat” in the PowerShell command.
    That's not technically true...

    Code:
    Get-Mailbox –Resultsize unlimited | Set-MailboxRegionalConfiguration –Language en-gb –TimeZone "GMT Standard Time"
    This little bit of PS works just fine - in your original post there is an extra space, so it's reading "Get-Mailbox - Resultsize..." which is wrong. That's a typo on the blog as well, but a quick bit of debugging would've picked that up!

    I'll correct the typo in the post.

  4. Thanks to jamesbmarshall from:

    Gardinho (3rd November 2011)

  5. #4

    Join Date
    Feb 2007
    Posts
    313
    Thank Post
    93
    Thanked 25 Times in 22 Posts
    Rep Power
    22
    Quote Originally Posted by jamesbmarshall View Post
    That's not technically true...

    Code:
    Get-Mailbox –Resultsize unlimited | Set-MailboxRegionalConfiguration –Language en-gb –TimeZone "GMT Standard Time"
    This little bit of PS works just fine - in your original post there is an extra space, so it's reading "Get-Mailbox - Resultsize..." which is wrong. That's a typo on the blog as well, but a quick bit of debugging would've picked that up!

    I'll correct the typo in the post.
    Here is the email I received from Microsoft Support (Who were excellent, might I add):

    I referred to the screenshot of the error and run similar tests on my domain. I figured that the issue is due to the absence of the following parameters “DateFormat” and “TimeFormat” in the PowerShell command.

    The following command should work fine:
    Get-Mailbox –Resultsize unlimited | Set-MailboxRegionalConfiguration -Language "en-gb" -TimeZone "GMT Standard Time" -DateFormat "dd/MM/yy" -TimeFormat "HH:mm"

    DateFormat - "dd/MM/yyyy, dd/MM/yy, d/M/yy, d.M.yy, yyyy-MM-dd"
    TimeFormat - "HH:mm, H:mm, hh:mm tt, h:mm tt"

    However, I would suggest you to test the command for a single user using the following command:
    Set-MailboxRegionalConfiguration –identity username -Language "en-gb" -TimeZone "GMT Standard Time" -DateFormat "dd/MM/yy" -TimeFormat "HH:mm"

    Username – DisplayName or Email address of the user.

    Verify the results using the following command:
    Get-MailboxRegionalConfiguration username

  6. #5
    jamesbmarshall's Avatar
    Join Date
    Feb 2010
    Location
    Reading, UK
    Posts
    499
    Thank Post
    25
    Thanked 222 Times in 153 Posts
    Rep Power
    83
    Quote Originally Posted by dgardner View Post
    Here is the email I received from Microsoft Support (Who were excellent, might I add)
    I'm glad support were excellent!

    Quote Originally Posted by dgardner View Post
    I figured that the issue is due to the absence of the following parameters “DateFormat” and “TimeFormat” in the PowerShell command
    Not in this case. Indeed, adding those parameters is possible for the command to still work, but the error in your screen shot clearly states that it cannot find a parameter to bind the argument "Resultsize" to. This is because there's a superfluous space between "-" and "resultsize". I have since gone back, pasted the exact bit of code from my blog into PS and tested it, reproduced the error, removed the space, and found that the code works as intended.

    The extra parameters for DateFormat and TimeFormat shouldn't be needed if you just want to overcome the first-login regional settings screen, but you can be all means include them anyway. The bit of code I posted up is designed to be run so that your end users don't have to go through the process of selecting the correct language and country, as often they accidentally make the wrong choice, or deliberately end up picking something for a laugh and then they're unable to figure out how to change it back!
    Last edited by jamesbmarshall; 3rd November 2011 at 07:53 AM. Reason: Spelling!

SHARE:
+ Post New Thread

Similar Threads

  1. Add a shared printer for all users in XP
    By R1ch in forum Windows
    Replies: 7
    Last Post: 11th November 2010, 07:09 PM
  2. How to Disable Power Settings for All Users
    By jzepeda in forum Windows
    Replies: 5
    Last Post: 27th January 2010, 10:21 AM
  3. Firefox settings for all users.
    By Dos_Box in forum Windows
    Replies: 1
    Last Post: 22nd September 2006, 01:31 PM
  4. Desktop configuration for all users.
    By Kyle in forum Windows
    Replies: 8
    Last Post: 28th January 2006, 01:27 AM
  5. Replies: 12
    Last Post: 12th September 2005, 10:47 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •